[adbe 3020027] Firefox Crash @ F18720598

RESOLVED WORKSFORME

Status

External Software Affecting Firefox
Flash (Adobe)
--
critical
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: marcia, Assigned: smadayag)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

6 years ago
Seen while reviewing the explosive report. https://crash-stats.mozilla.com/report/list?signature=npswf32_11_2_202_61.dll%400x19e5f5. I am not sure where this version is coming from since the version I get from labs.adobe.com is Version: 11.2.202.19.

https://crash-stats.mozilla.com/report/index/4e21926a-198e-4d63-bd29-fc29f2111107

Frame 	Module 	Signature [Expand] 	Source
0 	NPSWF32_11_2_202_61.dll 	NPSWF32_11_2_202_61.dll@0x19e5f5 	
1 	NPSWF32_11_2_202_61.dll 	NPSWF32_11_2_202_61.dll@0x38bbe1
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 700159
(Reporter)

Comment 2

6 years ago
Actually, not a dupe since the version is different. Sorry for the noise.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 3

6 years ago
.61 comes from the new Flash Player auto updater (since about 2011-11-05)

Comment 4

6 years ago
I have contacted one developer from Adobe to stop delivering build .61 and reported it here too:
http://forums.adobe.com/thread/922370
(Reporter)

Comment 5

6 years ago
#42 top crash in Firefox 8 Beta 6.
Status: REOPENED → NEW

Comment 6

6 years ago
Hi Marcia,
Do you have the dump file of this crash? Or any reproducing steps for this crash is helpful!
Thanks!

Comment 7

6 years ago
Tracking this in internal bug#3021553
(Reporter)

Comment 8

6 years ago
I am trying to get the .61 version from the updater but I seem to be stuck on Version: 11.2.202.18 on Win XP even though I have the correct update settings. Maybe I have not got the ping yet or .61 is not being offered?

There are no comments in the crash reports and I will have to see if can get some URLs. But the volume seems high (1,455 Crash Reports in the last week) for a version that has not even been shipped yet.
 
(In reply to yzhou from comment #6)
> Hi Marcia,
> Do you have the dump file of this crash? Or any reproducing steps for this
> crash is helpful!
> Thanks!
(Reporter)

Comment 9

6 years ago
Also it looks as if the lion's share of the crashes are hitting Win XP users.

Comment 10

6 years ago
Same here. I installed flash player 11.2 beta from labs.adobe.com,the version was 11.2.202.18. I'm also investigating on this right now.

Comment 11

6 years ago
Here are the .61 files for Windows (x32 & x64)
http://remixshare.com/dl/xufjl/Flash_Player_11.2.202.61_win.zip

So you don't have to wait for the auto update.

Comment 12

6 years ago
Thanks, Marcia. I'm preparing for the symbol file of 61 build now. Should I send the symbol directly to you or to other folks as usual?
(Reporter)

Comment 13

6 years ago
Please send to the others folks as they actually take care of the upload.

(In reply to yzhou from comment #12)
> Thanks, Marcia. I'm preparing for the symbol file of 61 build now. Should I
> send the symbol directly to you or to other folks as usual?

Comment 14

6 years ago
Thanks for confirming, Marcia! I've already sent out the symbol files for windows to those guys.

Updated

6 years ago
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: plugins → adobe-flash
Version: Trunk → 11.x
(Reporter)

Updated

6 years ago
Crash Signature: [@ npswf32_11_2_202_61.dll@0x19e5f5 ] → [@ npswf32_11_2_202_61.dll@0x19e5f5 ] [@ npswf32_11_2_202_61.dll@0xb1e13 ] [@ npswf32_11_2_202_61.dll@0x43942e ] [@ npswf32_11_2_202_61.dll@0xb0ab4 ] [@ npswf32_11_2_202_61.dll@0xb0b12 ] [@ npswf32_11_2_202_61.dll@0xb152e ]
(Reporter)

Comment 15

6 years ago
This signature is showing as being a bit high in the latest Firefox 8 explosive report:

https://crash-analysis.mozilla.com/rkaiser/2011-11-07/2011-11-07.firefox.8.explosiveness.html

Is this update still being served automatically?

Comment 16

6 years ago
(In reply to Marcia Knous [:marcia] from comment #15)
> Is this update still being served automatically?

It seems so:
https://fpdownload.macromedia.com/pub/flashplayer/update/current/sau/11/xml/version.xml

Comment 17

6 years ago
I've got a feeling the crashes are linked to the excessive memory use im seeing in this version of flash.

A recent bug fix in plugin container resulted in 11.x properly releasing memory when the applet / page was closed, but 11.2b61 seems to have brought it back for revenge.

simply opening a few 5-12minute dailymotion video's is locking the container up at 800MB, and then a few more takes it even higher. It might be hitting the 2GB allocation limit on x32 os's, and i can even make it hit the 4GB LAA limit on x64 if i try hard enough.

Comment 18

6 years ago
and given the virtual allocation is approximately 1.5x the private bytes, its already hitting close to 1.7GB by the time its at 1.1GB private :|
(Reporter)

Comment 19

6 years ago
This signature is showing up in the explosive report: https://crash-analysis.mozilla.com/rkaiser/2011-11-13/2011-11-13.firefox.9.explosiveness.html. 2,854 Crash Reports in the last week across all versions.

Comment 20

6 years ago
Yes, its a high level memory leak which is hitting the 32bit virtual allocation limit and generating a memory exception as a result.
(Assignee)

Comment 21

6 years ago
tracking internally as #3020027.

after reprocess in sorroco, signature resolved to F18720598__________________________________________________
Assignee: nobody → smadayag
Status: NEW → ASSIGNED
Summary: Firefox Crash @ npswf32_11_2_202_61.dll@0x19e5f5 → [adbe 3020027] Firefox Crash @ npswf32_11_2_202_61.dll@0x19e5f5
(Reporter)

Updated

6 years ago
Crash Signature: [@ npswf32_11_2_202_61.dll@0x19e5f5 ] [@ npswf32_11_2_202_61.dll@0xb1e13 ] [@ npswf32_11_2_202_61.dll@0x43942e ] [@ npswf32_11_2_202_61.dll@0xb0ab4 ] [@ npswf32_11_2_202_61.dll@0xb0b12 ] [@ npswf32_11_2_202_61.dll@0xb152e ] → [@ npswf32_11_2_202_61.dll@0x19e5f5 ] [@ npswf32_11_2_202_61.dll@0xb1e13 ] [@ npswf32_11_2_202_61.dll@0x43942e ] [@ npswf32_11_2_202_61.dll@0xb0ab4 ] [@ npswf32_11_2_202_61.dll@0xb0b12 ] [@ npswf32_11_2_202_61.dll@0xb152e ] [@ F18720598______…

Updated

6 years ago
Summary: [adbe 3020027] Firefox Crash @ npswf32_11_2_202_61.dll@0x19e5f5 → [adbe 3020027] Firefox Crash @ npswf32_11_2_202_61.dll@0x19e5f5 (F18720598__________________________________________________)

Comment 22

6 years ago
More reports at:
https://crash-stats.mozilla.com/report/list?signature=F18720598__________________________________________________

It seems to be fixed from Flash 11.2.203.96.
Status: ASSIGNED → RESOLVED
Crash Signature: [@ npswf32_11_2_202_61.dll@0x19e5f5 ] [@ npswf32_11_2_202_61.dll@0xb1e13 ] [@ npswf32_11_2_202_61.dll@0x43942e ] [@ npswf32_11_2_202_61.dll@0xb0ab4 ] [@ npswf32_11_2_202_61.dll@0xb0b12 ] [@ npswf32_11_2_202_61.dll@0xb152e ] [@ F18720598______… → [@ F18720598__________________________________________________ ]
Last Resolved: 6 years ago6 years ago
Resolution: --- → WORKSFORME
Summary: [adbe 3020027] Firefox Crash @ npswf32_11_2_202_61.dll@0x19e5f5 (F18720598__________________________________________________) → [adbe 3020027] Firefox Crash @ F18720598

Comment 23

2 years ago
Version and milestone values are being reset to defaults as part of product refactoring.
Version: 11.x → unspecified
You need to log in before you can comment on or make changes to this bug.