Content in columns larger than column width should be clipped

RESOLVED DUPLICATE of bug 372053

Status

()

Core
Layout
P3
normal
RESOLVED DUPLICATE of bug 372053
6 years ago
4 years ago

People

(Reporter: jwir3, Assigned: jwir3)

Tracking

(Blocks: 1 bug, {css3})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [css3-multicol], URL)

(Assignee)

Description

6 years ago
An image that is larger than the calculated column width in a multicol layout needs to be clipped. Currently, we don't do any clipping, and thus the column width is disregarded for images larger than the max width calculated. The images overlay columns when they shouldn't.
In particular, http://dev.w3.org/csswg/css3-multicol/#overflow-inside-multicol-elements says:

  Content in the normal flow that extends into column gaps (e.g., long words or images) is
  clipped in the middle of the column gap.
(Assignee)

Comment 2

6 years ago
(In reply to David Baron [:dbaron] from comment #1)
> In particular,
> http://dev.w3.org/csswg/css3-multicol/#overflow-inside-multicol-elements
> says:
> 
>   Content in the normal flow that extends into column gaps (e.g., long words
> or images) is
>   clipped in the middle of the column gap.

So, just to be clear - this means we should allow the content to extend into the column gap (i.e. for a given column, there would then be no gap on one side), but clip it at the center?
(Assignee)

Updated

6 years ago
Priority: -- → P3
(Assignee)

Comment 3

5 years ago
In the w3c multicolumn tests, this is block-clip-001.xht. We're failing this test right now because we don't clip content that is too large in the inline direction for a column.
Summary: Images larger than column width should be clipped → Content in columns larger than column width should be clipped
This spec is really quite weird, though, in that it requires normal flow content but not other content to be clipped.  That should probably be clarified, both in terms of whether it's desirable and what exactly it means.

And doing clipping horizontally but not vertically requires a bit of care too, though it's certainly doable; just need to look at the visual overflow area of the column when constructing the clip rect in order to construct a clip rect that doesn't actually clip anything vertically.  But also perhaps worth checking that that's what's intended as well.
(Assignee)

Comment 5

4 years ago
(In reply to David Baron [:dbaron] (don't cc:, use needinfo? instead) from comment #4)
> This spec is really quite weird, though, in that it requires normal flow
> content but not other content to be clipped.  That should probably be
> clarified, both in terms of whether it's desirable and what exactly it means.
> 
> And doing clipping horizontally but not vertically requires a bit of care
> too, though it's certainly doable; just need to look at the visual overflow
> area of the column when constructing the clip rect in order to construct a
> clip rect that doesn't actually clip anything vertically.  But also perhaps
> worth checking that that's what's intended as well.

I've requested feedback from www-style on both of these issues - what to do when horizontally clipping an absolutely (or otherwise) positioned child, and vertical clipping. A link to the thread is available here:

http://lists.w3.org/Archives/Public/www-style/2013Aug/0269.html
I think we should hold off on further work on this bug until the spec becomes clearer and more reasonable:
http://lists.w3.org/Archives/Public/www-style/2013Aug/0395.html
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 372053
You need to log in before you can comment on or make changes to this bug.