Closed Bug 700369 Opened 9 years ago Closed 4 years ago

Firefox Crash @ idmmbc.dll@0xe99d with Internet Download Manager

Categories

(Firefox :: Extension Compatibility, defect)

8 Branch
x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED WONTFIX

People

(Reporter: marcia, Unassigned)

Details

(Keywords: crash)

Crash Data

Seen while looking at Firefox 8 data. Looks to be related to Internet Download Manager.

https://crash-stats.mozilla.com/report/list?signature=RtlpWaitOnCriticalSection%20|%20RtlpDeCommitFreeBlock%20|%20idmmbc.dll@0xe99d

Frame 	Module 	Signature [Expand] 	Source
0 	ntdll.dll 	RtlpWaitOnCriticalSection 	
1 	ntdll.dll 	RtlpDeCommitFreeBlock 	
2 	idmmbc.dll 	idmmbc.dll@0xe99d 	
3 	Accelerator.dll 	Accelerator.dll@0x7066b 	
4 		@0x2fb
We should contact them. They have been very responsive in the past if there's a risk that they'll get blocklisted.
Here are correlations per module version in 12.0:
  RtlpWaitOnCriticalSection | RtlpDeCommitFreeBlock | idmmbc.dll@0xe99d|EXCEPTION_ACCESS_VIOLATION_WRITE (19 crashes)
    100% (19/19) vs.   0% (419/88179) idmmbc.dll
          0% (0/19) vs.   0% (4/88179) 
          0% (0/19) vs.   0% (1/88179) 3.0.0.1
          0% (0/19) vs.   0% (1/88179) 4.0.0.1
          0% (0/19) vs.   0% (2/88179) 4.0.2.1
          0% (0/19) vs.   0% (3/88179) 5.11.0.4
          0% (0/19) vs.   0% (3/88179) 5.12.2.0
          0% (0/19) vs.   0% (7/88179) 5.12.8.0
          0% (0/19) vs.   0% (8/88179) 5.14.1.0
          0% (0/19) vs.   0% (13/88179) 5.14.5.0
          0% (0/19) vs.   0% (5/88179) 5.15.4.0
          0% (0/19) vs.   0% (23/88179) 5.15.6.0
          0% (0/19) vs.   0% (88/88179) 5.16.1.0
        100% (19/19) vs.   0% (261/88179) 5.18.2.0
Crash Signature: [@ RtlpWaitOnCriticalSection | RtlpDeCommitFreeBlock | idmmbc.dll@0xe99d ] → [@ RtlpWaitOnCriticalSection | RtlpDeCommitFreeBlock | idmmbc.dll@0xe99d] [@ RtlpWaitOnCriticalSection | EtwEventEnabled | idmmbc.dll@0xe99d] [@ RtlpWaitForCriticalSection | RtlEnterCriticalSection | idmmbc.dll@0xe99d] [@ RtlpWaitOnCriticalSection | Rt…
Component: General → Extension Compatibility
QA Contact: general → extension.compatibility
Summary: Firefox Crash @ RtlpWaitOnCriticalSection | RtlpDeCommitFreeBlock | idmmbc.dll@0xe99d → Firefox Crash @ idmmbc.dll@0xe99d with Internet Download Manager
Charles, do you still work on IDM?
Jorges,

yes, but the bug relates to obsolete versions of IDM with LSP DLL (idmmbc.dll) released before 2010, e.g. in 2008 and 2009. Customers should be advised to upgrade IDM. Note that LSP dlls are loaded by winsock and blacklisting will not help here

Charles Jones
Software engineer
This is from the IDM extension, right? Or is it just an injected DLL?

If this is an extension, we can blocklist by id and version number.
Jorge, this dll is not from IDM CC extension, it's not a part of it and it never was. It was only a part of old versions of IDM. It loads to all processes which use win sock dll: ws2_32.dll. yes, you may treat it as injected dll. But if it's not loaded correctly, it breaks the entire TCP/IP protocol stack. People who use old versions of IDM should update IDM, that's the only recommendation. If you can create an advisory information for this event/crash, please advise to update IDM

Try to search for "Layered Service Provider" in wikipedia, or better on MSDN site for more information
moreover, when IDM CC extension is working in Firefox (it's not disabled and matches version number), there will be no problems with idmmbc.dll. In all versions of idmmzcc.dll that is a part of IDM CC extension there is a GetListenerState() exported function, which returns TRUE when extension is working fine and it detects it from the first http request. In return old idmmbc.dll dlls when loaded into Firefox are searching for idmmzcc.dll in the process of Firefox, and if they find it, they use GetProcAddress and call GetListenerState. When GetListenerState returns TRUE, idmmbc.dll stops monitoring all Firefox traffic, it does nothing since it's assumed that the integration of IDM via IDM CC extension works more accurately, it's better and preferable. Note that idmmbc.dll was designed/implemented in early 2004 since IDM 4.0 and we removed it from IDM in 2009
I'm marking this bug as WONTFIX per bug #1269807.

For more information see - https://blog.mozilla.org/futurereleases/2015/10/08/npapi-plugins-in-firefox/
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.