Solaris font size's not proper

VERIFIED INVALID

Status

()

Core
Editor
P3
normal
VERIFIED INVALID
19 years ago
13 years ago

People

(Reporter: sujay, Assigned: Erik van der Poel)

Tracking

({pp})

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
using 5/24 build of apprunner

1) launch apprunner
2) launch editor from task menu
3) highlight some text
4) pull-down Format | Size and choose each size.

Notice the size's aren't set to what they're supposed to be. What I mean
is that as you go from -2 to 0 to +4, the font should increase...not the
case, its jumping back and forth from small to big...
(Reporter)

Comment 1

19 years ago
*** Bug 7009 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 2

19 years ago
*** Bug 7007 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

19 years ago
*** Bug 7008 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 4

19 years ago
okay +1, +2, +3, +4 seem to work fine...its just the -2, -1 and 0
that need to be checked out cause they don't match up..

Updated

19 years ago
Summary: Linux Font size's not proper → [PP]Linux Font size's not proper

Updated

19 years ago
Assignee: kostello → buster

Comment 5

19 years ago
This may be a layout bug: verify by creating an HTML document with each of the
font sizes set on some content and see if you are getting the same effect.

Changing assignment to buster, leaving milestone undefined

Comment 6

19 years ago
sujay, could you please try Greg's suggestion and create an HTML document test
case (not using ender) to see if it is a layout bug or an ender bug?  If the
document shows up correctly in apprunner/viewer, but ender can't create it
correctly, then we know it's an editor bug.

Comment 7

19 years ago
sujay--here is the example html source (save to a file):

<!doctype html public "-//w3c//dtd html 4.0 transitional//en">
<html>
<head>
   <meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
   <meta name="Author" content="Kathleen Brade">
   <meta name="GENERATOR" content="Mozilla/4.51 (Macintosh; U; PPC) [Netscape]">
   <title>bug6993.html</title>
</head>
<body>
<font size=-2>size -2</font>
<br><font size=-1>size -1</font>
<br>size 0
<br><font size=+1>size 1</font>
<br><font size=+2>size 2</font>
<br><font size=+3>size 3</font>
<br><font size=+4>size 4</font>
</body>
</html>
(Reporter)

Comment 8

19 years ago
okay I pulled up Kathy's test document in Ender...looks like a layout
issue...

Comment 9

19 years ago
sujay:
Akkana and I did a trivial test of this tonight and it seemed to work.  Can you
show us specifically how you get the browser and/or editor into a situation
where the fonts don't show up right?
(Reporter)

Comment 10

19 years ago
Steve, I just grabbed Akkana in my cube and showed her the problem. She
says its a problem with how Sun displays the font. I remotely log
into a Linux machine and siaply on a Sun box..

Updated

19 years ago
Assignee: buster → erik

Comment 11

19 years ago
Erik:  Peter L. thinks you're the owner of Unix font mapping issues on Unix.
This looks like a problem in that area.  Sujay verified that it has nothing to
do with the editor, it's a gecko font mapping problem on Unix.
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
OS: Linux → Solaris
Hardware: Other → Sun
Target Milestone: M10
(Assignee)

Comment 12

19 years ago
Changed platform/OS to Sun/Solaris. Marked M10 (bug fixing phase, not feature).
(Assignee)

Updated

19 years ago
Target Milestone: M10 → M12
(Assignee)

Updated

19 years ago
Summary: [PP]Linux Font size's not proper → [PP] Solaris font size's not proper
(Assignee)

Updated

19 years ago
Target Milestone: M12 → M16
(Assignee)

Comment 13

19 years ago
I tested Times fonts on Solaris, and it turns out that their actual sizes on
the screen do not increase monotonically when their advertized sizes are
sorted. This is a bug in Solaris, but it may be in lots of other Unixes too, if
the original data came from the X Consortium, so we might want to apply a
workaround. Marking M16 for now.

Updated

19 years ago
Keywords: pp
(Assignee)

Comment 14

19 years ago
Moving all M16s to M17. Please make comments if you disagree.
Target Milestone: M16 → M17

Updated

19 years ago
Summary: [PP] Solaris font size's not proper → Solaris font size's not proper
(Assignee)

Comment 15

18 years ago
This is not the kind of thing that Mozilla should be working around. The X
server vendors ought to fix their fonts. Marking INVALID.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → INVALID
(Reporter)

Comment 16

18 years ago
ok. verified in 5/25 build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.