Windows appear as solid white except for title bar

RESOLVED DUPLICATE of bug 644494

Status

()

Core
Graphics
RESOLVED DUPLICATE of bug 644494
7 years ago
6 years ago

People

(Reporter: MattN, Unassigned)

Tracking

Trunk
All
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Created attachment 572723 [details]
Attachment of white about dialog

Build: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:10.0a1) Gecko/20111107 Firefox/10.0a1 http://hg.mozilla.org/mozilla-central/rev/161c6106d787

Last week my about window appeared as solid white with only the titlebar drawn normally. Today the preferences window had the same problem.  I also see a flicker of white when windows are open even when it does eventually draw properly (Not sure if this is related).  I'm not sure if the flicker is new but the problem is that the window stays white sometimes but I can't figure out the pattern to it.  Sometimes if I close the window and re-open it from the menu it is fine.  Other times the window will be white after re-opening.

Reproducible: Intermittent
Created attachment 572724 [details]
Video of white flicker when window opens

Not sure if the flicker existed before this bug with the window remaining white.
This seems to only happen with hardware acceleration enabled. Felipe mentioned it's like another bug he's seen where clicking the mouse on the window fixes the problem and that seems to be the case here too.
Component: XUL → Graphics
QA Contact: xptoolkit.widgets → thebes

Comment 3

6 years ago
Are you still running into this? This sounds similar to Bug 603134.
(In reply to Ali Juma [:ajuma] from comment #3)
> Are you still running into this? This sounds similar to Bug 603134.

Yes, I saw this again the other day with the about window on Nightly.  The about window stayed white (not just a flicker).
FWIW, I just saw this a couple times and then it stopped happening (after I detached an external monitor) - Nightly Jan 28 2012
I'm fairly sure this is bug 644494. This is a Mac bug since I also get it with other OpenGL cocoa app such as Starcraft 2.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 644494
You need to log in before you can comment on or make changes to this bug.