Last Comment Bug 700553 - test_add_remove_dictionaries.xul silently fails with uncaught JS exception
: test_add_remove_dictionaries.xul silently fails with uncaught JS exception
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Spelling checker (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla14
Assigned To: Jesper Kristensen
:
Mentors:
Depends on:
Blocks: 702050 652494
  Show dependency treegraph
 
Reported: 2011-11-07 20:36 PST by Cameron McCormack (:heycam) (away Jun 25 – Jul 10)
Modified: 2012-04-10 08:33 PDT (History)
3 users (show)
ehsan: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
test fix (1.62 KB, patch)
2012-04-07 06:58 PDT, Jesper Kristensen
ehsan: review+
Details | Diff | Review

Description Cameron McCormack (:heycam) (away Jun 25 – Jul 10) 2011-11-07 20:36:10 PST
Due to bug 652494, test_add_remove_dictionaries.xul is failing with an caught JS exception:

spellchecker is null at chrome://mochitests/content/chrome/extensions/spellcheck/tests/chrome/test_add_remove_dictionaries.xul:22
Comment 1 :Ehsan Akhgari (busy, don't ask for review please) 2012-01-13 15:24:06 PST
Josh, do you know of somebody who can figure this out?  Might not fit the good first bug bill, but somebody who knows are testing framework and js can give it a shot I believe.  I would be happy to help.
Comment 2 Jesper Kristensen 2012-04-07 06:58:55 PDT
Created attachment 613102 [details] [diff] [review]
test fix
Comment 3 :Ehsan Akhgari (busy, don't ask for review please) 2012-04-09 12:40:18 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/38eb61d6f1e6
Comment 4 :Ehsan Akhgari (busy, don't ask for review please) 2012-04-10 08:33:01 PDT
https://hg.mozilla.org/mozilla-central/rev/38eb61d6f1e6

Note You need to log in before you can comment on or make changes to this bug.