Create mozilla.dev.general.zh discussion forum

RESOLVED DUPLICATE of bug 708511

Status

RESOLVED DUPLICATE of bug 708511
7 years ago
7 years ago

People

(Reporter: irvin, Assigned: mburns)

Tracking

Details

(Whiteboard: [waiting for Giganews and Google])

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111102223350

Steps to reproduce:

We, ppls from Taiwan community, would like to open a mailing list for developers to discussion things across all develop on mozilla platforms in Chinese (including Trad. and Simplified Chinese), such as gecko core, add-on development, b2g, and other related projects.

We think the best solution is hosting the list on Mozilla (list.mozilla.org), and we're wondering if we can open a list named "mozilla.dev.zh" or "mozilla.dev.chinese," for developers, to discuss things in Chinese?

Kenny, the contact person of W3C HTML5 Chinese SIG, can help the management of the list. 

If it's possible, what should we do to have the list?

We'd sent mail to 'mailman@lists.mozilla.org' and get no response for 10~ days, thus firing the bug.
(In reply to Irvin (MozTW) from comment #0) 
> We think the best solution is hosting the list on Mozilla
> (list.mozilla.org), and we're wondering if we can open a list named
> "mozilla.dev.zh" or "mozilla.dev.chinese," for developers, to discuss things
> in Chinese?

I would personally prefer "mozilla.dev.chinese", ".zh" is too geeky.
 
> Kenny, the contact person of W3C HTML5 Chinese SIG, can help the management
> of the list. 

I would assume this means minimal moderation. I don't expect to spend too much time on management actually (and I don't quite see why this mailing list needs to be managed), besides asking random Gecko questions being a volunteering contributor. FYI, W3C HTML5 Chinese IG is the first Chinese mailing list on lists.w3.org .


The following is the list of reasons why I want this new forum, which was sent to 'mailman@lists.mozilla.org' too, with no response:

* I believe it's been very hard for Chinese people to ever know the
existence of all the exciting and open forums, the mozilla.dev.*. This
is very unfortunate. Having this list hosted by Mozilla and listed on
[1] would improve the awareness of all other lists.
* Now that we have a Taiwan office, I believe it would benefit all
Chinese people if the engineers of the Taiwan office discuss technical
issues in a public forum from time to time, which is then indexed by the
search engines. Though as a community member, this is only my personal wish.
* The MozTW community has been maintaining a mailing list on Google
Groups, yet that is usually for event organization but not for technical
discussions. In addition to that, Google Groups are unfortunately
blocked by the China internet firewell, which makes people difficult to
get involved.
* I would really want a lightweight discussion forum for lightweight
contributor like me who can ask dumb questions in Chinese.
* Paul Rouget menton me that there are people in MoCo who can speak
Chinese and such a list welcomes them of course. We are eager to learn
technical details from them.

[1] http://www.mozilla.org/about/forums/
This is fine in principle.

Regional communities are currently going in mozilla.community.*, named after regions rather than languages - we currently have about 15 in there, see here for the list: https://www.mozilla.org/about/forums/#community-algeria

So I propose mozilla.community.china. (And people can have various opinions about the exact geographic region that covers :-) 

Gerv

Comment 3

7 years ago
The purpose of this mailing list is to help developers who reading/writing Chinese to connect more people.  Not only for people in China.  Is it possible to provide a mailing list for all people who read/write the same language?
Not sure if we "should" use mozilla.community.*, as the list is suppose to be focus on developer discussion but not for other issues (local marketing, events... etc.) IMO mozilla.dev.* would be a better name, if possible.
(In reply to Thinker Li from comment #3)
> The purpose of this mailing list is to help developers who reading/writing
> Chinese to connect more people.  Not only for people in China.  Is it
> possible to provide a mailing list for all people who read/write the same
> language?

It's not forbidden for anyone else to join the list! :-) I'm sure there are people who don't live in India but who have an interest in what goes on who are members of mozilla.community.india.

(In reply to Po-chiang Chao (Bob Chao, from moztw.org) from comment #4)
> Not sure if we "should" use mozilla.community.*, as the list is suppose to
> be focus on developer discussion but not for other issues (local marketing,
> events... etc.) IMO mozilla.dev.* would be a better name, if possible.

What happens on the list is defined by the people on it :-) If you find the traffic is too high to support everything the community wants to discuss, we can create more lists. But I think you will find that discussion will naturally diverge to other matters of interest to all Chinese-speakers, and it would be better to just embrace that right than fight it.

Gerv
(Reporter)

Comment 6

7 years ago
One of the serious problem on mozilla.community.china is the political issue, we can't just simply equal "China" to "China + Taiwan + other chinese language region", it'll gain a sovereignty problem and nobody likes that, its specially sensitive these days.

mozilla.community.chinese would be a little better for avoid the political issue, but you can't recognize it at the sight as "mailing-list for development discussion" either. General users at this region used to looking for support at the forum, not mailing-list, and I don't think there is needed for a general chinese community mailing list currently.

We want to specify the topic on the list for development discussion only. Just as you don't want the general users problem and compliant filled everywhere in bugzilla either, right?

The list's idea came from the discussion through local community and some of the Taiwan office member month ago, we agree that a Chinese specific mailing list for Mozilla development, similar to the mailing list of HTML5 Chinese interest group[1] would do good on several ways, and can encourage ppls who's not good in English to join our Mozilla Dev Community, isn't that's what we all like?

If there can't be a dev.chinese, community.dev-chinese is also acceptable for me.

[1] http://lists.w3.org/Archives/Public/public-html-ig-zh/
For language-specific lists (rather than regional ones), our practice is to use the language code. See https://www.mozilla.org/about/forums/#dev-l10n-cs for examples of us doing this. Kenny may think it's geeky, but you keep telling me this is a list for development discussion :-)

If you really want it in the dev. hierarchy, I would propose mozilla.dev.general.zh . This shows it's a general development list in Chinese.

Gerv
Status: UNCONFIRMED → NEW
Ever confirmed: true
(In reply to Gervase Markham [:gerv] from comment #5)
> What happens on the list is defined by the people on it :-) 

I agree with this statement 100%-wise. Personally, I can live with any name but I still prefer something under mozilla.dev.

> If you find the traffic is too high to support everything the community wants
> to discuss, we can create more lists. But I think you will find that discussion
> will naturally diverge to other matters of interest to all Chinese-speakers, and
> it would be better to just embrace that right than fight it.

My experience with the Chinese list on lists.w3.org is that at long as you focus on technical discussions, people who don't want to talk about technical stuff will find their home. No need to fight. The MozTW community Google Group is still there and I am sure Mozilla Online has similar community effort.

(In reply to Gervase Markham [:gerv] from comment #7)
> Kenny may think it's geeky, but you keep telling me this is a list for
> development discussion :-)

I can certainly imagine a Chinese developer who knows XPCOM but nothing about BCP 47 code. Anyway, if there are rules, we should follow them. Notice that the language codes there match those l10n efforts, and people who are interested in l10n should probably know BCP 47.

(In reply to Gervase Markham [:gerv] from comment #7)
> If you really want it in the dev. hierarchy, I would propose
> mozilla.dev.general.zh . This shows it's a general development list in
> Chinese.

I'm fine with this idea. Irvin seems fine too. I think we are more interested in getting this moving.
(Reporter)

Comment 9

7 years ago
i'm good at the suggestion, thanks Gerv
OK. Over to server-ops for mozilla.dev.general.zh.

Gerv
Assignee: gerv → server-ops
Summary: Possibility to open a "mozilla.dev.zh" or "mozilla.dev.chinese"? → Create mozilla.dev.general.zh discussion forum

Updated

7 years ago
Assignee: server-ops → mburns
(Assignee)

Updated

7 years ago
Whiteboard: [waiting for Giganews and Google]
(Assignee)

Comment 11

7 years ago
This list has been created and setup with Giganews and Google Groups.

https://lists.mozilla.org/listinfo/dev-general-zh
http://groups.google.com/group/mozilla.dev.general.zh/topics?lnk=srg
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(In reply to Michael Burns [:mburns] from comment #11)
> This list has been created and setup with Giganews and Google Groups.

Great! Thank you so much! I was gonna ask how long this would take yesterday.

But... I posted a mail to dev-general-zh and it turned that the post does showed up on mozilla.dev.general.zh but it's not archived in the Google Group. Is there anything I, as the mailing list moderator, should do to activate the Google Group (just for archiving)?
(Reporter)

Comment 13

7 years ago
mburns,

We'd find that some problem occur on the mailing lsit:

when post via mailing list and news, it doesn't archive to google group. 
when post to google group and mailing lsit, it doesn't always send to news server.

the archive function to google group is very important in such tech discussion,
could you help us to check it?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Comment 14

7 years ago
Gerv, 

Could you help us to check the above problem?
It's been another week, and we intend to launch the dev channel at mid Dec.

Irvin
Hi Irvin,

I have no ability to influence this at all :-| It's best to deal with problems in new bugs. I suggest you file a new bug in this component, assigned to server-ops@mozilla-org.bugs for triage, and CC mburns and me as well.

Gerv
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
(Assignee)

Comment 16

7 years ago
We're waiting to hear back from Google Groups admins on why posts aren't syncing correctly.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

7 years ago
Blocks: 708511
(Assignee)

Comment 17

7 years ago
Closing this ticket as we have a second, most specific bug that was opened about Google Groups not syncing with the newsgroup.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 708511
You need to log in before you can comment on or make changes to this bug.