Closed Bug 700624 Opened 9 years ago Closed 9 years ago

Treetwisties in the debugger's property view are no longer transparent

Categories

(DevTools :: General, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 700639

People

(Reporter: past, Assigned: vporof)

References

Details

Attachments

(1 file)

No description provided.
Since the last merge from fx-team the expander arrows in the property panel have been showing an ugly solid background. There was a similar bug in the style inspector recently, bug 699832.
Summary: Expander arrows → Treetwisties in the debugger's property view are no longer transparent
Attached patch WIPSplinter Review
The final patch in that bug uses a xul:hbox, but Mike had previously posted another patch that worked in an html page. I extracted the relevant parts in this patch and it seems to fix the issue, although I have made everything slightly bigger. Also, the scaling of the twisty looks too blurry now, it may be better to use the original size.
Attachment #572778 - Flags: feedback?(vporof)
Assignee: nobody → vporof
Comment on attachment 572778 [details] [diff] [review]
WIP

Review of attachment 572778 [details] [diff] [review]:
-----------------------------------------------------------------

The reason we didn't use treetwisty in the first place is that it's a bit too big for the property view and makes too much spacing between elements. Scaling, indeed, makes it blurry, so that's probably not a good way to handle this.

For a temporary solution, this is ok though.
Attachment #572778 - Flags: feedback?(vporof) → feedback+
I am merging these changes in the patch for bug 700639, since the conversion to XUL touches this part as well and is an excellent opportunity for a little style cleanup.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 700639
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.