If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

spellchecker switching from one language to another broken

RESOLVED DUPLICATE of bug 688860

Status

SeaMonkey
MailNews: Composition
RESOLVED DUPLICATE of bug 688860
6 years ago
4 years ago

People

(Reporter: u331436, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Bug Flags:
blocking-seamonkey2.0.15 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:10.0a1) Gecko/20111107 Firefox/10.0a1 SeaMonkey/2.7a1
Build ID: 20111107003001

Steps to reproduce:

I have several languages loaded in Seamonkey nightly (english US, French...).
When switching language for the spellcheck in message composition, using the "spellcheck button" down arrow to directly select the proper language, the change does not occur. 


Actual results:

The Check spelling window opens and I need to switch the language in this window to effectively switch language.


Expected results:

The spell checking change should happen directly, like it used to work in the past.
A few weeks (2-3 weeks ??) it used to work this way in the nightly / Trunk versions of Seamonkey.

Comment 1

6 years ago
Can't reproduce this. Does this happen in safe mode? Any likely looking errors in the Error Console?
(Reporter)

Comment 2

6 years ago
It does not happens in safe mode as the dictionary is disabled.
What happens (not sure I have been precise enough...) is that when switching language by clicking the down arrow of the spell button (msg composition), it opens the spellcheck box instead of just switching to the new dictionary, as it used to do.
Not sure if this behavior is now intended or not.
(Reporter)

Comment 3

6 years ago
Another issue is the switch back to another dictionary which does not happens correctly. I see the following behavior:
Both needs to be set to the same value for a proper language to be selected in the message composition:
- The chosen language ticked in the drop-down list (down arrow of spell button)
- The chosen language selected in the spellcheck box 

Note that I just went to SM nightly 2.8a1 and I am still truggling with some disable or unavailable add-ons / extensions.
(Reporter)

Comment 4

6 years ago
Error console message:

Error: uncaught exception: [Exception... "Component returned failure code: 0xc1f30001 (NS_ERROR_NOT_INITIALIZED) [nsIInlineSpellChecker.spellCheckRange]"  nsresult: "0xc1f30001 (NS_ERROR_NOT_INITIALIZED)"  location: "JS frame :: chrome://messenger/content/messengercompose/MsgComposeCommands.js :: ChangeLanguage :: line 2229"  data: no]

Comment 5

6 years ago
IanN, You were the last to touch this part of the code in Bug 686372. so CCing you.

> It does not happens in safe mode as the dictionary is disabled.
Dom, To get around this, copy the *.aff and *.dic files into the application seamonkey/dictionaries/ directory.
Flags: blocking-seamonkey2.0.15-

Comment 6

6 years ago
(In reply to Philip Chee from comment #5)
> IanN, You were the last to touch this part of the code in Bug 686372. so
> CCing you.
> 
> > It does not happens in safe mode as the dictionary is disabled.
> Dom, To get around this, copy the *.aff and *.dic files into the application
> seamonkey/dictionaries/ directory.

I touched some pref setting code, but I cannot, at the moment, see how this would cause the problem. Also the 2-3 weeks before the reporting would put it in the middle of October.
Dominique, just to confirm, could you try a nightly from after 13th September for example:
http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/2011/09/2011-09-15-00-30-51-comm-central-trunk/seamonkey-2.6a1.en-US.win32.installer.exe
or
http://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/2011/09/2011-09-15-00-30-51-comm-central-trunk/seamonkey-2.6a1.en-US.win32.zip
depending on whether you use installers or zips.

Comment 7

6 years ago
Having done a bit more digging, I suspect it may be the landing of Bug 591780 (which also happened on 13th September). By the looks of things only the mInlineSpellChecker of the editor is getting reinitialised, not the one in the subject line.
Hopefully Jesper might know a bit more about the changes and what can be done to fix the issue.
Depends on: 591780
(Reporter)

Comment 8

6 years ago
Regarding comment 5:
I tested safe mode and the dictionary switch. The problem is still there in safe mode, the spell check box appears when switching languages using the "down" arrow in message composition
- The settings showing in the "down" arrow box and the spell check need to be consistent (i.e. pointing to the same language).

Regarding comment 7: 
Yes, the subject line spellchecking is not working any more since then.

I still need to test again with the nightly dated 20110915 as suggested.
(Reporter)

Comment 9

6 years ago
Confirming that the nightly dated 20110915 has the correct (previous) behavior.

Nit: the spell button of the message composition is grayed out when the cursor is in the subject line !

Comment 10

6 years ago
(In reply to Dominique Fillon from comment #9)
> Confirming that the nightly dated 20110915 has the correct (previous)
> behavior.
> 
We do need to find a regression window so could you try 20111017. If it happens on there look at ones between that and 20110915 until you find a pair between which the regression happens. If it doesn't happen on 20111017 could you try 20111031 and if it happens on 20111031 then we have a two week window of m-c checkins to look at.
Keywords: regressionwindow-wanted
(Reporter)

Comment 11

6 years ago
I could not find a proper regression window.
In the mean time, as I upgraded to the latest 2.8a1 (nightly), I suppressed the usual addons delivered with nightlies (chatzilla, DOM inspector, etc...) because the upgrade process disabled those.

Since then, trying to find a regression window, I tested the nightlies of 20110918, 20110930, 20111017, 20111031, 20111105, 20111107 and finally 20111108, without finding back the error.

Only thing that changed prior to the regression tests seems to be the removal of those addons. 
Is there a way I could re-install those to make sure that it did not interfere with the tests ?

Comment 12

6 years ago
Either install the Addons Compatibility Reporter and disable compatibility checks, or go to about:config and create a new boolean entry:
extensions.checkCompatibility.nightly == false
(Reporter)

Comment 13

6 years ago
Mmm, even with the entry: extensions.checkCompatibility.nightly == false , and re-installing today's nightly, I don't get Chatzilla, Dom inspector, QA, etc...
I tried to check my profile and I have not found anything by the installed extensions: noscript, adblock, lightning, dictionaries.
(Reporter)

Comment 14

6 years ago
OK, I have now recovered all extensions, but the problem for opening this bug is now gone (SM 2.8a1 nightly 20111110 of today )!

Closing it as "no trouble found" ? (this one must not be closed as "resolved" !).

Sorry for all the trouble and the noise.

Comment 15

6 years ago
I did a quick skim through the conversation so I might have missed something. I am aware of one bug related to switching from one language to another (Bug 688860), and I know that bug can happen in ways that are hard to reproduce. I don't know if that is related to what is seen here.
(Reporter)

Comment 16

6 years ago
Hi Jesper,
Reviewing bug 688860, I don't see the same exact pattern. When opening two message compose windows simultaneously, I can change in one window the language and see it changed into the other (with the problem that I report here).

I did investigate further to seek for a regression window and I found that the problem occurred for me between 20111107 (nightly 2.7a1) and 20111108 (nightly 2.8a1).

Hope this helps.
(Reporter)

Comment 17

6 years ago
Seems resolved since bug 688860 is fixed ! Thanks Jesper.
The behavior is now as expected (spellchecking window opens when the language is changed).

Nit: the subject line does not trigger the spellchecking (spellcheck button grayed out, only the body of a message composition. I think this is probably another bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
(Reporter)

Comment 18

6 years ago
Seems resolved since bug 688860 is fixed ! Thanks Jesper.
The behavior is now as expected (spellchecking window opens when the language is changed).

Nit: the subject line does not trigger the spellchecking (spellcheck button grayed out, only the body of a message composition. I think this is probably another bug.
(Reporter)

Updated

6 years ago
Resolution: INVALID → DUPLICATE
Duplicate of bug: 688860

Updated

4 years ago
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.