Acquire deployment environment for myapps and appsync

RESOLVED INVALID

Status

P1
normal
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: ianbicking, Assigned: gozer)

Tracking

Details

(Whiteboard: server)

(Reporter)

Description

7 years ago
The appsync service needs to be deployed alongside the openwebapps /site/ files, and when going live on https://myapps.mozillalabs.com

We have one VM at apps1.vm1.labs.sjc1.mozilla.com (that is currently *not* setup as myapps.mozillalabs.com).  We should have a staging configuration at least, and ideally a development/sandbox configuration (ideally continuously deployed).
(Reporter)

Comment 1

7 years ago
Note that while we have a new server setup at myapps, we should be using a RHEL6 Services-style server, and currently we are using a server that is more appropriate for development (an Ubuntu machine that was allocated on a short schedule).
(Reporter)

Updated

7 years ago
OS: Linux → All
Priority: -- → P1
Hardware: x86 → All
Whiteboard: server
Assignee: nobody → tarek
Status: NEW → ASSIGNED
(Assignee)

Updated

7 years ago
Assignee: tarek → gozer
I've run into a problem this morning and the other fresh box you provided last night. I have added in /tmp  all the rpms for appsync in that box.

But all our packages are expecting python26

Error: Package: gunicorn-0.11.2-1moz.x86_64 (/gunicorn-0.11.2-1moz.x86_64)
           Requires: /usr/bin/python26

The box has python2.6 and python2. I've tried to add a symbolic link but it did not get fooled...

So, since python26 is what we have in RHEL6 I am wondering why it's different here.

Did you install Python 2.6 yourself ?

I am switching back to coding, but whenever you are online and pinging me, we can work on this issue and activate that box.

I don't want to do a mass renaming everywhere since RHEL6 wants 2.6 ! (note that these RPMs are built on a RHEL6 slave @ Jenkins)

I grabbed the RPMs from :

http://hudson.build.mtv1.svc.mozilla.com/view/9.%20Apps/job/Apps-Sync-RPMS-RHEL6/lastSuccessfulBuild/artifact/rpms/

and mrepo for gunicorn and nginx,
(Assignee)

Comment 3

7 years ago
(In reply to Tarek Ziadé (:tarek) from comment #2)
> I've run into a problem this morning and the other fresh box you provided
> last night. I have added in /tmp  all the rpms for appsync in that box.
> 
> But all our packages are expecting python26
> 
> Error: Package: gunicorn-0.11.2-1moz.x86_64 (/gunicorn-0.11.2-1moz.x86_64)
>            Requires: /usr/bin/python26
> 
> The box has python2.6 and python2. I've tried to add a symbolic link but it
> did not get fooled...
> 
> So, since python26 is what we have in RHEL6 I am wondering why it's
> different here.
> 
> Did you install Python 2.6 yourself ?

Problem was solved by installing a fake python26 package form the RHEL6 mozilla-services repo, it provides that symlink, and keeps everything happy.
(Assignee)

Updated

7 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
The old app sync codebase is no longer going to be supported. All resolved fixed bugs are being marked as invalid, as they no longer apply to the new apps in the cloud service.
Resolution: FIXED → INVALID
You need to log in before you can comment on or make changes to this bug.