Closed Bug 700732 Opened 8 years ago Closed 8 years ago

Firefox 10.0a1+ Crash @ mozilla::layers::SurfaceToTexture

Categories

(Core :: Graphics, defect, critical)

10 Branch
x86
Windows 7
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 715916
Tracking Status
firefox11 - ---

People

(Reporter: marcia, Assigned: joe)

Details

(Keywords: crash, regression, topcrash)

Crash Data

Low volume trunk crash which started showing up in crash stats using the 2011092800 build. There is one crash in 7.0.1 but the remainder are trunk: https://crash-stats.mozilla.com/report/list?signature=mozilla::layers::SurfaceToTexture

https://crash-stats.mozilla.com/report/index/1b405207-57a2-4835-a8c5-ddf0e2111108

Frame 	Module 	Signature [Expand] 	Source
0 	xul.dll 	mozilla::layers::SurfaceToTexture 	gfx/layers/d3d10/ImageLayerD3D10.cpp:65
1 	nspr4.dll 	PR_NewMonitor 	nsprpub/pr/src/threads/prmon.c:59
2 	mozutils.dll 	je_malloc 	memory/jemalloc/jemalloc.c:6220
3 	xul.dll 	mozilla::layers::ImageContainerD3D10::ImageContainerD3D10 	gfx/layers/d3d10/ImageLayerD3D10.cpp:102
4 	xul.dll 	mozilla::layers::CairoImageD3D10::CairoImageD3D10 	gfx/layers/d3d10/ImageLayerD3D10.h:144
5 	xul.dll 	mozilla::layers::CairoImageD3D10::SetData 	gfx/layers/d3d10/ImageLayerD3D10.cpp:469
6 	xul.dll 	nsImageFrame::GetContainer 	layout/generic/nsImageFrame.cpp:1277
7 	mozutils.dll 	arena_bin_malloc_hard 	memory/jemalloc/jemalloc.c:3841
8 	xul.dll 	nsDisplayImage::GetContainer 	layout/generic/nsImageFrame.cpp:1216
9 	xul.dll 	mozilla::`anonymous namespace'::ContainerState::ThebesLayerData::CanOptimizeImageLayer 	layout/base/FrameLayerBuilder.cpp:952
10 	mozutils.dll 	arena_malloc_small 	memory/jemalloc/jemalloc.c:4038
11 	mozutils.dll 	je_malloc 	memory/jemalloc/jemalloc.c:6220
12 	xul.dll 	mozilla::`anonymous namespace'::ContainerState::PopThebesLayerData 	layout/base/FrameLayerBuilder.cpp:964
13 	mozutils.dll 	arena_malloc 	memory/jemalloc/jemalloc.c:4100
14 	mozutils.dll 	arena_dalloc_small 	memory/jemalloc/jemalloc.c:4459
15 	xul.dll 	nsIFrame::GetView 	layout/generic/nsFrame.cpp:4032
16 	xul.dll 	nsLayoutUtils::GetCrossDocParentFrame 	layout/base/nsLayoutUtils.cpp:503
17 	mozutils.dll 	arena_malloc_small 	memory/jemalloc/jemalloc.c:4038
18 	xul.dll 	moz_cairo_matrix_multiply 	gfx/cairo/cairo/src/cairo-matrix.c:329
19 	xul.dll 	nsPresContext::GetRootPresContext 	layout/base/nsPresContext.cpp:1149
20 	xul.dll 	nsRegion::SetToElements 	gfx/src/nsRegion.cpp:286
21 	xul.dll 	nsRegion::Copy 	gfx/src/nsRegion.cpp:614
22 	xul.dll 	nsDisplaySVGEffects::GetOpaqueRegion 	layout/base/nsDisplayList.h:663
23 	xul.dll 	mozilla::`anonymous namespace'::ContainerState::ThebesLayerData::Accumulate 	layout/base/FrameLayerBuilder.cpp:1213
24 	mozutils.dll 	arena_malloc_small 	memory/jemalloc/jemalloc.c:4038
25 	xul.dll 	PL_DHashTableOperate 	obj-firefox/xpcom/build/pldhash.cpp:626
26 	mozutils.dll 	arena_malloc 	memory/jemalloc/jemalloc.c:4100
27 	mozutils.dll 	je_malloc 	memory/jemalloc/jemalloc.c:6220
28 	xul.dll 	nsTArray<mozilla::FrameLayerBuilder::Clip::RoundedRect,nsTArrayDefaultAllocator>::AppendElements<mozilla::FrameLayerBuilder::Clip::RoundedRect> 	obj-firefox/dist/include/nsTArray.h:871
29 	xul.dll 	mozilla::`anonymous namespace'::ContainerState::FindThebesLayerFor 	layout/base/FrameLayerBuilder.cpp:1253
30 	xul.dll 	nsIFrame::GetVisualOverflowRectRelativeToSelf 	layout/generic/nsFrame.cpp:4826
31 	xul.dll 	mozilla::`anonymous namespace'::ContainerState::ProcessDisplayItems 	layout/base/FrameLayerBuilder.cpp:1431
32 	xul.dll 	mozilla::FrameLayerBuilder::GetDisplayItemDataArrayForFrame 	layout/base/FrameLayerBuilder.cpp:482
33 	xul.dll 	mozilla::FrameLayerBuilder::GetOldLayerFor 	layout/base/FrameLayerBuilder.cpp:692
34 	xul.dll 	PL_DHashTableFinish 	obj-firefox/xpcom/build/pldhash.cpp:395
35 	xul.dll 	mozilla::`anonymous namespace'::ContainerState::InvalidateForLayerChange 	layout/base/FrameLayerBuilder.cpp:1452
36 	xul.dll 	mozilla::FrameLayerBuilder::Clip::Clip 	layout/base/FrameLayerBuilder.cpp:2164
37 	xul.dll 	mozilla::`anonymous namespace'::ContainerState::ProcessDisplayItems 	layout/base/FrameLayerBuilder.cpp:1331
38 	xul.dll 	mozilla::FramePropertyTable::Get 	layout/base/FramePropertyTable.cpp:105
39 	mozutils.dll 	je_malloc 	memory/jemalloc/jemalloc.c:6220
40 	mozalloc.dll 	moz_xmalloc 	memory/mozalloc/mozalloc.cpp:105
41 	xul.dll 	nsIFrame::GetOffsetToCrossDoc 	layout/generic/nsFrame.cpp:4162
42 	xul.dll 	nsTArray<nsRefPtr<mozilla::layers::Layer>,nsTArrayDefaultAllocator>::AppendElements<mozilla::layers::Layer*> 	obj-firefox/dist/include/nsTArray.h:868
43 	xul.dll 	mozilla::SetHasContainerLayer 	layout/base/FrameLayerBuilder.cpp:584
44 	xul.dll 	mozilla::FrameLayerBuilder::BuildContainerLayerFor 	layout/base/FrameLayerBuilder.cpp:1800
45 	xul.dll 	SnapBounds 	layout/base/nsDisplayList.cpp:927
46 	xul.dll 	nsDisplayList::GetBounds 	layout/base/nsDisplayList.cpp:418
47 	xul.dll 	SearchTable
Crash Signature: [@ mozilla::layers::SurfaceToTexture ]
This is happening in 10.0a2 and 11.0a1 as well, just for completeness. Also requesting tracking so we don't forget that it's on 10.
Summary: Firefox 10.0a1 Crash @ mozilla::layers::SurfaceToTexture → Firefox 10.0a1+ Crash @ mozilla::layers::SurfaceToTexture
[Triage Comment]
We'd definitely consider taking this for FF10 if a low-risk fix is identified, but this would not block shipping based upon the low crash volume.
It's #21 top browser crasher in 10.0b2 and #37 in 11.0a2.
Version: Trunk → 10 Branch
It's #19 top crasher in 10.0b3.
Keywords: topcrash
Tracking now that this is a top crasher. Also sending over to help find an assignee for this tracked bug.
Assignee: nobody → joe
This is a Windows version of bug 715916, I'm almost certain.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 715916
You need to log in before you can comment on or make changes to this bug.