Plugin check site incorrectly indicates (outdated) Flash is installed.

RESOLVED DUPLICATE of bug 734674

Status

RESOLVED DUPLICATE of bug 734674
7 years ago
6 years ago

People

(Reporter: ddj, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 572948 [details]
Screen Shot 2011-11-08 at 3.33.19 PM

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_2) AppleWebKit/534.51.22 (KHTML, like Gecko) Version/5.1.1 Safari/534.51.22

Steps to reproduce:

I went to the plugin check URL using both Safari and Firefox on MacOS.

http://www.mozilla.org/en-US/plugincheck/


Actual results:

It reported:

For your safety, Firefox has disabled your outdated version of Flash. Please upgrade to the latest version.

...even under Safari.


Expected results:

It should have correctly seen that I do not have Flash installed at all, at least under Safari (where it knew it wasn't Firefox).  For a few minutes, I was in a panic thinking that something had installed Flash on my system without my knowing about it.
Another symptom of the same bug: after uninstalling Flash the plugin-check page says:

“Missing FLASH? For your safety, Firefox has disabled your outdated version of Flash. Please upgrade to the latest version.”

The page assumes if it can't detect Flash that Flash is (1) installed, (2) disabled, (3) by Firefox, (4) because it's unsafe. That's four assumptions.

Also, “Mozilla's mission is to promote openness, innovation and opportunity on the web.” Promoting closed-source software to users who have deliberately uninstalled it seems to me to be the opposite of promoting openness and innovation.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

7 years ago
This is the same bug as https://bugzilla.mozilla.org/show_bug.cgi?id=734674

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 734674
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.