Wrong buttons whether to send email confirmation or not

RESOLVED FIXED in 1.9.1

Status

Calendar
Dialogs
RESOLVED FIXED
6 years ago
4 years ago

People

(Reporter: hub, Assigned: Decathlon)

Tracking

Lightning 1.0b7
1.9.1

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Created attachment 572952 [details]
screenshot of the dialog.

I accepted a meeting invite.

I got the message "Would you like to send out notification E-Mail now?" with the two buttons [Cancel] [OK].

This is confusing. Buttons should be [No] [Yes].

See screenshot.

Updated

6 years ago
Summary: Wrong buttons when whether to send email confirmation or not. → Wrong buttons whether to send email confirmation or not

Comment 1

6 years ago
I totally agree with that !

Comment 2

6 years ago
Problem still there in 1.2b3 
Can you please have a look at it ?
Thanks

Updated

5 years ago
Duplicate of this bug: 832089
(Assignee)

Comment 4

5 years ago
Created attachment 708787 [details] [diff] [review]
patch - v1

This patch should fix.
Assignee: nobody → bv1578
Status: NEW → ASSIGNED
Attachment #708787 - Flags: review?(matthew.mecca)
Comment on attachment 708787 [details] [diff] [review]
patch - v1

Review of attachment 708787 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. r=mmecca

::: calendar/itip/calItipEmailTransport.js
@@ +214,5 @@
> +                                              null,
> +                                              null,
> +                                              null,
> +                                              cal.calGetString("lightning", "imipSendMail.Outlook2000CompatMode.text", null, "lightning"),
> +                                              inoutCheck) != 0) {

Since a return value of zero evaluates to false, and non-zero values to true, you can just use:

if (Services.prompt.confirmEx(...))

instead of:

if (Services.prompt.confirmEx(...) != 0)
Attachment #708787 - Flags: review?(matthew.mecca) → review+
(Assignee)

Comment 6

4 years ago
(In reply to Matthew Mecca [:mmecca] from comment #5)
 
> Since a return value of zero evaluates to false, and non-zero values to
> true, you can just use:
> 
> if (Services.prompt.confirmEx(...))

Corrected in the changeset.

Pushed to comm-central: http://hg.mozilla.org/comm-central/rev/49fedca3c4b6
(Assignee)

Updated

4 years ago
Attachment #708787 - Flags: approval-calendar-release?(philipp)
Attachment #708787 - Flags: approval-calendar-beta?(philipp)
Attachment #708787 - Flags: approval-calendar-aurora?(philipp)
(Assignee)

Comment 7

4 years ago
Matthew, could you also approve the other branches? ;)
OS: Linux → All
Hardware: x86_64 → All
Target Milestone: --- → 2.3
Attachment #708787 - Flags: approval-calendar-release?(philipp)
Attachment #708787 - Flags: approval-calendar-release+
Attachment #708787 - Flags: approval-calendar-beta?(philipp)
Attachment #708787 - Flags: approval-calendar-beta+
Attachment #708787 - Flags: approval-calendar-aurora?(philipp)
Attachment #708787 - Flags: approval-calendar-aurora+
Pushed to:
comm-aurora - https://hg.mozilla.org/releases/comm-aurora/rev/06f49a35fc65
comm-beta - https://hg.mozilla.org/releases/comm-beta/rev/6f3f31d3b381
Whiteboard: [wanted-1.9.x]
Target Milestone: 2.3 → 2.1
comm-esr17 - https://hg.mozilla.org/releases/comm-esr17/rev/5ef751e0f2fe
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Target Milestone: 2.1 → 1.9.1
Whiteboard: [wanted-1.9.x]
You need to log in before you can comment on or make changes to this bug.