Register Fennec to make use of the Android speech recognition service

RESOLVED DUPLICATE of bug 774309

Status

()

P5
normal
RESOLVED DUPLICATE of bug 774309
7 years ago
6 years ago

People

(Reporter: aaronmt, Unassigned)

Tracking

({access})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Currently when you tap and hold your devices search button when focused on the awesome bar, you invoke the Google Speech service, but the query is redirected to the stock browser.

It would be nice to be able to register Fennec as a recognizer of this service, and direct input to the URL Bar.

http://developer.android.com/reference/android/speech/RecognizerIntent.html
http://developer.android.com/resources/articles/speech-input.html
http://developer.android.com/resources/samples/ApiDemos/src/com/example/android/apis/app/VoiceRecognition.html

Updated

7 years ago
Priority: -- → P5
http://stackoverflow.com/questions/2215004/android-how-to-disable-long-press-on-search-button-nexus-one
+ Speech Activity will do the trick I guess. The return value can be passed to loadUri()
(Reporter)

Comment 2

6 years ago
Is this a dupe of lucas's bug of the day? http://lucasr.org/2012/12/07/featured-bug-1-in-firefox-for-android/
Flags: needinfo?(lucasr.at.mozilla)
(In reply to Aaron Train [:aaronmt] from comment #2)
> Is this a dupe of lucas's bug of the day?
> http://lucasr.org/2012/12/07/featured-bug-1-in-firefox-for-android/

Yes.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?(lucasr.at.mozilla)
Resolution: --- → DUPLICATE
Duplicate of bug: 774309
You need to log in before you can comment on or make changes to this bug.