[Firefox Live 2 Campaign] "Send" button shows "301 Moved Permanently" HTTP status code, due to redirect

VERIFIED FIXED

Status

Websites
Other
--
major
VERIFIED FIXED
7 years ago
6 years ago

People

(Reporter: stephend, Assigned: sgarrity)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 573020 [details]
Screenshot

This is a blocker until we figure out otherwise :-(

STR:

1. Load http://www.allizom.org/firefoxlive
2. Click on "Send"
3. Look at the resulting popup

Expected Results:

Post-to-Facebook snippet with the right content

Actual Results:

See screenshot; we show a 301, instead :-(
(Reporter)

Updated

7 years ago
Blocks: 694445
This might be caused by og:url pointing to a 404 page on prod (i.e., the problem would disappear on deployment).

To confirm this suspicion, I replaced the prod URL with the stage one in r97542, then we can debug again. If Facebook likes that, we can put the prod URL back.

Also, the final bitly URL should probably point to www.mozilla.org, not just mozilla.org, to avoid one redirect.

Updated

7 years ago
Assignee: nobody → fwenzel
Here's a new bitly URL that points to www.mozilla.org (not just mozilla.org):
http://mzl.la/s2x11b 

Also, feel free to use the complete URL instead if that will help the error code and message go away:
http://www.mozilla.org/firefoxlive?WT.mc_id=fxl_fbmsg&WT.mc_ev=click

Thanks for the help with this Fred!
(Reporter)

Comment 3

7 years ago
re: comment 1:

Looks like it didn't: "The page at http://mzl.la/ttSCXP could not be reached because the server returned status code 502."
(Assignee)

Comment 4

7 years ago
We're using a URL shortener (http://mzl.la/sPo5yu) to have a short share-able URL that includes some webtrends tracking info. This shortened URL points to a longer URL at mozilla.org, which then redirects to the longer url with the www. prefix, which then gets redirected to the locale-specific URL.

It string of redirects goes something like this:

http://mzl.la/ttSCXP
http://mozilla.org/firefoxlive?WT.mc_id=fxl_fbmsg&WT.mc_ev=click
http://www.mozilla.org/firefoxlive?WT.mc_id=fxl_fbmsg&WT.mc_ev=click
http://www.mozilla.org/en-US/firefoxlive?WT.mc_id=fxl_fbmsg&WT.mc_ev=click

Each of the three redirects is a 301 ("Moved Permanently").

I could be that the Facebook widget isn't smart enough to follow ANY redirects, which means we'll have to use the full locale-specific for the Facebook URL.

It could also be something about the mzl.la URL shortener, in which case we'll should just have Facebook share the longer URL.

If we do keep the mzl.la links, we should at least have them point to the URL with the "www." prefix, to cut out one unnecessary redirect.

For now, I'll try changing the Facebook sharing link to the full un-shortened URL (without the locale) and we'll see if that clears things up in the widget.
(Assignee)

Comment 5

7 years ago
I should have refreshed before posting...
Actually it seems to redirect one more time: It adds a trailing slash.

Also, it doesn't seem to be fixed, and the Facebook linter is not refreshing its cache, so I am going to put the URL from comment 2 back.
All right, removed the "Send" button as a stopgap fix for the broken opengraph data.

Dev: r97545
Stage: r97546

Over to Stephen for a fix after release. When re-enabling the button, please also make sure it redirects as little as possible. (Supposedly, redirects are fine, and I think they should be, or FB would lock themselves out of all the URL shorteners, which is unlikely).
Assignee: fwenzel → steven
Severity: blocker → major
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

6 years ago
Project's gone; verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.