Last Comment Bug 700993 - Chrome tabs broken after landing of bug 677421
: Chrome tabs broken after landing of bug 677421
Status: RESOLVED FIXED
: regression
Product: Thunderbird
Classification: Client Software
Component: Mail Window Front End (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: Thunderbird 11.0
Assigned To: Jonathan Protzenko [:protz]
:
Mentors:
Depends on:
Blocks: 677421
  Show dependency treegraph
 
Reported: 2011-11-09 05:06 PST by Jonathan Protzenko [:protz]
Modified: 2011-11-21 01:04 PST (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
+
fixed


Attachments
Patch (971 bytes, patch)
2011-11-09 05:06 PST, Jonathan Protzenko [:protz]
squibblyflabbetydoo: review+
standard8: approval‑comm‑aurora+
Details | Diff | Review

Description Jonathan Protzenko [:protz] 2011-11-09 05:06:53 PST
Created attachment 573162 [details] [diff] [review]
Patch

Opening chrome tabs is broken. shouldSwitchTo expects a contentPage property, when forwarding the call from the chrome tab type, the parameter is named chromePage, not contentPage.
Comment 1 Jim Porter (:squib) 2011-11-09 09:47:02 PST
Comment on attachment 573162 [details] [diff] [review]
Patch

Good catch! This looks ok to me, assuming you've tested that it works.
Comment 2 Jonathan Protzenko [:protz] 2011-11-10 01:07:59 PST
Yep. Tested that it works :). Thanks for the quick review!

http://hg.mozilla.org/comm-central/rev/b09edfb0a96b
Comment 3 Jonathan Protzenko [:protz] 2011-11-19 12:05:47 PST
http://hg.mozilla.org/releases/comm-aurora/rev/5de7b954c1eb

Mark, can you make sure I did the right things with flags? Thanks :)
Comment 4 Mark Banner (:standard8) 2011-11-21 01:04:14 PST
(In reply to Jonathan Protzenko [:protz] from comment #3)
> Mark, can you make sure I did the right things with flags? Thanks :)

Leave the tracking alone, just mark the status as fixed (its only if tracking ver == trunk ver that I tend to cancel that flag due to the tools being not quite good enough).

Note You need to log in before you can comment on or make changes to this bug.