Message counts don't show up

VERIFIED FIXED in M9

Status

defect
P3
normal
VERIFIED FIXED
21 years ago
11 years ago

People

(Reporter: scottputterman, Assigned: scottputterman)

Tracking

Trunk
All
Windows NT
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Perf])

Because of my fix for 7002, Message Counts no longer show up when parsing a
mailbox folder and don't get increased when copying or getting new mail. I need
a way to do this without going through OnKeyAdded.
Target Milestone: M7
QA Contact: 4080 → 4111
<I'll add this to the M6 release notes.>

Does this apply for counts for news messages also?
Yes, though I don't think it will affect IMAP since I don't think they are going
through that code path.
Here is the release note item I asked verah to include: "Due to optimizing
performance in displaying headers (bug 7002), Messenger will temporarily not
have the message counts show up in the folder pane when parsing a mailbox folder
and don't get increased when copying or getting new mail.  This also applies to
News messages.  IMAP mail may not be affected."
Target Milestone: M7 → M8
This is going to require some work from mscott, bienvenu, and myself.  We've
talked about this briefly, but I'm pretty sure this won't get done for M7 so I'm
moving to M8.
Whiteboard: [Perf]
Putting on [Perf] radar
Hmm, in today's (6/1) Win32 build, I'm able to see message counts displayed
after I've selected my IMAP inbox.
It should be only if it has an .msf file.  If you are actually parsing (at least
on Pop), it won't show up.
Status: NEW → ASSIGNED
Ok, I get this now.  Here are the steps:
1) delete all .msf files
2) Start Messenger
3) Select a folder which contains messages.
4) The ??? status changes to 0 (except on Linux, where ??? remains).  This is
true even after the folder has been completely loaded.
5) Must exit and restart Messenger to see the message counts.

But, like you mentioned, copying/moving/getting/deleting new mail does not
update the message count.

IMAP has this same problem.
Target Milestone: M8 → M9
We aren't going to be handling message counts for M8. Trying M9.
I hope we'll get this before Beta.
I still have a few more times I can put this off until we need to get worried :)
Blocks: 9161
*** Bug 9982 has been marked as a duplicate of this bug. ***
Note for verification:  Check the case for News messages also.
*** Bug 11113 has been marked as a duplicate of this bug. ***
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
I put this back in.  I hope it doesn't slow it down too much.
Depends on: 10797, 10971, 11025, 11418
1999081009M9: Win32/NT4

It seems to be working better because the number Unread and Totals update after
getting, selecting and deleting messages. I cannot verify this bug until the
problem with copying and moving no longer crashes (bug# 11025 and 11418)

Note: Need to upgrade my Linux system to 6.0. Mac is having problems displaying
messages on IMAP which also makes it difficult.
Status: RESOLVED → VERIFIED
Build 1999081608M9: Win32/NT4, Linux/Redhat 6.0, Mac 8.5.1
Verified Fixed. Tried deleting msf files, getting, moving, copying and deleting
messages and message counts were updated. For News I retrived messages and the
message counts were updated in the same session, without having to restart the
application.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.