Last Comment Bug 701083 - The Vidyo Linux client doesn't work
: The Vidyo Linux client doesn't work
Status: RESOLVED FIXED
:
Product: mozilla.org
Classification: Other
Component: Video (show other bugs)
: other
: All Linux
: -- normal with 1 vote (vote)
: ---
Assigned To: Guillermo Huerta [:guillermo]
:
Mentors:
: 772131 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-09 10:22 PST by Chris Lord [:cwiiis]
Modified: 2016-04-27 02:12 PDT (History)
51 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Ubuntu 11.10's /etc/lsb-release file (101 bytes, text/plain)
2012-02-24 17:13 PST, John Schoenick [:johns]
no flags Details
Hack to trick Vidyo into believing it is running on Ubuntu, see comments (693 bytes, text/x-c)
2012-02-24 18:13 PST, John Schoenick [:johns]
no flags Details
Arch Linux (x64) source package for vidyo desktop (1.11 KB, application/gzip)
2012-02-24 18:14 PST, John Schoenick [:johns]
no flags Details
Arch Linux (x64) source package for vidyo desktop (1.12 KB, application/gzip)
2012-02-27 09:17 PST, John Schoenick [:johns]
no flags Details

Description Chris Lord [:cwiiis] 2011-11-09 10:22:26 PST
I've never been able to take part in video conferences because the Vidyo Linux client doesn't work. I've heard the same story from all other Linux-users I've contacted.

- I load VidyoDesktop - note that I can't log in at all if I don't do this, so it's definitely being detected.

- I go to v.mozilla.com and enter my credentials. It spends a long time 'Waiting for VidyoDesktop', and then appears to log in

- I see the contacts/rooms page, with my full name at the top (which confirms that I logged in with the correct credentials)

- After a short while, a dialog appears with "Authorization problem with VidyoConferencing system. Please refresh your browser, then log back in."

Doing as it says yields the same results.

I'm running 64-bit Fedora 16, and had the same problem with 64-bit Fedora 15.
Comment 1 Lucas Rocha (:lucasr) 2011-11-09 10:26:36 PST
Exact same problem here. I'm running 32-bit Fedora 16.
Comment 2 Guillermo Huerta [:guillermo] 2011-12-01 11:57:38 PST
The Linux client is a beta that was designed more for Ubuntu.  I'll follow up with Vidyo on this.
Comment 3 John Schoenick [:johns] 2012-02-08 11:42:36 PST
The newer version of the client (2.1.0_0335) still doesn't work.

I messed with it a little via strace - it was trying to read /etc/fstab to find my root drive's UUID to generate some fingerprint. Really. So I added a dummy line there that actually included a UUID, now its failing somewhere more cryptic, and printing a 'failed to generate unique session ID' message.
Comment 4 Michael Ratcliffe [:miker] [:mratcliffe] 2012-02-20 09:34:30 PST
I have an identical problem on 32bit Fedora. Taking 5 minutes to boot into windows and then another 3 minutes to boot into Linux for daily meetings is at least 40 minutes per week.
Comment 5 John Schoenick [:johns] 2012-02-24 17:13:58 PST
Created attachment 600578 [details]
Ubuntu 11.10's /etc/lsb-release file

Well, I fixed it!

I replaced /etc/lsb-release, which holds info about the current distribution, with Ubuntu 11.10's. And Vidyo now works perfectly.

I should note that I already had a perfectly-valid /etc/lsb-release file for Arch Linux. Changing the Ubuntu file to include any other string ("Goobuntu") breaks it again.

The Vidyo client checks for the string "Ubuntu" in /etc/lsb-release, and silently fails if it is not found.

ಠ_ಠ
Comment 6 Hubert Figuiere [:hub] 2012-02-24 17:16:55 PST
This is worse than UA sniffing. *sigh*
Comment 7 John Schoenick [:johns] 2012-02-24 18:13:09 PST
Created attachment 600593 [details]
Hack to trick Vidyo into believing it is running on Ubuntu, see comments

Because I discovered other apps on my system need lsb-release, and don't feel like making everything I have installed believe my system is Ubuntu, I wrote this dirty dirty hack!

1. Install VidyoDesktop
2. Put Ubuntu's lsb-release file (attached) at /opt/vidyo/VidyoDesktop/ubuntu-lsb-release
3. Compile this with | gcc -fPIC -shared -Wl,-soname,totally-ubuntu.so -o totally_ubuntu.so totally_ubuntu.c
4. Put totally_ubuntu.so in /opt/vidyo/VidyoDesktop/
5. Run vidyo with this command | env LD_PRELOAD=totally_ubuntu.so VidyoDesktop

Note that if you have a currently non-working install you may need to delete ~/.vidyo and re-run the program (it only seems to check for ubuntu on first start)
Comment 8 John Schoenick [:johns] 2012-02-24 18:14:30 PST
Created attachment 600594 [details]
Arch Linux (x64) source package for vidyo desktop

Annnd because I spent the time making it, here's a source package for Arch linux 64bit users to install Vidyo with pacman.

Extract this somewhere, download "VidyoDesktopInstaller-sl564-TAG_VD_2_1_0_00335.rpm" to that folder, then run | makepkg -sci

It installs vidyo and my awesome/horrific hack
Comment 9 David Lawrence [:dkl] 2012-02-26 19:47:22 PST
I would like to verify that the steps in comment 7 work for me on Fedora 16.

dkl
Comment 10 Chris Lord [:cwiiis] 2012-02-27 02:51:31 PST
I notice we have someone with an @vidyo.com address CC'd to this bug. Is there any chance of getting a fixed version?

I'd be interested in knowing what exactly is being checked here and why, too - it could be a check for something legitimate, done in the wrong way.

Well done to John for finding and fixing this issue :)
Comment 11 Lucas Rocha (:lucasr) 2012-02-27 03:12:00 PST
Apparently, Vidyo is not offering the .rpm package anymore. Where can I get it?
Comment 12 David Lawrence [:dkl] 2012-02-27 07:22:38 PST
(In reply to Lucas Rocha (:lucasr) from comment #11)
> Apparently, Vidyo is not offering the .rpm package anymore. Where can I get
> it?

You can get them from here (VPN) : http://fs2.office.mozilla.org/IT/Vidyo/Linux/

dkl
Comment 13 Paul Rouget [:paul] 2012-02-27 08:59:21 PST
(In reply to John Schoenick [:johns] from comment #8)
> Created attachment 600594 [details]
> Arch Linux (x64) source package for vidyo desktop
> 
> Annnd because I spent the time making it, here's a source package for Arch
> linux 64bit users to install Vidyo with pacman.
> 
> Extract this somewhere, download
> "VidyoDesktopInstaller-sl564-TAG_VD_2_1_0_00335.rpm" to that folder, then
> run | makepkg -sci
> 
> It installs vidyo and my awesome/horrific hack

Thank you! You should add "rpmextract" to the dependency list.
Comment 14 Paul Rouget [:paul] 2012-02-27 09:00:43 PST
Using ArchLinux here, I can log in, but when I join a room, I see a "Now entering conference, please wait…" progress bar, and it's stuck at 16%.

http://i.imgur.com/ctrOO.png
Comment 15 Chris Arnold 2012-02-27 09:11:26 PST
The VidyoDekstop for Linux currently only is officially supporting Ubuntu v10 (10.04 and 10.10) and SL/SLC v5.5 (32 and 64bit for all).  
And only GNOME as the desktop environment for all.

Both .deb and .rpm packages are still available.

We will be expanding our support in VidyoDesktop v2.2 to: 
Ubuntu 11.10 (Ubuntu 11.04 is found to be unstable and minimum testing has been performed) 
SL/SLC v5.7.
FedoraCore 14,  FedoraCore 15
Debian 6.0.3. (Debian 5 is in process of being verified and may be added).
GNOME as the primary Desktop UI. Some testing is performed on KDE (Sharing Issues are observed and MRs are being filed)
Comment 16 John Schoenick [:johns] 2012-02-27 09:17:02 PST
Created attachment 600934 [details]
Arch Linux (x64) source package for vidyo desktop
Comment 17 John Schoenick [:johns] 2012-02-27 09:21:35 PST
@Chris - only supporting Ubuntu is one thing, but Vidyo is reading /etc/lsb-release and silently failing, with an obscure error, on other systems. A much better option would be a "Your distribution is not officially supported, you're on your own!" style message - not bailing out entirely.

For what it's worth, I can join and participate in conferences fine in my Arch Linux KDE4 environment, once I've fooled the client into trying.

@Paul - Try resetting your vidyo directory (rm ~/.vidyo), and check the log file it creates there for clues. You may be missing a dependency or something similar.
Comment 18 David Lawrence [:dkl] 2012-02-27 09:22:35 PST
I just tried it out with another attendee and with just the two of us, performance was really bad. Our voices on both ends was very crackly and frame rate was pretty bad.

Anyone who has this working on their Linux systems, how is the performance for you? 

I tried on my tablet using VidyoMobile with the same person right away, and the performance was normal and fine. 

This is with Fedora16 64bit running GnomeShell 3.2

dkl
Comment 19 John Schoenick [:johns] 2012-02-27 09:24:43 PST
It's also worth noting that the Ubuntu .deb offered through v.mozilla.com is a 32bit compile, while the rpm on fs2 is a 64bit one. Both used to be linked on v.mozilla.com, not sure why that changed.
Comment 20 Michael Ratcliffe [:miker] [:mratcliffe] 2012-02-27 10:31:01 PST
(In reply to Chris Arnold from comment #15)
> The VidyoDekstop for Linux currently only is officially supporting Ubuntu
> v10 (10.04 and 10.10) and SL/SLC v5.5 (32 and 64bit for all).  
> And only GNOME as the desktop environment for all.
> 
> Both .deb and .rpm packages are still available.
> 
> We will be expanding our support in VidyoDesktop v2.2 to: 
> Ubuntu 11.10 (Ubuntu 11.04 is found to be unstable and minimum testing has
> been performed) 
> SL/SLC v5.7.
> FedoraCore 14,  FedoraCore 15
> Debian 6.0.3. (Debian 5 is in process of being verified and may be added).
> GNOME as the primary Desktop UI. Some testing is performed on KDE (Sharing
> Issues are observed and MRs are being filed)

Here's wishing I hadn't upgraded to Fedora 16 :o/
Comment 21 Pascal Chevrel:pascalc 2012-02-27 11:24:56 PST
> We will be expanding our support in VidyoDesktop v2.2 to: 
> Ubuntu 11.10 (Ubuntu 11.04 is found to be unstable and minimum testing has
> been performed) 
> SL/SLC v5.7.
> FedoraCore 14,  FedoraCore 15
> Debian 6.0.3. (Debian 5 is in process of being verified and may be added).
> GNOME as the primary Desktop UI. Some testing is performed on KDE (Sharing
> Issues are observed and MRs are being filed)


The current available .deb packages don't even want to install for me on Ubuntu 11.10, do you have alpha/beta packages of version 2.2 I could try?
Comment 22 David Lawrence [:dkl] 2012-02-27 11:33:24 PST
(In reply to Pascal Chevrel:pascalc from comment #21)
> > We will be expanding our support in VidyoDesktop v2.2 to: 
> > Ubuntu 11.10 (Ubuntu 11.04 is found to be unstable and minimum testing has
> > been performed) 
> > SL/SLC v5.7.
> > FedoraCore 14,  FedoraCore 15
> > Debian 6.0.3. (Debian 5 is in process of being verified and may be added).
> > GNOME as the primary Desktop UI. Some testing is performed on KDE (Sharing
> > Issues are observed and MRs are being filed)
> 
> 
> The current available .deb packages don't even want to install for me on
> Ubuntu 11.10, do you have alpha/beta packages of version 2.2 I could try?

I also would love to beta test rpms for Fedora 15+ if they are available.

dkl
Comment 23 Al Billings [:abillings] 2012-02-27 11:57:18 PST
I was trying to use this on 32-bit Ubuntu 11.10 last week and it is unusable anyway. Framerate is horrible and vidyo crashes constantly. It is so unusable that I went back to my macbook.
Comment 24 Hubert Figuiere [:hub] 2012-02-27 14:19:16 PST
> > FedoraCore 14,  FedoraCore 15
> > Debian 6.0.3. (Debian 5 is in process of being verified and may be added).
> > GNOME as the primary Desktop UI. Some testing is performed on KDE (Sharing
> > Issues are observed and MRs are being filed)
> 
> Here's wishing I hadn't upgraded to Fedora 16 :o/

Could be worse. You could have hardware on which Fedora 15 fails - like I do.
Comment 25 Ben Kero [:bkero] 2012-02-28 03:21:40 PST
I got this to work by manually (on Ubuntu 12.04 64-bit) by installing:

$ rpm2cpio VidyoDesktopInstaller-sl564-TAG_VD_2_1_0_00335.rpm | cpio -idmv
$ sudo mkdir /opt/vidyo/VidyoDesktop/
$ sudo cp opt/vidyo/VidyoDesktop/* /opt/vidyo/VidyoDesktop/
$ /opt/vidyo/VidyoDesktop/VidyoDesktop

Now it should start or fail complaining that it's missing a library.  Go install those libraries!
Comment 26 Christian Holler (:decoder) 2012-03-20 06:46:05 PDT
Just as a quick hint: On Ubuntu 11.10 64 bit, I had to download one 32-bit lib manually (http://archive.ubuntu.com/ubuntu/pool/main/u/util-linux/libblkid1_2.19.1-2ubuntu3_i386.deb), unpack it manually (dpkg -x) and move the library to the /opt/vidyo directory. Application starts fine afterwards, haven't tried calling yet on this machine.
Comment 27 Chris Lord [:cwiiis] 2012-03-20 07:04:10 PDT
Just to note, although it works with these hacks, I find that the video stops updating if I'm not constantly moving my mouse over the window... No idea why this is, maybe damage-related? Need to try without a compositor to see if it makes a difference...
Comment 28 Christian Holler (:decoder) 2012-03-20 07:06:00 PDT
(In reply to Chris Lord [:cwiiis] from comment #27)
> Just to note, although it works with these hacks, I find that the video
> stops updating if I'm not constantly moving my mouse over the window... No
> idea why this is, maybe damage-related? Need to try without a compositor to
> see if it makes a difference...

I had exactly this problem already on the old laptop. I wasn't able to solve it, other than writing a script that will constantly move the mouse by +/- 1px :(
Comment 29 Chris Lord [:cwiiis] 2012-03-23 04:46:58 PDT
Just a note, you can actually just hold down a key rather than moving the mouse - a bit more comfortable :)

The problem appears to be that the event-loop is only being processed in response to input events (perhaps X events?) Maybe it was tested under a different window manager (Compiz?) that sends ping events periodically (for greying out of unresponsive windows, for example?), and so they never caught this bug?

Lots of conjecture... If only we had the source to find out...
Comment 30 Guillermo Huerta [:guillermo] 2012-03-23 10:39:26 PDT
Had a meeting with Vidyo yesterday.  They will be taking a closer look at this.
Comment 31 Al Billings [:abillings] 2012-03-23 10:40:55 PDT
"this" being "complete failure to be usable at all"?
Comment 32 Christian Holler (:decoder) 2012-04-10 12:54:40 PDT
(In reply to Chris Lord [:cwiiis] from comment #29)
> Just a note, you can actually just hold down a key rather than moving the
> mouse - a bit more comfortable :)

Here's a little more comfort:

> watch -n0.5 xdotool key --window `xdotool search --name NAME_Mozilla` r

Replace NAME by your Vidyo login name (e.g. full Mozilla LDAP login).
Comment 33 Christian Holler (:decoder) 2012-04-10 13:25:56 PDT
(In reply to Christian Holler (:decoder) from comment #32)
> 
> Replace NAME by your Vidyo login name (e.g. full Mozilla LDAP login).


Correction, it seems that this is the room name (just check the window title).
Comment 34 Mihai Sucan [:msucan] 2012-04-25 09:33:06 PDT
Neat trick with /etc/lsb-release!

Yesterday I installed the VidyoDesktop debian package offered at v.mozilla.com. It is, indeed, 32 bits only and Ubuntu 12.04 complained that the package will install code in places it should not (perhaps it did refer to /opt).

The debian package, as expected, pulled a good number of 32 bits packages, but it missed libblkid which I had to install from the Ubuntu repos as well.

VidyoDesktop now starts and "works": video is fine. Audio is very skippy, I hear robotic voices only. On startup it complains that the microphone is used by some other application.

When VidyoDesktop is running no other app can output any sounds - pulseaudio itself is locked out of access to the sound card.

Did some investigation and it looks like VidyoDesktop uses ALSA directly and it picks only the hardware devices. It doesn't list pulseaudio output as an option, nor does it respect the configs that tell the default ALSA output device. There's no obvious way to make VidyoDesktop to output sound through ALSA's pulse plugin.

On my previous machine (where I had Ubuntu 10.04) VidyoDesktop audio and video work well. However, the fact VidyoDesktop chooses to output sound directly to the selected device causes breakage: any app that tries to output sound fails to do so, or it breaks VidyoDesktop's own output.

My wishlist for VidyoDesktop: please support pulseaudio and please include a 64 bits version as well.

Thank you!
Comment 35 John Schoenick [:johns] 2012-04-25 11:00:15 PDT
@Mihai: There actually is a 64bit compile, it's just in the .rpm rather than the .deb :-/

I've had issues with robotic voices once, but after a reboot it went away. It does seem to play nice with pulse on my system, so I'm not sure why it's choosing to bypass it and take exclusive control of alsa devices for you - perhaps you're missing a 32bit libpulse or similar?
Comment 36 Chris Arnold 2012-04-26 16:48:38 PDT
We do have a 64bit .deb installer. Maybe it has just not been posted on the v.mozilla.org VidyoPortal for some reason.  

Guillermo, can you please check your portal and ensure the 64bit debian installer package is posted?
Comment 37 Chris Arnold 2012-04-26 16:51:07 PDT
For the record, Vidyo offers 4 Linux installer packages:

.deb 32bit
.deb 64bit
.rpm 32bit
.rpm 64bit
Comment 38 Matt Brubeck (:mbrubeck) 2012-04-26 16:55:37 PDT
(In reply to Chris Arnold from comment #36)
> We do have a 64bit .deb installer. Maybe it has just not been posted on the
> v.mozilla.org VidyoPortal for some reason.  

v.mozilla.org does offer an "ubuntu64" deb package, with "Architecture: amd64" but the code inside it is 32-bit and it depends on the ia32-libs package.  (It also has undeclared dependencies on one or more other 32-bit libraries, including libblkid.)

$ dpkg -e VidyoDesktopInstaller-ubuntu64-TAG_VD_2_1_0_00335.deb control
$ grep Arch control/control

Architecture: amd64

$ dpkg -x VidyoDesktopInstaller-ubuntu64-TAG_VD_2_1_0_00335.deb vidyo
$ file vidyo/opt/vidyo/VidyoDesktop/VidyoDesktop

vidyo/opt/vidyo/VidyoDesktop/VidyoDesktop: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), BuildID[sha1]=0xe2c24b18f926b6a56ad85bc1e5ffe006a1c633ee, not stripped
Comment 39 Chris Arnold 2012-04-26 17:05:06 PDT
OK, I will take this 64bit .deb installer issue up with our RnD.
Comment 40 Chris Arnold 2012-04-26 17:05:19 PDT
Regarding the issue rasied in Comment #27, whereby the client hangs unless the mouse is kept moving or the keyboard has continuous input:  

On distributions using Intel graphics running OpenGL version Mesa 7.9 or later, video rendering continually freezes. Moving the mouse cursor into the VidyoDesktop window unfreezes video for a short period. This is due to a bug in the Mesa driver described on this page:

https://bugs.freedesktop.org/show_bug.cgi?id=40372

Consequently a machine using an Intel graphics card and running Ubuntu 11.04 or 11.10 or Fedora 14 or 15 will not work with VidyoDesktop.

This is not a VidyoDesktop issue but a Xserver issue. Should be resolved in a future Ubuntu patch.
Comment 41 Mihai Sucan [:msucan] 2012-04-27 03:38:29 PDT
(In reply to John Schoenick [:johns] from comment #35)
> @Mihai: There actually is a 64bit compile, it's just in the .rpm rather than
> the .deb :-/
> 
> I've had issues with robotic voices once, but after a reboot it went away.
> It does seem to play nice with pulse on my system, so I'm not sure why it's
> choosing to bypass it and take exclusive control of alsa devices for you -
> perhaps you're missing a 32bit libpulse or similar?

Thanks for your tip! I'll need to check that.

Can you please tell me if Vidyo shows up in your volume control in the applications section? Can pulseaudio control the volume of VidyoDesktop? And can you output sounds from other apps while VidyoDesktop is connected to a room?
Comment 42 Christian Holler (:decoder) 2012-04-27 05:07:45 PDT
(In reply to Chris Arnold from comment #40)

> On distributions using Intel graphics running OpenGL version Mesa 7.9 or
> later, video rendering continually freezes. Moving the mouse cursor into the
> VidyoDesktop window unfreezes video for a short period. This is due to a bug
> in the Mesa driver described on this page

Thanks for that info. It seems that it's already fixed in upstream so that increases chances it will be fixed soon. What I wonder about is why I never hit this bug with any other application (e.g. Skype). Anyhow, until the issue is resolved, by "workaround" sending keystroke X events periodically from the background works reasonably well.
Comment 43 Chris Lord [:cwiiis] 2012-04-27 06:49:06 PDT
(In reply to Christian Holler (:decoder) from comment #42)
> (In reply to Chris Arnold from comment #40)
> 
> > On distributions using Intel graphics running OpenGL version Mesa 7.9 or
> > later, video rendering continually freezes. Moving the mouse cursor into the
> > VidyoDesktop window unfreezes video for a short period. This is due to a bug
> > in the Mesa driver described on this page
> 
> Thanks for that info. It seems that it's already fixed in upstream so that
> increases chances it will be fixed soon. What I wonder about is why I never
> hit this bug with any other application (e.g. Skype). Anyhow, until the
> issue is resolved, by "workaround" sending keystroke X events periodically
> from the background works reasonably well.

I doubt Skype uses libxcb - I don't think many things do, if I recall correctly. It should be perfectly possible to compile and install a more recent libxcb and see if this fixes it, so I'll do this next week.
Comment 44 Mihai Sucan [:msucan] 2012-04-27 12:04:05 PDT
(In reply to John Schoenick [:johns] from comment #35)
> @Mihai: There actually is a 64bit compile, it's just in the .rpm rather than
> the .deb :-/
> 
> I've had issues with robotic voices once, but after a reboot it went away.
> It does seem to play nice with pulse on my system, so I'm not sure why it's
> choosing to bypass it and take exclusive control of alsa devices for you -
> perhaps you're missing a 32bit libpulse or similar?

Just checked: I have libpulse 32 bits installed.
Comment 45 Mark Finkle (:mfinkle) (use needinfo?) 2012-05-01 08:01:25 PDT
(In reply to Ben Kero [:bkero] from comment #25)
> I got this to work by manually (on Ubuntu 12.04 64-bit) by installing:
> 
> $ rpm2cpio VidyoDesktopInstaller-sl564-TAG_VD_2_1_0_00335.rpm | cpio -idmv
> $ sudo mkdir /opt/vidyo/VidyoDesktop/
> $ sudo cp opt/vidyo/VidyoDesktop/* /opt/vidyo/VidyoDesktop/
> $ /opt/vidyo/VidyoDesktop/VidyoDesktop
> 
> Now it should start or fail complaining that it's missing a library.  Go
> install those libraries!

After following these instructions and getting the missing libraries, I get this output when trying to join a room:

mfinkle@mfinkle-VPCZ13HGX:~$ /opt/vidyo/VidyoDesktop/VidyoDesktop
main(): called getrlimit(RLIMIT_CORE, ...), return value 0, rlim_cur = 0 rlim_max = 18446744073709551615
main(): will call setrlimit(RLIMIT_CORE, ...), rlim_cur = 18446744073709551615 rlim_max = 18446744073709551615
main(): called setrlimit(RLIMIT_CORE, ...), return value 0, rlim_cur = 18446744073709551615 rlim_max = 18446744073709551615
main(): called getrlimit(RLIMIT_CORE, ...), return value 0, rlim_cur = 18446744073709551615 rlim_max = 18446744073709551615
main(): getenv( HOME ) returned /home/mfinkle 
main(): PATH_MAX = 4096 
main(): pathToLogDir = /home/mfinkle/.vidyo/VidyoDesktop/ 
main(): VidyoRect has: 0 0 0 0 
got fs = ext 4
supports ext4 get_tag_value-50-99-97-48-49-57
QLayout: Attempting to add QLayout "" to NetworkTab "Network Tab", which already has a layout
Object::connect: No such signal QMessageBox::showEvent(QShowEvent * ) in ../../Gui/Linux/VidyoDesktop.cpp:352
Object::connect:  (receiver name: 'VidyoDesktop')
VIDYO_CLIENT_PRIVATE_REQUEST_SET_LAYOUT_RECT: 5 94 800 500 
doResize 
+ClientManagerCallBack: Subscribing for conference: Dummy data endpointStatus 1 
+ClientManagerCallBack: Subscribing for conference: Dummy data endpointStatus 2 
+ClientManagerCallBack: Subscribing for conference: Dummy data endpointStatus 1 
--found Ubuntu in lsb-release
+ClientManagerCallBack: Subscribing for conference: Dummy data endpointStatus 1 
ClientManagerCallBack: Got Sign In : Dummy data 
+ClientManagerCallBack: Subscribing for conference: Dummy data endpointStatus 1 
+ClientManagerCallBack: Subscribing for conference: Dummy data endpointStatus 2 
ClientManagerCallBack: Joining conference: Dummy data 
  numProgressSteps: 6 
  caption: mfinkle@mozilla.com_Mozilla 
ClientManagerCallBack: Join Progress for conference: Dummy data 
Segmentation fault (core dumped)
Comment 46 François Marier [:francois] 2012-05-01 11:22:40 PDT
For Ubuntu 12.04 (Precise) on amd64, you need to do this after you install the package:

  cd /usr/lib/i386-linux-gnu/
  sudo ln -s /usr/lib32/libblkid.so.1 .
Comment 47 Mark Finkle (:mfinkle) (use needinfo?) 2012-05-01 11:25:11 PDT
(In reply to Mark Finkle (:mfinkle) from comment #45)
> (In reply to Ben Kero [:bkero] from comment #25)
> > I got this to work by manually (on Ubuntu 12.04 64-bit) by installing:
> > 
> > $ rpm2cpio VidyoDesktopInstaller-sl564-TAG_VD_2_1_0_00335.rpm | cpio -idmv
> > $ sudo mkdir /opt/vidyo/VidyoDesktop/
> > $ sudo cp opt/vidyo/VidyoDesktop/* /opt/vidyo/VidyoDesktop/
> > $ /opt/vidyo/VidyoDesktop/VidyoDesktop
> > 
> > Now it should start or fail complaining that it's missing a library.  Go
> > install those libraries!
> 
> After following these instructions and getting the missing libraries, I get
> this output when trying to join a room:

OK. I deleted my ~/.vidyo folder and rebooted and things seem to work fine now. Thanks!
Comment 48 Andrew Overholt [:overholt] 2012-05-16 13:45:56 PDT
I installed the 64-bit RPM on my Fedora 16 (x86_64) box today.  With John's fix above I *think* things are now working.  Thanks!  FWIW, I got the following in the yum transaction output:

  Installing : VidyoDesktop-2.1.0-00335.x86_64                              1/1
*** stack smashing detected ***: /opt/vidyo/VidyoDesktop/RunAsUser terminated

*** stack smashing detected ***: /opt/vidyo/VidyoDesktop/RunAsUser terminated
Non-fatal POSTIN scriptlet failure in rpm package VidyoDesktop-2.1.0-00335.x86_64
Start VidyoDesktop from Application --> Internet --> VidyoDesktop
VidyoDesktop has been installed in /opt/vidyo/VidyoDesktop
/opt/vidyo/VidyoDesktop/post.sh: line 2: 20767 Segmentation fault      (core dumped) /opt/vidyo/VidyoDesktop/RunAsUser /opt/vidyo/VidyoDesktop/VidyoDesktopInstallHelper
/opt/vidyo/VidyoDesktop/post.sh: line 6: 20798 Segmentation fault      (core dumped) /opt/vidyo/VidyoDesktop/RunAsUser -n /usr/bin/VidyoDesktop
warning: %post(VidyoDesktop-2.1.0-00335.x86_64) scriptlet failed, exit status 139
  Verifying  : VidyoDesktop-2.1.0-00335.x86_64                              1/1 

Installed:
  VidyoDesktop.x86_64 0:2.1.0-00335
Comment 49 Rubén Martín [:Nukeador] 2012-05-16 16:10:33 PDT
Ubuntu 12.04 64 bits here. I managed to install vidyo this way.

Download and install the deb file (accept warnings):

https://v.mozilla.com/upload/VidyoDesktopInstaller-ubuntu64-TAG_VD_2_1_0_00335.deb

Then on terminal:

cd /usr/lib/i386-linux-gnu/
sudo ln -s /usr/lib32/libblkid.so.1 .

Reboot or kill the process and run manually (/opt/vidyo/VidyoDesktop/VidyoDesktop)

I'm able to connect to a conference, video works both ways, for audio they can hear me but I get no sound.
Comment 50 Andrew Overholt [:overholt] 2012-05-25 13:23:04 PDT
I've been experiencing intermittent "pauses" where the video and audio freeze for something like 5 seconds at a time.  The people on the other end see me as frozen during these small pauses.

I'm on Fedora 16 x86_64 and using the xdo line from comment #32 so it's not that type of freeze I mean.

Does anyone else experience this?
Comment 51 François Marier [:francois] 2012-05-29 16:27:29 PDT
This is not actually a Vidyo problem, but I experienced this only while doing video chats and so it took me a long time to figure out that it had nothing to do with video drivers or Vidyo itself, but that the Microphone Mute button on my USB headset was stealing the mouse focus on Ubuntu 12.04:

  https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-evdev/+bug/1006156

(Mentioning it here since other Vidyo-on-Linux users might have run into it. It was making video chats quite a miserable experience for me.)
Comment 52 Mihai Sucan [:msucan] 2012-06-04 07:59:19 PDT
Is anyone here successfully able to use VidyoDesktop on Ubuntu 12.04? I'd like to know if yes - how did you get it to work? I have problems with audio not working, as explained in comment 34. Thank you!
Comment 53 François Marier [:francois] 2012-06-04 12:23:41 PDT
It works ok for me on Ubuntu 12.04, but to get sound working, I have to plug in a headset (built in mic doesn't work) and then open up the sound manager in gnome-control-center. In there I set output and input to the internal stuff so that nothing uses the USB headset.

Finally, I right click on the VidyoDestop icon in the notification bar and configure the audio to use the headset for both input and output.
Comment 54 Mihai Sucan [:msucan] 2012-06-04 12:35:33 PDT
Thank you François for your quick reply - much appreciated! That might work for me, indeed. However due to other constraints I need to use the builtin mic, so I can't get VidyoDesktop to work.
Comment 55 Andrew Sutherland [:asuth] 2012-06-08 14:49:16 PDT
Does screen/window sharing work for people on Ubuntu 12.04, and if so, what tricks are required?  Other people seeing me and me seeing other people works for me, but screen sharing does not.

Specifically, the default setup of composited Unity on (open source) Intel drivers does not work for me on x86_64.  I choose the option and there is some glitching like it tried to make it happen, but failed and gave up.
Comment 56 Gene Wood [:gene] 2012-06-11 17:19:28 PDT
Just wanted to confirm that comment 46 and comment 49 worked for me. This is on Ubuntu 12.04

Install the .deb package

cd /usr/lib/i386-linux-gnu/
sudo ln -s /usr/lib32/libblkid.so.1 .

video and audio work for me both ways
Comment 57 arky [:arky] 2012-06-13 15:59:16 PDT
Thanks, got this working on  Ubuntu 12.04 (i686) with 

 sudo dpkg-deb --extract  VidyoDesktopInstaller-ubuntu-TAG_VD_2_1_0_00335.deb /tmp 
 sudo cp /tmp/opt/vidyo  /opt 
 /opt/vidyo/VidyoDesktop/VidyoDesktop
Comment 58 John Karahalis [:openjck] 2012-06-25 12:10:04 PDT
Finally! Comment 56 did the trick for me. Video and audio working both ways.
Comment 59 Adam Muntner [:adamm] (use NEEDINFO) 2012-07-02 16:03:51 PDT
The Ubuntu "64-bit" package still contains 32-bit binaries. Any chance of a real 64-bit .deb package? No combination of the above advice worked, for getting the .deb package running.

I downloaded the 64-bit RPM and noticed that it has real 64-bit binaries.

VidyoDesktopInstaller-ubuntu64-TAG_VD_2_1_0_00335.deb contains:

$ file /opt/vidyo/VidyoDesktop/VidyoDesktop
/opt/vidyo/VidyoDesktop/VidyoDesktop: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), BuildID[sha1]=0xe2c24b18f926b6a56ad85bc1e5ffe006a1c633ee, not stripped

VidyoDesktopInstaller-sl564-TAG_VD_2_1_0_00335.rpm contains:

$ file opt/vidyo/VidyoDesktop/VidyoDesktop
opt/vidyo/VidyoDesktop/VidyoDesktop: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked (uses shared libs), BuildID[sha1]=0x53dd747c1984c0fdc4dcf466b8dfc2392e2522b9, not stripped

I finally got it working, but probably win the horrible kluge award in the process. Notes are below, hopefully they can save someone else some time in the future.

64-Bit Debian Wheezy report-

First just tried installing the "64-bit" .deb installer, but got "*** stack smashing detected ***" errors like Andrew did in #48, above. The totally-ubuntu.c program doesn't LD_PRELOAD since the command line built a 64-bit binary by default which can't be loaded by a 32-bit binary. So, I built a 32-bit version:

I installed the following packages:  libc6-dev-i386 ia32-libs multiarch-support and all the usual stuff needed for a gnu build environment. Then,

$ gcc -fPIC -shared  -Wl,-soname,totally-ubuntu.so -m32 -o totally_ubuntu.so totally_ubuntu.c

This seemed to work, but I looked at the console output and saw VidyoDesktop was missing libasound_module_conf_pulse.so. I hada 64-bit version installed, but that wasn't going to work, I needed the 32-bit version of the lib32asound2-plugins package.

For some reason, Wheezy doesn't have this package, so I had to do the following to install it:

add following line to sources.list
deb http://mirror.cc.columbia.edu/debian/ squeeze main
# apt-get update
# apt-get install lib32asound2-plugins
comment the line added to sources.list
# apt-get update
put the .so and the ubuntu-lsb-release file into the right place

Vidyo just gave the waiting... message. when using env to preload the 32-bit totally-ubuntu.so and start up VidyoDesktop

I decided to try the real 64-bit binaries from the .rpm on the debian system:

Dowload the rpm:
$ wget https://v.mozilla.com/upload/VidyoDesktopInstaller-sl564-TAG_VD_2_1_0_00335.rpm

unpacked the rpm:
$ rpm2cpio VidyoDesktopInstaller-sl564-TAG_VD_2_1_0_00335.rpm | cpio -vid

Then, manually copied all the files to their respective places. Debian uses os-release, not lsb-release, so I put the ubuntu lsb-release file into /etc

This actually worked on Debian Wheezy, while the .deb didn't.
Comment 60 Andrea Marchesini (:baku) 2012-07-10 05:43:10 PDT
*** Bug 772131 has been marked as a duplicate of this bug. ***
Comment 61 Trevor Norris [:tnorris] 2012-08-02 13:19:32 PDT
I'm currently running Xubuntu 12.04 on a W520 Lenovo with Optimus disabled (because it wrecks havoc) and the proprietary Nvidia drivers installed. Quickest and most reliable setup I've used so far is to do the following:

$ sudo apt-get install rpm2cpio libqtgui4
$ wget https://v.mozilla.com/upload/VidyoDesktopInstaller-sl564-TAG_VD_2_1_0_00335.rpm
$ rpm2cpio VidyoDesktopInstaller-sl564-TAG_VD_2_1_0_00335.rpm | cpio -vid
$ sudo cp -r opt/vidyo /opt

in case you've had it installed in the past:

$ rm -rf ~/.vidyo

and for convenience:

$ cd /usr/local/bin
$ sudo ln -s /opt/vidyo/VidyoDesktop/VidyoDesktop

Haven't experienced a crash or any audio/video problems so far.
Comment 62 Trevor Norris [:tnorris] 2012-08-15 10:22:18 PDT
It was working great until I updated my kernel. Now it fails. Here are the error messages:


Object::connect: No such signal QMessageBox::showEvent(QShowEvent * ) in ../../Gui/Linux/VidyoDesktop.cpp:352
Object::connect:  (receiver name: 'VidyoDesktop')

ClientManagerCallBack: Join Progress for conference: Dummy data 
Segmentation fault (core dumped)
Comment 63 Nikos Roussos [:nikos] 2012-08-27 06:21:55 PDT
Finally I got it working on Fedora using the hack from comment 5. It seems that Vidyo searches for an Ubuntu distribution.
Comment 64 Guillermo Huerta [:guillermo] 2012-08-31 14:49:45 PDT
This appears to be resolved with the upgrade.  Please reopen if you are still seeing these issues.
Comment 65 Mihai Sucan [:msucan] 2012-09-01 01:55:50 PDT
Guillermo: I still cannot use the new VidyoDesktop on Ubuntu 12.04 LTS.

I have audio problems: others can hear me, but I cannot hear what they say. All audio is very choppy/broken/robotic.

Am I missing something? What should I check?
Comment 66 Kevin Brosnan [:kbrosnan] 2012-09-04 10:40:09 PDT
This bug was largely about using Vidyo on a non Ubuntu OS. File a new bug or whatever #desktop uses these days.
Comment 67 Andrew Overholt [:overholt] 2012-09-04 11:31:24 PDT
Where can I get 64-bit RPMs of the new version?  v.mozilla.org only offers me .debs and fs2 also seems to only have the .debs.
Comment 68 Hubert Figuiere [:hub] 2012-09-04 11:53:10 PDT
Parallel: how can we get them without needing to install Flash.... (the Mac version seems to allow use of it without Flash in the browser by being stand alone like the mobile client, but I can't try on Linux)
Comment 69 Kevin Brosnan [:kbrosnan] 2012-09-04 12:05:45 PDT
(In reply to Andrew Overholt [:overholt] from comment #67)

I had to edit the download url using VidyoDesktopInstaller-sl564-TAG_VD_2_?_?_?????.rpm as the mask for 64 bit Fedora.

You can use VidyoDesktopInstaller-sl5-TAG_VD_2_?_?_?????.rpm for 32 bit Fedora.
Comment 70 Kevin Brosnan [:kbrosnan] 2012-09-04 12:11:02 PDT
(In reply to Hub Figuiere [:hub] from comment #68)

Right click on Vidyo icon select sign in. In the portal type v.mozilla.com username/password as normal. From then on (till LDAP reset) you can use right click on the Vidyo Desktop icon and choose Place Call.
Comment 71 Hubert Figuiere [:hub] 2012-09-04 12:38:42 PDT
(In reply to Kevin Brosnan [:kbrosnan] from comment #70)
> (In reply to Hub Figuiere [:hub] from comment #68)
> 
> Right click on Vidyo icon select sign in. In the portal type v.mozilla.com
> username/password as normal. From then on (till LDAP reset) you can use
> right click on the Vidyo Desktop icon and choose Place Call.

That's not the question I asked. The question I asked is where do I download the installer package for the desktop client?
Comment 72 Guillermo Huerta [:guillermo] 2012-09-04 13:04:31 PDT
I've posted the latest clients on

http://fs2.mv.mozilla.com/IT/Vidyo/Linux/

You will need to be connected on VPN to download from here.

As for the nonpackaged tars, I have asked Vidyo about this and it is with their Engineering team for a response.
Comment 73 Andrew Overholt [:overholt] 2012-09-10 07:55:31 PDT
I was able to install and run the 64-bit RPM on Fedora 17 but got some errors during installation:

  Installing : VidyoDesktop-2.2.0-00379.x86_64                                                      1/1 
*** stack smashing detected ***: /opt/vidyo/VidyoDesktop/RunAsUser terminated
*** stack smashing detected ***: /opt/vidyo/VidyoDesktop/RunAsUser terminated
Non-fatal POSTIN scriptlet failure in rpm package VidyoDesktop-2.2.0-00379.x86_64
Start VidyoDesktop from Application --> Internet --> VidyoDesktop
VidyoDesktop has been installed in /opt/vidyo/VidyoDesktop
/opt/vidyo/VidyoDesktop/post.sh: line 8:  9908 Segmentation fault      (core dumped) LD_LIBRARY_PATH=/opt/vidyo/VidyoDesktop /opt/vidyo/VidyoDesktop/RunAsUser /opt/vidyo/VidyoDesktop/VidyoDesktopInstallHelper
/opt/vidyo/VidyoDesktop/post.sh: line 12:  9917 Segmentation fault      (core dumped) LD_LIBRARY_PATH=/opt/vidyo/VidyoDesktop /opt/vidyo/VidyoDesktop/RunAsUser -n /usr/bin/VidyoDesktop
warning: %post(VidyoDesktop-2.2.0-00379.x86_64) scriptlet failed, exit status 139

It seems to run fine.
Comment 74 Kris Maglione [:kmag] 2013-01-30 11:19:58 PST
If anyone is having problems with Vidyo freezing after the latest update once it prints:

main(): VidyoRect has: 0 0 0 0 

you should make sure that you have the pulseaudio daemon installed and running, especially if you have libpulse installed.
Comment 75 Mihai Sucan [:msucan] 2013-01-31 08:41:51 PST
I'm trying the new VidyoDesktop 2.2.1 which has official support for Ubuntu 12.04. I use this Ubuntu version and it seems Vidyo still fails to work.

I always get segmentation faults when I try to connect to any room. What can I do?

I have a separate headset - as is recommended in this bug, and I still can't get it to work...
Comment 76 Daniele "Mte90" Scasciafratte 2013-06-04 03:16:19 PDT
i get this error when i try to install on my debian 6

Configurazione di vidyodesktop (2.2.1-00417)...
The effective user ID is 0
The real user ID is 0
Effective and real user ID are both root, need to walk process hierarchy to find ancestral real user ID.
Attempting to change back to first non-root user ID in process chain...
First non-root user ID in process chain is 1000, with effective user ID of 0.
Group ID is 0, with effective group ID of 0.
got match for HOME, value of /home/mte90!
*** stack smashing detected ***: /opt/vidyo/VidyoDesktop/RunAsUser terminated
Segmentation fault
Comment 77 Daniele "Mte90" Scasciafratte 2013-06-04 03:46:19 PDT
When i execute after the package for fake ubuntu i get this
main(): called getrlimit(RLIMIT_CORE, ...), return value 0, rlim_cur = 0 rlim_max = 18446744073709551615
main(): will call setrlimit(RLIMIT_CORE, ...), rlim_cur = 18446744073709551615 rlim_max = 18446744073709551615
main(): called setrlimit(RLIMIT_CORE, ...), return value 0, rlim_cur = 18446744073709551615 rlim_max = 18446744073709551615
main(): called getrlimit(RLIMIT_CORE, ...), return value 0, rlim_cur = 18446744073709551615 rlim_max = 18446744073709551615
main(): getenv( HOME ) returned /home/mte90 
main(): PATH_MAX = 4096 
main(): pathToLogDir = /home/mte90/.vidyo/VidyoDesktop/ 
main(): VidyoRect has: 0 0 0 0 
Home directory not accessible: Permission denied

While by root the package not work.
I can't understand because the folder of vidyo are created :-/
Comment 78 Daniele "Mte90" Scasciafratte 2013-06-04 05:14:30 PDT
Sorry for the multiple message but i have resolved the problem!

Using the https://bugzilla.mozilla.org/show_bug.cgi?id=701083#c59 now work!
i haven't try to use the last version because the file on the package are different and i have not installed the package lib32asound2-plugins (i think that in sid it's not necessary).
Comment 79 John Karahalis [:openjck] 2013-06-04 07:27:25 PDT
After following this bug for a while, I finally gave in and set up a Windows/Linux dual boot. Annoying yes, but it is the only reliable way of running Vidyo I have found.
Comment 80 John Schoenick [:johns] 2013-12-19 10:30:44 PST
For those looking for a newer arch linux package, I've uploaded my newer source package here:
http://people.mozilla.org/~jschoenick/vidyo-desktop-2.2.1.00419-2.src.tar.gz
Comment 81 Johnny Stenback (:jst, jst@mozilla.com) 2014-01-10 15:58:47 PST
For those looking at why vidyo doesn't output any sound on recent linux distros, please see https://bugzilla.mozilla.org/show_bug.cgi?id=840707#c7.
Comment 82 Ashickur Rahman 2014-01-17 01:39:46 PST
I tried to install it on Arch 32 bit. But it is not running. When I tried to run it from terminal it shows error like: 

/usr/bin/VidyoDesktop: line 6: /opt/vidyo/VidyoDesktop/VidyoDesktop: cannot execute binary file
Comment 83 Johnny Stenback (:jst, jst@mozilla.com) 2014-01-17 16:15:29 PST
32 bit vs 64 bit?
Comment 84 Ashickur Rahman 2014-01-17 18:41:54 PST
32 bit.
Comment 85 Guillermo Movia [:deimidis] 2014-03-24 12:58:50 PDT
Thanks Johnny, that's resolve my problem with audio. I didn't want to upgrade to 3 (I do it in desktop and consume a lot of resources)
Comment 86 Guillermo Movia [:deimidis] 2014-03-24 12:59:41 PDT
@Ashickur did you resolve your issue? I have Arch64 and works
Comment 87 Ashickur Rahman 2014-03-24 18:19:04 PDT
Hey  Guillermo

Nope, I am using 32 bit. Vidyo has build of 32 bit for Ubuntu and Fedora, not for Arch :(
Comment 88 Guillermo Movia [:deimidis] 2014-03-25 11:18:32 PDT
Ashickur did you try https://bugzilla.mozilla.org/show_bug.cgi?id=701083#c8 this solution? It says 64 bits, but you could make it work for 32 bits, I think. you could ping me on IRC
Comment 89 Ashickur Rahman 2014-03-25 11:21:07 PDT
Guillermo, I think I have already tried that, but failed. In which channel I can find you?
Comment 90 Guillermo Movia [:deimidis] 2014-03-27 06:15:31 PDT
You could find me in mozilla-hispano channel
Comment 91 arky [:arky] 2014-07-07 10:13:33 PDT
New crash. Strange 
$ VidyoDesktop 
QString::arg: Argument missing: "@@@@ ASYNC EVENT TYPE " , 100 
QThread: Destroyed while thread is still running
QThread::wait: Thread tried to wait on itself
/usr/bin/VidyoDesktop: line 6:  5861 Segmentation fault      (core dumped) /opt/vidyo/VidyoDesktop/$EXEC $option $audioflag $@


$ lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 13.10
Release:	13.10
Codename:	saucy
Comment 92 arky [:arky] 2014-07-07 10:43:10 PDT
Here is a work-around. Removing ~/.vidyo folder helped.
Comment 93 Ashickur Rahman 2014-08-21 20:12:25 PDT
I tried it today on Debian 7 32 bit. It is not working. When I try to open it via terminal, there is no error, but vidyo is not starting. 

$ lsb_release -a
No LSB modules are available.
Distributor ID:	Debian
Description:	Debian GNU/Linux 7.6 (wheezy)
Release:	7.6
Codename:	wheezy
Comment 94 Kaustav Das Modak [:kaustavdm] 2014-09-09 08:57:48 PDT
People on Arch Linux can use this: https://aur.archlinux.org/packages/vidyo-moz.
Comment 95 Anivar Aravind 2015-06-08 08:36:14 PDT
Segmentation Fault on Elementary OS (based on Ubuntu 14.04)

$ VidyoDesktop 

(VidyoDesktop:5993): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(VidyoDesktop:5993): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(VidyoDesktop:5993): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(VidyoDesktop:5993): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",

(VidyoDesktop:5993): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
QPainter::begin: Widget painting can only begin as a result of a paintEvent
got fs = ext 4
supports ext4 get_tag_value-101-57-54-57-50-48
QObject: Cannot create children for a parent that is in a different thread.
(Parent is VDVidyoClientPlugIn(0x31093a0), parent's thread is VDVidyoClientPlugIn(0x31093a0), current thread is QThread(0x2ba7c40)
QObject: Cannot create children for a parent that is in a different thread.
(Parent is VDVidyoClientPlugIn(0x31093a0), parent's thread is VDVidyoClientPlugIn(0x31093a0), current thread is QThread(0x2ba7c40)
Object::connect: No such signal VDController::StartDownload(bool) in ../source/VDController.cpp:610
QObject::moveToThread: Cannot move objects with a parent
No systemtrayicon available
QThread::wait: Thread tried to wait on itself

$ lsb_release -a
No LSB modules are available.
Distributor ID:	elementary OS
Description:	elementary OS Freya
Release:	0.3
Codename:	freya
Comment 96 Daniele "Mte90" Scasciafratte 2016-03-12 02:53:27 PST
Finally is working on Debian sid!
First step try with 3.3.0 but is very old (feb 2014) so I search for a new version.
The 3.5.4 is the last of sep 2015 downloadable here: https://demo.vidyo.com/upload/VidyoDesktopInstaller-ubuntu64-TAG_VD_3_5_4_010.deb
This is ok for ubuntu but the libqt4-gui not exist on sid so I edit the package depends and now use libqtgui4 of debian sid.
If you want download the package edited for debian sid that in my computer works is here: https://codeat.owncube.com/index.php/s/ITStyQN6oaCV8VR

Resources useful if you have problem:

* http://information-technology.web.cern.ch/services/fe/howto/users-use-vidyo-linux
* http://information-technology.web.cern.ch/services/fe/vidyo/howto/users-test-your-setup
* https://bugzilla.mozilla.org/show_bug.cgi?id=840707
Comment 97 Mathieu Leplatre (:leplatrem) 2016-04-27 02:12:46 PDT
I had this error with 3.3.0-027 on Ubuntu 15.10 64bits:

   $ VidyoDesktop 
   QPainter::begin: Widget painting can only begin as a result of a paintEvent
   QThread: Destroyed while thread is still running
   QThread::wait: Thread tried to wait on itself
   /usr/bin/VidyoDesktop : ligne 6 : 13240 Erreur de segmentation  (core dumped) /opt/vidyo/VidyoDesktop   /$EXEC $option $audioflag $@

I could solve by deleting my profile folder `~/.vidyo`.

Note You need to log in before you can comment on or make changes to this bug.