Pages do not expire even if > browser.history_expire_days.mirror

RESOLVED INVALID

Status

()

Firefox
Bookmarks & History
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Christoph Wickert, Unassigned)

Tracking

7 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
I am using Mozilla/5.0 (X11; Linux x86_64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1 from Fedora.

Steps to reproduce:
1. Set browser.history_expire_days.mirror to 60 and restarted firefox.
2. Open history, add the column "last accessed" and use it for sorting.

Actual results:
1. History still has an entry for "Older than 6 months"
2. "Older than 6 months" lists pages that were last accessed a year ago (30.11.2010 as I file this bug). This is even bigger than the default hard limit of browser.history_expire_days.mirror (180 days) and way bigger than the limit I set manually.

Expected results:
1. There should be no "Older than 6 months" but only "Older than a month" or "Older than 2 months"
2. "Older than X months" should not list pages that were last accessed before browser.history_expire_days.mirror
(Reporter)

Updated

7 years ago
See Also: → bug 520165

Comment 1

7 years ago
Excerpt from discussion at http://blog.bonardo.net/2010/01/20/places-got-async-expiration:
"browser.history_expire_days.mirror has no effect, it’s stored for UI reasons. in Firefox 4 browser.history_expire_days_min is unused, you can Reset it and it will disappear."
right, we don't use anymore that pref.

you can try with this experimental add-on https://addons.mozilla.org/firefox/addon/expire-history-by-days/
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Component: General → Bookmarks & History
QA Contact: general → bookmarks
Resolution: --- → INVALID
(Reporter)

Comment 3

7 years ago
(In reply to Marco Bonardo [:mak] from comment #2)
> right, we don't use anymore that pref.

It's hard to guess if something is a bug or an intended change. It it's not used anymore,
- it should be removed automatically (just like browser.history_expire_days)
- all relevant information should be updated. This includes mozilla.org websites.
- you should make sure that users are aware of this change. E.g. by mentioning it in the release notes. When did it change?

> you can try with this experimental add-on
> https://addons.mozilla.org/firefox/addon/expire-history-by-days/

It's kind of sad that I need an addon to get back a functionality that was included since the Netscape days.
(In reply to Christoph Wickert from comment #3)
> It's kind of sad that I need an addon to get back a functionality that was
> included since the Netscape days.

That was the idea that distinguished firefox from netscape, core functionality is in the browser, additional functionality is provided by addons, so I'm not sure I buy that.

Btw, this happened in Firefox 4 and was announced on planet.mozilla, planet.firefox, on the mozilla newsgroups. Atm, I don't remember if it was in relnotes, sorry.
(Reporter)

Comment 5

7 years ago
Marco, thanks a lot for your reply.

(In reply to Marco Bonardo [:mak] from comment #4)
> That was the idea that distinguished firefox from netscape, core
> functionality is in the browser, additional functionality is provided by
> addons

For me this is a core functionality. But thanks for the extension, limiting the history to 180 days has dramatically improved responsiveness of the UI and lowered the memory footprint.
You need to log in before you can comment on or make changes to this bug.