Last Comment Bug 701251 - Entering DOM Fullscreen leaves Firefox Find Bar on the screen.
: Entering DOM Fullscreen leaves Firefox Find Bar on the screen.
Status: VERIFIED FIXED
[qa!]
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: All All
: -- normal with 1 vote (vote)
: Firefox 11
Assigned To: Dão Gottwald [:dao]
:
Mentors:
: 704214 (view as bug list)
Depends on:
Blocks: 545812
  Show dependency treegraph
 
Reported: 2011-11-09 17:25 PST by Justin Dolske [:Dolske]
Modified: 2012-01-25 07:36 PST (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
verified
verified


Attachments
patch (1009 bytes, patch)
2011-11-28 06:35 PST, Dão Gottwald [:dao]
dolske: review+
asa: approval‑mozilla‑aurora+
Details | Diff | Review

Description Justin Dolske [:Dolske] 2011-11-09 17:25:40 PST
Perhaps this is is technically a frontend bug, but haven't looked at the implementation yet.

STR:

1) Visit http://blog.pearce.org.nz/2011/11/firefoxs-html-full-screen-api-enabled.html

2) Control-F or Command-F to bring up the find bar at the bottom of the browser.

3) Click the page's "Make video full-screen" button (below the video)

4) Video goes full-screen, find-bar remains present at the bottom of the screen (full-width).
Comment 1 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-11-09 18:59:55 PST
Let's call this a front-end bug :-). The front-end is responsible for hiding all the chrome when fullscreen is activated.
Comment 2 Dão Gottwald [:dao] 2011-11-10 00:41:54 PST
Also, you can open the find bar while in DOM FS.
Comment 3 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-11-10 00:58:20 PST
(In reply to Dão Gottwald [:dao] from comment #2)
> Also, you can open the find bar while in DOM FS.

I think that's a good thing.
Comment 4 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2011-11-10 02:10:11 PST
When I noticed this, I thought it was a (good) feature.
Comment 5 Boris Zbarsky [:bz] (Out June 25-July 6) 2011-11-21 11:09:32 PST
*** Bug 704214 has been marked as a duplicate of this bug. ***
Comment 6 Dão Gottwald [:dao] 2011-11-28 06:35:54 PST
Created attachment 577243 [details] [diff] [review]
patch
Comment 7 Dão Gottwald [:dao] 2011-11-29 07:05:31 PST
https://hg.mozilla.org/mozilla-central/rev/65cdbf003bd3
Comment 9 Paul Silaghi, QA [:pauly] 2012-01-03 05:22:55 PST
What about if activate the Find Bar, enter DOM fullscreen and then exit fullscreen? The bar is not seen anymore.
Comment 10 Virgil Dicu [:virgil] [QA] 2012-01-25 07:36:26 PST
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0) Gecko/20100101 Firefox/10.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:11.0a2) Gecko/20120124 Firefox/11.0a2
Mozilla/5.0 (Windows NT 6.1; rv:10.0) Gecko/20100101 Firefox/10.0
Mozilla/5.0 (Windows NT 6.1; rv:11.0a2) Gecko/20120124 Firefox/11.0a2
Mozilla/5.0 (X11; Linux x86_64; rv:11.0a2) Gecko/20120124 Firefox/11.0a2
Mozilla/5.0 (X11; Linux x86_64; rv:10.0) Gecko/20100101 Firefox/10.0


Setting this to verified. The original issue has been fixed. Used STR from comment 0 on mac OS 10.6, Ubuntu 11.10 and Windows 7.--Firefox 10 Beta 6 and Firefox 11 Aurora.

Filed bug 721026 for follow-up, as the find-bar doesn't remain active after exiting DOM Full screen. (comment 9)

Note You need to log in before you can comment on or make changes to this bug.