Intermittent test_aboutmemory.xul | Timed out while polling clipboard for pasted data. and | pasted text doesn't match for amFrame

RESOLVED WORKSFORME

Status

()

Toolkit
about:memory
RESOLVED WORKSFORME
6 years ago
2 years ago

People

(Reporter: philor, Unassigned)

Tracking

({intermittent-failure})

Trunk
x86_64
Linux
intermittent-failure
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=7317914&tree=Firefox
Rev3 Fedora 12x64 mozilla-central opt test mochitest-other on 2011-11-09 15:19:38 PST for push c60535115ea1

13341 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/components/aboutmemory/tests/chrome/test_aboutmemory.xul | Timed out while polling clipboard for pasted data.
13342 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/components/aboutmemory/tests/chrome/test_aboutmemory.xul | pasted text doesn't match for amFrame
Hasn't happened for 11 days; closing worksforme.  Philor, I know you'd love nothing more than to reopen when I'm proven wrong.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Comment hidden (Treeherder Robot)
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Duplicate of this bug: 711614
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

5 years ago
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

5 years ago
Keywords: intermittent-failure
(Assignee)

Updated

5 years ago
Whiteboard: [orange]

Comment 10

2 years ago
Hello! Can I take up this bug? I've been encountering this error while trying to run testcases to test the loading and saving of content from/to files using about:memory. Could anyone please guide me on how I should be going about this?
The test code that is failing is here:
https://dxr.mozilla.org/mozilla-central/rev/f14898695ee0dd14615914f3e1401f17df57fdd7/toolkit/components/aboutmemory/tests/test_aboutmemory.xul#552-578

It is calling the waitForClipboard function that is defined here:
https://dxr.mozilla.org/mozilla-central/rev/f14898695ee0dd14615914f3e1401f17df57fdd7/testing/mochitest/tests/SimpleTest/SimpleTest.js#908-909

To start debugging this test, you could use the debugger or add some log statements to find out what text is actually on the clipboard ("aActual"). Then try to figure out where that that text is coming from and why it doesn't match the expected contents.

Comment 12

2 years ago
Sure!! Thank you!! I'll try it out and let you in case I have any doubts..

Comment 13

2 years ago
Hi! with log statements like below, I'm trying to test if the clipboard content and the expected content matches or not. I'm not being able to trace the expected and the clipboard text despite of including them in the dump statements. Any idea as to how I should proceed? 
            ok(false, "pasted text doesn't match");
            dump("******EXPECTED******\n");
            dump(aExpected);
            dump("*******ACTUAL*******\n");
            dump(aActual);
            dump("********************\n");
You need to log in before you can comment on or make changes to this bug.