Last Comment Bug 701297 - Several favicons are lost in bookmarks with the upgrade to newer version of Firefox
: Several favicons are lost in bookmarks with the upgrade to newer version of F...
Status: RESOLVED INCOMPLETE
[Summary in comment 26]
: regression
Product: Firefox
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: All All
: -- normal with 6 votes (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
: Marco Bonardo [::mak]
Mentors:
https://support.mozilla.com/en-US/que...
: 701287 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-09 23:56 PST by Frédéric Buclin
Modified: 2013-02-12 07:37 PST (History)
29 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
-
-
-


Attachments
Screenshot of Favicons in Bar but not in Bookmarks (237.19 KB, image/jpeg)
2011-12-07 12:57 PST, Julius
no flags Details
Firefox 9.0 on Mac OS X 10.6.8 showing missing bookmarks menu icons, but they do show in the bookmarks sidebar (3.07 MB, image/png)
2011-12-20 17:57 PST, Mario Grgic
no flags Details

Description Frédéric Buclin 2011-11-09 23:56:35 PST
As mentioned in https://support.mozilla.com/en-US/questions/893818, several favicons are no longer displayed in bookmarks, nor are they displayed when opening tabs (if the favicon is missing in the bookmark, then it's also missing when opening the URL in a tab). This means I now have several pinned tabs with no favicon, which makes it rather difficult to identify them. I didn't notice this problem in Firefox 7.

I'm surprised this bug hasn't been reported on bmo yet (or maybe it has, but I couldn't find it).
Comment 1 Cork 2011-11-09 23:59:57 PST
Should prob dup this or bug 701287. I haven't seen an example link yet though.
Comment 2 Frédéric Buclin 2011-11-10 07:01:31 PST
An example of a page with a missing favicon? For instance:
http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/webtools/bugzilla/Bugzilla/Bug.pm
Comment 3 Frédéric Buclin 2011-11-10 07:18:54 PST
It appears that many favicons have been lost during the upgrade to Fx8. When reopening these pages, many favicons come back, both in the tab and in the bookmarks.
Comment 4 Marco Bonardo [::mak] 2011-11-10 08:18:00 PST
the tabs and the bookmarks follow different path to fetch the icons btw.
Comment 5 Marco Bonardo [::mak] 2011-11-10 09:40:50 PST
(In reply to Frédéric Buclin from comment #2)
> An example of a page with a missing favicon? For instance:
> http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/webtools/bugzilla/
> Bugzilla/Bug.pm

This page doesn't seem have a favicon at all...

I found a bug, but it only involves a bookmark that has a uri that redirects to a page with an icon, the bookmark does not get the icon.
If you have an example of a bookmark that doesn't get an icon, and the final uri is the same as the one in the bookmarks, I'd love to get a copy of places.sqlite, privately (by mail or on irc)
Comment 6 Marco Bonardo [::mak] 2011-11-10 10:02:13 PST
I filed Bug 701421 on the edge cases I found, but it's pretty clear it's not the bug hitting so many users.
Comment 7 Peter E. Humphries 2011-11-10 10:29:01 PST
Immediately upon upgrading to FF8, I discovered that the dotted square is replacing favicons that do, in fact, exist.  They were all working in FF7 but are now "missing" in FF8.

Take this page, for instance: in the title bar, the Bugzilla favicon appears ( https://bugzilla.mozilla.org/extensions/BMO/web/images/favicon.ico ), but on the tab is the dotted box.  Even Google's favicon is missing; although it is not coded in the HTML, it is sitting in the expected spot ( http://www.google.com/favicon.ico ).

I have discovered that the favicon will appear in the address bar (for sites that have one, whether coded with rel="icon" or in the default root location) after clicking on the "blank" icon beside the address.  (Moving the tab may have the same effect; I am sure that it happened, once, but I have not been able to reproduce it!)

The favicon does not persist, however.  Once the page is reloaded or after clicking a link to another page on the same site, the behaviour repeats ("blank" favicon until clicked).

I have not discovered any way to force the favicon to display on the tab.

I have tested pages that do not have the rel="icon" instruction but do have a default favicon.ico in the site's root, pages that have both a (different or identical) default favicon and a rel="icon" direction, pages that change icons as the site is navigated (different favicons for different pages) and a variety of capitalization ("Icon" "ICON" &c) in the rel="icon" (or rel="shortcut icon") instruction.

The favicon also does not appear in the Page Info / Media preview until you click on another picture and then click back on the favicon entry.  This has no effect on the address bar or tab display, and the favicon sometimes persists and sometimes does not when you exit the Page Info window and open it, again.  I have not figured out if there is any pattern to this latter behaviour.
Comment 8 Marco Bonardo [::mak] 2011-11-10 11:02:26 PST
Considered you see the bug in tabs and in pageinfo, I can likely exclude issues in favicons service, moreover there have not been changes there in FF8. I suspect it just doesn't get a call to store the icon.
It may be a problem in browser's setIcon(), in the cache, or in the http channel. It's hard to tell without being able to reproduce.
If anybody able to reproduce the problem wants to help, may compress a copy of his profile folder (provided it has an acceptable size) and mail it to us (either me, margaret, gavin or any other browser peer, see https://wiki.mozilla.org/Modules/Firefox).
Otherwise, if you can figure out steps to reproduce in a new and clean profile, would be extremely useful.
Comment 9 Marco Bonardo [::mak] 2011-11-10 11:20:04 PST
Also, could you please check if safe mode makes a difference? http://support.mozilla.com/kb/Safe+Mode

I have tried with several hundreds pages in Firefox 8 and all of them set the icon correctly :(
Comment 10 Frédéric Buclin 2011-11-10 11:25:17 PST
(In reply to Marco Bonardo [:mak] from comment #9)
> I have tried with several hundreds pages in Firefox 8 and all of them set
> the icon correctly :(

Do you mean bookmarks? Once you load the page, its favicon is displayed correctly in my few tests. Either that, or the page really seems to not have a favicon at all. What also confuses us is that in Fx 7 and older, a missing favicon was replaced by some visible favicon. Now in Fx8, it's replaced by an empty favicon, which gives us a false impression that much more websites have no favicons. For instance, I realized that my example in comment 2 is inaccurate. Fx 3.6 doesn't display any favicon either for this URL.
Comment 11 Peter E. Humphries 2011-11-10 11:55:29 PST
(In reply to Marco Bonardo [:mak] from comment #8)
> ...if you can figure out steps to reproduce in a new and clean
> profile, would be extremely useful.

Well, my profile is 134MB; so, before emptying my cache, I thought that I would try your suggestion of testing Safe Mode.

In Safe Mode, the favicons are behaving as expected, and all the behaviours that I reported in my long post have returned to normal.

Looking through my Add Ons, I disabled a few that fiddle with images and, through the process of elimination, determined that Favicon Picker 2 v0.6.2.15 ( https://addons.mozilla.org/en-US/firefox/addon/favicon-picker-2/ ) is the culprit.  Add this to your clean profile to confirm.

There are already two reports of this bug appearing at the FF7.0.1 release.  If you can duplicate my experience and others can check their Add Ons, perhaps we have found the problem.
Comment 12 Peter E. Humphries 2011-11-10 12:00:50 PST
Just to clarify my last post, there are two bug reports on the Favicon Picker 2 page indicating that the Favicon Picker 2 Add On started interfering with favicon display at the FF7.0.1 release.

If everyone who has reported this problem can solve it by removing Favicon Picker 2, then the Add On is the culprit.  If we have a variety of Add Ons to which we can trace the issue, then we can find the root problem by looking at what they hook in common, perhaps.
Comment 13 Marco Bonardo [::mak] 2011-11-10 12:34:12 PST
regarding Favicon Picker 2, it seems to overlay browser.xml with a versione coming from Firefox3.5, the current "setIcon" implementation accepts both nsIURI or an url string, while that overlay only accepts plain url strings.

so for example, from that overlay:
browser.mIconURL = aURI;

may be wrong where aURI is a nsIURI.
Comment 14 chris 2011-11-11 10:29:58 PST
No question about it: Firefox 8.0 is nuking perfectly good icons. I have reproduced the issue on multiple Windows PCs. I use my bookmarks as a library, and icons allow me to navigate that library more easily. I expect icons in that library to persist indefinitely, regardless of how recently I visited the URL, and *even if the URL is no longer valid*. Broken URLs are still information! They're often useful to me because they tell me what I had, and give clues as to where I might find it again. I'm reverting to version 7 until this gets sorted out. Luckily I always back up my places.sqlite for exactly this reason.
=ck
Comment 15 Marco Bonardo [::mak] 2011-11-11 10:36:24 PST
Do you use or did you ever use a Favicons addon like Favicon Picker?
Comment 16 chris 2011-11-11 10:46:56 PST
Update to Comment 14: I can confirm that rolling back to 7.0.1 caused ALL of my icons to REAPPEAR. I didn't even need to blow away places.sqlite with my backup. So it seems the problem isn't that 8.0 is deleting the icons from the database; it's deciding that certain icons are unworthy and replacing them with the blank squares. I can't say exactly what criteria it's using. Based on a small sample, it looks like the icons that 8.0 considers unworthy are from older and/or less recently used bookmarks, some (but not all) of which may have broken URLs. I would be willing to do a more systematic analysis if that's helpful.
=ck

@Marco Bonardo 

>>>Do you use or did you ever use a Favicons addon like Favicon Picker?

No I did not. My addons are: Adblock Plus 1.3.10, Add to Search Bar 2.0, Go Parent Folder 2.5, NoScript 2.1.9, Password Exported 1.2.1 and that's all.
Comment 17 Marco Bonardo [::mak] 2011-11-11 10:58:23 PST
(In reply to chris from comment #16)
> No I did not. My addons are: Adblock Plus 1.3.10, Add to Search Bar 2.0, Go
> Parent Folder 2.5, NoScript 2.1.9, Password Exported 1.2.1 and that's all.

Could you please try disabling Go Parent Folder? Even the others if you wish to try (though I can probably exclude Adblock plus, since I use it too), if the icons are in the database it's likely a view problem, and 99% those are caused by addons.
Comment 18 chris 2011-11-11 11:15:14 PST
(In reply to Marco Bonardo [:mak] from comment #17)
> (In reply to chris from comment #16)
> > No I did not. My addons are: Adblock Plus 1.3.10, Add to Search Bar 2.0, Go
> > Parent Folder 2.5, NoScript 2.1.9, Password Exported 1.2.1 and that's all.
> 
> Could you please try disabling Go Parent Folder? 

I just reupgraded from 7.0.1 to 8.0 on my main XP box, disabled ALL of the above addons, restarted, and the icons are still hosed. I was confident this would be the case, b/c when I first observed the problem I tried starting FF8 in safe mode and it didn't help. I should emphasize that FF8 makes hundreds of bookmark icons into white squares, so it's not a minor impact. It's as if code has been added that tries to invalidate "older" bookmark icons, perhaps the way Windows sometimes hides "older" icons on the desktop. Could it have something to with whether a given URL has been visited since the last time places.sql was restored from a backup? If there are any tests you want me to do while I'm running 8.0 let me know, otherwise I'll roll back to 7 again.
=ck
Comment 19 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-11-11 11:23:55 PST
(In reply to chris from comment #18)
> I just reupgraded from 7.0.1 to 8.0 on my main XP box, disabled ALL of the
> above addons, restarted, and the icons are still hosed.

Thanks a lot for your testing, we really want to get to the bottom of this!

Could you post a screenshot of the icons for a given bookmark appearing in 7.0.1, and then disappearing in 8.0?
Comment 20 Marco Bonardo [::mak] 2011-11-11 11:28:47 PST
Chris, if you create a new test profile in 8, and copy places.sqlite to it, do you see the icons in that profile?
Comment 21 chris 2011-11-11 12:22:08 PST
(In reply to Marco Bonardo [:mak] from comment #20)
> Chris, if you create a new test profile in 8, and copy places.sqlite to it,
> do you see the icons in that profile?

Apologies! I was mistaken. After taking many screen shots and examining them carefully, I found that in all cases the blank icons in FF8 are default icons in FF7. I couldn't find any case where non-default icons are being shown as blank. I enclose links to a representative example.

http://whorld.org/temp/FF8-blank-icons/FF7-comp-prog-MFC-code-proj.gif
http://whorld.org/temp/FF8-blank-icons/FF8-comp-prog-MFC-code-proj.gif

It was a pretty alarming change though, it spooked me and apparently quite a few others. What was the issue with showing the venerable default icon?
=ck
Comment 22 Wes Kocher (:KWierso) 2011-11-11 17:30:18 PST
Running the Check Places extension and checking/replacing all the favicons got back my bookmark favicons, if that adds anything to the discussion.
Comment 23 PimpUigi 2011-11-12 00:09:33 PST
http://www.mediafire.com/download.php?0bjbyhorijpxkjg
My buttons patch actually seems to fix this (I think).
Can anyone here confirm???
Comment 24 rd 2011-11-13 13:56:10 PST
An example of a site that worked fine under FF7, but just displays the default icon symbol under FF8

http://www.cosmosmagazine.com/

Displaying its source, the following line appears

<link rel="shortcut icon" href="/favicon.ico" type="image/x-icon" />

Disabling all Add-ons, it still doesn't work.
I do not & have never used a favicon picker of any sort
Comment 25 Masatoshi Kimura [:emk] 2011-11-13 17:33:56 PST
(In reply to rd from comment #24)
> http://www.cosmosmagazine.com/
The site do not actually have a favicon. The follwing URL returned 404.
http://www.cosmosmagazine.com/favicon.ico
Comment 26 Marco Bonardo [::mak] 2011-11-14 04:39:51 PST
I think this bug can be solved as the mixture of:
- favicon picker 2 addon creating issues to users having it
- confusion caused by the new empty favicon, that makes missing favicons much more evident

Nothing else has been reported so far.
Comment 27 Frédéric Buclin 2011-11-14 07:32:36 PST
(In reply to Marco Bonardo [:mak] from comment #26)
> Nothing else has been reported so far.

That's not true, see my comment 3 (unless they have been lost before the upgrade).
Comment 28 Marco Bonardo [::mak] 2011-11-14 08:39:52 PST
(In reply to Frédéric Buclin from comment #27)
> That's not true, see my comment 3 (unless they have been lost before the
> upgrade).

right there is some spurious favicons expiration but I've checked any code that touches that table, and nothing may cause that internally. may have been some light corruption or still a third party addon afaict.
Comment 29 :Gavin Sharp [email: gavin@gavinsharp.com] 2011-11-14 17:51:01 PST
*** Bug 701287 has been marked as a duplicate of this bug. ***
Comment 30 lwz 2011-11-16 04:32:18 PST
I also have this problem. For me, although all the icons appear properly on the tabs, when I use the address bar, even drop-down entry for www.google.com has a dotted square next to it. I am not sure whether the missing icon happened when I upgraded. Even if it didn't, the dotted square makes it so much more obvious, and really doesn't look right in my opinion.
Comment 31 j.j. 2011-11-16 05:12:49 PST
(In reply to limweizhong from comment #30)
> I also have this problem.
See comment 26 and disable that add on.
Comment 32 lwz 2011-11-16 06:19:21 PST
I don't have that add-on installed. However, thinking of it again, I think the drop-down entry for www.google.com actually did not ever have a favicon...?
Comment 33 Darrel Jones 2011-11-16 08:22:43 PST
The problem is NOT correctly stated in #26 above.

What is bothering me most is the "This is not a problem" attitude repeatedly shown as above.  Either take time to seriously look at this or else just say you aren't going to resolve it and I will toss firefox 8.0.

The favicon for given bookmarks was set in some previous version of Firefox and was retained all the way up to version 7.1.  Upgrading to 8.0 then enforced the internal rules and made the favicons default to the dashed round cornered square because the bookmarked page does not contain a rel=favicon statement.  The reason for reports of problems at 8.0 is because it continued to work up to this point.

The webpages and corresponding bookmarks do NOT currently have a rel=favicon statement.  The favicon WAS set in a previous version of Firefox by proactively loading the base website favicon and attaching it to the bookmark. Somewhere buried in previous versions of Firefox was a little tweak that loaded the base website favicon.ico and set it against the bookmarked webpage.  For example:

http://www.gardenweb.com/ which is the base webpage has a favicon.ico file.
http://forums.gardenweb.com/forums/asianveg/ which is my bookmarked page does NOT have a rel=favicon statement.
Therefore previous versions of Firefox automatically loaded:
http://www.gardenweb.com/favicon.ico
and attached the base website favicon to the bookmark.

Upgrading to version 7.1 retained those already existing favicons associated with the bookmarks.  Upgrading to version 8.0 tossed the existing favicons thereby giving the impression the problem is with 8.0.  In reality, both 7.1 and 8.0 are deliberately disabling this function but 7.1 continued to use any existing favicons.

Please consider that this is a significant enough problem that I will toss version 8.0 to get rid of it.  I navigate through webpages very quickly by using the visual cue of the favicon to find the correct bookmark.  When it is missing, there is a significant impact which is VERY frustrating.

DarJones
Comment 34 Masatoshi Kimura [:emk] 2011-11-16 08:47:20 PST
(In reply to Darrel Jones from comment #33)
> http://forums.gardenweb.com/forums/asianveg/ which is my bookmarked page
> does NOT have a rel=favicon statement.
> Therefore previous versions of Firefox automatically loaded:
> http://www.gardenweb.com/favicon.ico
> and attached the base website favicon to the bookmark.
My Firefox 3.6 and 7.0.1 (with clean profile) didn't load http://www.gardenweb.com/favicon.ico when opening http://forums.gardenweb.com/forums/asianveg/ . Only the default favicon was displayed. I guess you get something wrong.
Comment 35 Marco Bonardo [::mak] 2011-11-16 12:42:39 PST
(In reply to limweizhong from comment #30)
> I also have this problem. For me, although all the icons appear properly on
> the tabs, when I use the address bar, even drop-down entry for
> www.google.com has a dotted square next to it. I am not sure whether the
> missing icon happened when I upgraded. Even if it didn't, the dotted square
> makes it so much more obvious, and really doesn't look right in my opinion.

Another known addon causing favicon issues is Divx HTML5 web player add-on, so please check if you have it. Checking in safe-mode is also a good way to know if any of your addons may cause the issue http://support.mozilla.com/kb/Safe+Mode

If the entry did not have a favicon, and now shows an empty favicon, then there's no bug, it's just the new favicon is confusing.
Comment 36 Marco Bonardo [::mak] 2011-11-16 12:54:09 PST
(In reply to Darrel Jones from comment #33)
> What is bothering me most is the "This is not a problem" attitude repeatedly
> shown as above.  Either take time to seriously look at this or else just say
> you aren't going to resolve it and I will toss firefox 8.0.

I don't see any not-a-problem attitude, a lot of devs moved for this bug, trying to reproduce it, trying to ask around for testcases and answering and asking in forums. I personally asked both here, on irc and in 3 forums for multiple days, and in mixed languages.

> http://www.gardenweb.com/ which is the base webpage has a favicon.ico file.
...

Neither Firefox, neither Chrome, neither IE10 show the icon, maybe they changed the page, who knows, for sure not showing an icon is the right thing to do for these pages.

> Upgrading to version 8.0 tossed the existing favicons
> thereby giving the impression the problem is with 8.0.

The problem has been for sure made more evident and confusing by the new empty icon plus the fact 2 popular addons (favicon picker 2 and DivX web player) are causing similar issue. Now the fact is that we don't expire icons content till a new version of the icon replaces it, there is no code to do that, afaik.

> Please consider that this is a significant enough problem that I will toss
> version 8.0 to get rid of it.

We know, we are asking for a testcase and help from users seeing the problem, but we are failing getting something to work on.
Comment 37 Josh Grossman 2011-11-17 06:43:37 PST
I am not a developer but wanted to report this problem as well. Up until Firefox 8, our website, https://savingstar.com showed a favicon. Now it is not displaying. I also see problems on some of my bookmarks. Here's a screenshot:

http://imageshack.us/photo/my-images/257/screenhunter27nov170939.gif/
Comment 38 Peter E. Humphries 2011-11-17 08:17:37 PST
(In reply to Josh Grossman from comment #37)
> ...our website, https://savingstar.com showed a favicon. Now it is not...

I am seeing a favicon on that site.  Have you tried Safe Mode to see if you have any Add Ons conflicts as noted, above?

(In reply to Darrel Jones from comment #33)
> http://www.gardenweb.com/ which is the base webpage has a favicon.ico file.

Interestingly enough, when I load http://www.gardenweb.com/, I see the favicon as expected.  However, the favicon.ico file, itself, appears to be corrupted in some way -- Firefox offers to save it instead of displaying it, but it opens without issue in a favicon editor.

Compare the behaviour in your browser betwixt:

http://www.gardenweb.com/favicon.ico

and

http://www.google.com/favicon.ico

However, that is neither here nor there insofar as the issue at hand, I think.

> http://forums.gardenweb.com/forums/asianveg/ which is my bookmarked page
> does NOT have a rel=favicon statement.
> Therefore previous versions of Firefox automatically loaded:
> http://www.gardenweb.com/favicon.ico
> and attached the base website favicon to the bookmark.

This highlights a change in behaviour if you did nothing to manually add the favicon to your bookmarks.  I have not noticed this, before, but, as there is no http://forums.gardenweb.com/favicon.ico file, it is the *expected* behaviour (as per the somewhat loose rules around favicons :)).

> Upgrading to version 8.0 tossed the existing favicons...

It would appear that the code to "update" favicons was tweaked to also "remove" favicons when no valid favicon is found.  Perhaps someone who worked on that could provide some insight.

If this is the case, it would explain why the new "blank" icon has become so noticeable.  (For the record, I agree that the dotted box sends the wrong message and should be changed back to the "blank bookmark" icon.)
Comment 39 Josh Grossman 2011-11-17 08:30:42 PST
(In reply to Peter E. Humphries from comment #38)
> (In reply to Josh Grossman from comment #37)
> > ...our website, https://savingstar.com showed a favicon. Now it is not...
> 
> I am seeing a favicon on that site.  Have you tried Safe Mode to see if you
> have any Add Ons conflicts as noted, above?
> 

Please try this URL which is our blog, the favicon is missing:

https://savingstar.com/blog

Also, note that if you look at the bookmarks in my screenshot, you'll see that 3 favicons are missing.

http://imageshack.us/photo/my-images/257/screenhunter27nov170939.gif/

My only Add-Ons are Delicious, Alexa, and Springpad.
Comment 40 Marco Bonardo [::mak] 2011-11-17 08:39:42 PST
(In reply to Peter E. Humphries from comment #38)
> It would appear that the code to "update" favicons was tweaked to also
> "remove" favicons when no valid favicon is found.  Perhaps someone who
> worked on that could provide some insight.

The problem is that no changes have been done to favicons code in 8.0, and the interface has no concept of "removing" an icon. 

(In reply to Peter E. Humphries from comment #38)
> Interestingly enough, when I load http://www.gardenweb.com/, I see the
> favicon as expected.  However, the favicon.ico file, itself, appears to be
> corrupted in some way -- Firefox offers to save it instead of displaying it,
> but it opens without issue in a favicon editor.

fwiw, the server is replying with Content-Type text/plain; charset=UTF-8 so it's unlikely we may consider it an icon.

(In reply to Josh Grossman from comment #39)
> Please try this URL which is our blog, the favicon is missing:
> 
> https://savingstar.com/blog

Trying to load https://savingstar.com/favicon.ico I get a "The image cannot be displayed because it contains errors." image. It's just matter of checking if Firefox 7 can read it instead.
Comment 41 Marco Bonardo [::mak] 2011-11-17 08:41:45 PST
in IE9 I see a broken image, in Chrome I don't see anything.
Comment 42 Marco Bonardo [::mak] 2011-11-17 08:43:06 PST
(In reply to Josh Grossman from comment #39)
> Also, note that if you look at the bookmarks in my screenshot, you'll see
> that 3 favicons are missing.
> 
> http://imageshack.us/photo/my-images/257/screenhunter27nov170939.gif/

could you take the same screenshot in Firefox 7?
Comment 43 Josh Grossman 2011-11-17 09:08:39 PST
(In reply to Marco Bonardo [:mak] from comment #42)
> (In reply to Josh Grossman from comment #39)
> > Also, note that if you look at the bookmarks in my screenshot, you'll see
> > that 3 favicons are missing.
> > 
> > http://imageshack.us/photo/my-images/257/screenhunter27nov170939.gif/
> 
> could you take the same screenshot in Firefox 7?

My apologies Marco. Those sites are also missing the favicons in firefox 7! I supposed it was less noticeable because of the filled in white rectangle rather than the new dotted lines.
Comment 44 R. Glass 2011-11-17 09:14:03 PST
I don't know how much I can add, but here is something I just found:
I have a website:
   http://www.EspressoMyEspresso.com [call it EME]
which redirects to:
   http://www.frcndigital.com/coffee/Coffee.html [call it GD]

favicon display: 
- - - - EME - GD
 IE: -   N - Y  [v 8.0.0061.18702]
 FF:  -  N - N  [v 7.1.4288]
 FF:  -  N - N  [v 8.0]
Opera -  N - Y  [v 9.0.0. 8501]
Comment 45 Peter E. Humphries 2011-11-17 09:58:29 PST
(In reply to R. Glass from comment #44)
> I have a website:
>    http://www.EspressoMyEspresso.com [call it EME]
> which redirects to:
>    http://www.frcndigital.com/coffee/Coffee.html [call it GD]

You are not exactly "redirecting;" you actually have GD in a frameset within EME.

So, there is no favicon for EME in either the default location (/favicon.ico) or specified in the HTML (rel=icon).  There is a favicon for GD (/coffee/coffee.ico, specified in the rel=icon tag).

I see the favicon for GD in FF8.  (You could add it to EME by copying the tag from the header on your FD page.)  Have you tried Safe Mode to ensure that one of your Add Ons is not interfering with favicons, as was the case for me?

To the status of this bug, it appears that we have a lot of attention to favicon behaviour because of the new blank dotted square, and that behaviour results _for sure_ from misconfigured web servers (comment 40) and bad images (comment 40, again) and, _potentially_, from a change in the way that Firefox updates its bookmark list favicons.

It is the bookmark behaviour that seems to be the current potential bug and, incidentally, the one to which this bug's title actually refers.  Again according to comment 40, there were no changes in this code; so, perhaps something to do with updating bookmarks in general is calling the favicon routines and the new blank icon is being loaded as if it were the favicon instead of being displayed when there is no favicon.

We really need a picture of someone's bookmarks with actual favicons (not the old default) before the FF8 update and with the dotted box (the new default) after the FF8 update.
Comment 46 schneidern 2011-11-18 21:32:21 PST
(In reply to Marco Bonardo [:mak] from comment #5)
> (In reply to Frédéric Buclin from comment #2)
> > An example of a page with a missing favicon? For instance:
> > http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/webtools/bugzilla/
> > Bugzilla/Bug.pm
> 
> This page doesn't seem have a favicon at all...
> 
> I found a bug, but it only involves a bookmark that has a uri that redirects
> to a page with an icon, the bookmark does not get the icon.
> If you have an example of a bookmark that doesn't get an icon, and the final
> uri is the same as the one in the bookmarks, I'd love to get a copy of
> places.sqlite, privately (by mail or on irc)

Bug 389642 concerns the case where a bookmarked URL redirects to a page with a favicon.
Comment 47 Peter E. Humphries 2011-11-19 16:59:03 PST
(In reply to Peter E. Humphries from comment #45)
> ...according to comment 40, there were no changes in this code...

Actually, I misspoke.  According to comment 13, setIcon's characteristics *have* changed.  I wonder if the bookmark code, like the problem Add On(s), is expecting the old behaviour.  Can anyone comment on that?
Comment 48 Liz Panton 2011-11-20 06:56:02 PST
(In reply to Peter E. Humphries from comment #45)

> We really need a picture of someone's bookmarks with actual favicons (not
> the old default) before the FF8 update and with the dotted box (the new
> default) after the FF8 update.

Do you mean images?  I have just done these for FF-8, FF-7.0.1 and FF-3.624 and I would say that my memory has been playing tricks on my and that the icons were gone for a long time, if they were ever there, but I didn't notice it ;-(

There is something about those new "dotty-line blank icons" that just hits you in the face as "something is wrong here!" whereas the old version looked like it was meant to be like that, so it didn't really register.

http://geekstreak.posterous.com/firefox-bookmarks-icons-mac-1058#!/slideshow

I use SeaMonkey as well and the default there (weird little tube thing?) is also rather horrid but at least it doesn't look like some sort of "error indicator", like the dotty-boxes do.
Comment 49 Peter E. Humphries 2011-11-20 07:31:15 PST
Your results illustrate what others have discovered upon systematic investigation: the favicons that are missing in FF8 are also missing in earlier versions.

If this bookmark bug is reproduce-able, ideally, someone who runs an earlier version on one machine and FF8 on another could get screen shots of both, illustrating that the favicon was captured by, say, FF3.6.23, and lost in FF8.

(The Add Ons issues with setIcon appear to have appeared with a change in FF7.0.1 because I only noticed the disappearing favicons when I upgraded from FF7.0 to FF8.0, but some report the same issue with FF7.0.1, I believe.)

Presumably, anyone running an earlier version on one machine but not on another has a reason to do so and would be unwilling to do a FF8 upgrade on that earlier version (especially if the bug is proven!), but that would be nice to see, too.
Comment 50 Frédéric Buclin 2011-11-20 10:34:27 PST
I just saw that when I access the Bugzilla documentation on my local installation, the favicon is not displayed in Firefox but is displayed in Opera and Chrome.

The base URL of my Bugzilla installation is https://localhost/bugzilla/. Here, all browsers display the favicon as expected (because we explicitly point to it in the HTML page). But when I go to https://localhost/bugzilla/docs/, only Opera 11.52 and Chrome 15 display the favicon; Firefox 8.0.1 ignores it, despite the favicon is located at /var/www/html/favicon.ico. Note that this is not new as Firefox 3.6 ignores it too, so this case is unrelated to the upgrade to Fx 8, but is still annoying.
Comment 51 Peter E. Humphries 2011-11-20 10:49:18 PST
(In reply to Frédéric Buclin from comment #50)
> ...we explicitly point to it in the HTML page...

Are you sure that the link in the HTML from your https://localhost/bugzilla/docs/ is not a relative link pointing to the wrong spot?  I thought that I had found a couple of cases illustrating favicon problems only to discover that the link to the favicon was wrong.
Comment 52 Frédéric Buclin 2011-11-20 10:53:59 PST
(In reply to Peter E. Humphries from comment #51)
> Are you sure that the link in the HTML from your
> https://localhost/bugzilla/docs/ is not a relative link pointing to the
> wrong spot?

This is not a HTML file, it's a directory, and so has no link to any favicon. HTML files in this directory have no link to any favicon either. So by default, it should fallback to the default favicon located in the root directory of the web server IMHO (and so would be consistent with Opera and Chrome).
Comment 53 Peter E. Humphries 2011-11-20 11:07:12 PST
(In reply to Frédéric Buclin from comment #52)
> This is not a HTML file, it's a directory...

Tricky...  Does Firefox (in its various versions) display its default icon or a special icon, in this instance?  Depending upon how you are browsing a directory, Firefox has different icons that it displays.

In your first example ( https://localhost/bugzilla/ ), you *are* retrieving a HTML file, the default index file.  In your second example ( https://localhost/bugzilla/docs/ ), are you returning simply a directory listing?
Comment 54 Frédéric Buclin 2011-11-20 11:14:06 PST
(In reply to Peter E. Humphries from comment #53)
> In your first example ( https://localhost/bugzilla/ ), you *are* retrieving
> a HTML file, the default index file.  In your second example (
> https://localhost/bugzilla/docs/ ), are you returning simply a directory
> listing?

Correct. And viewing any HTML file in this docs/ directory gives the same result. None of them has any reference to a favicon.
Comment 55 Peter E. Humphries 2011-11-20 11:36:39 PST
I am interested to know what HTML you get back when you browse your "docs" directory.  Have a look at the Bugzilla site:

http://www.bugzilla.org/docs/4.0/

That is just an example URL; you can browse up and down any help link from the site and see that you sometimes get HTML with favicon links specified and sometimes without (when there is no index.html file to return).

On the bugzilla.org site, FF8 always displays the correct favicon, which is sometimes the default /favicon.ico file and sometimes the specified /img/bugzilla_icon.png file.  It is always the site's favicon, not a default or other Firefox icon.  This makes me wonder if your experience falls into the "web server configuration" case that I noted as one of the bug bins (comment 45); this may be an artefact of using a local server or your local server, specifically (I am not trying to trivialize your contribution to the discussion but to find out more about the bug).
Comment 56 Marco Bonardo [::mak] 2011-11-21 05:37:03 PST
please stop going off topic, if something happens in previous versions as well, then it's not this bug and you are just adding noise that is not useful for the solution of the bug.
Comment 57 Peter E. Humphries 2011-11-21 06:37:20 PST
I have to disagree, Marco.  It appears that this bug may have been introduced in FF7.0.1, but if it is related to a long standing FF behaviour instead of a specific change in, for example, setIcon, that would help those trying to reproduce it to focus on more specific use cases.
Comment 58 Marco Bonardo [::mak] 2011-11-21 07:15:46 PST
The setIcon() change is there from a long time, the fact some add-ons use an old overlay from firefox _3.5_ is not a reason to point at it, by itself. May be related, but we can't cope with badly compatible-marked add-ons.

Btw, I was referring to your discussion about local folders or html files that never has an icon. If it did not have an icon in previous versions and it does not have an icon today, it's off topic for this bug. File a separate bug to discuss that stuff please.
Comment 59 Peter E. Humphries 2011-11-21 11:34:24 PST
If the Add Ons, such as Favicon 2 Picker, are any indication, *something* changed in the FF7.0.1 release that *may* be related to the bookmark icon issue (if there *is* a bookmark icon issue).  If setIcon's specification changed a long time ago, why did an Add On like Favicon 2 Picker continue to work until the FF7.0.1 update?

I think that there is a good chance that that could point us to, if not a solution, at least an avenue by which we might explore the use case(s) that could recreate this issue (again, if it really is an issue).

It would be great to hear back from users Wes and lwz to find out if they have confirmed the problem on their installations.
Comment 60 lwz 2011-11-22 01:31:12 PST
I have not much more to add, as I have checked and it was right that what is shown in Firefox 7.0.1 is the default favicon, just that the new dotted box makes it much more obvious. I think my bug (for the www.google.com entry) is this: https://bugzilla.mozilla.org/show_bug.cgi?id=389642. Sorry for the confusion.
Comment 61 Marco Bonardo [::mak] 2011-11-22 02:30:12 PST
(In reply to Peter E. Humphries from comment #59)
> If the Add Ons, such as Favicon 2 Picker, are any indication, *something*
> changed in the FF7.0.1 release that *may* be related to the bookmark icon
> issue (if there *is* a bookmark icon issue).  If setIcon's specification
> changed a long time ago, why did an Add On like Favicon 2 Picker continue to
> work until the FF7.0.1 update?

Maybe it didn't, but the new icon made that evident on 8, while it mas a masked problem before.
Otherwise, there is still the possibility some callpoint invoking setIcon started passing into a nsIURI when it was previously passing a string. Even in this case it would be a bug in the add-on. Btw, I checked code invoking setIcon() and the last changes were in firefox 4.
Comment 62 Peter E. Humphries 2011-11-22 07:01:04 PST
(In reply to Marco Bonardo [:mak] from comment #61)
> ...a masked problem before.

No, something definitely changed between FF7.0 and FF8.0, and it appears to have changed at FF7.0.1 (from the reports on Favicon Picker 2 -- I did not install FF7.0.1).  *My* original bug report (the Address Bar and tab icons disappearing) was a conflict between Favicon Picker 2 and FF8.0, solved by disabling the Add On, Favicon Picker 2.

> ...some callpoint invoking setIcon started passing into a nsIURI
> when it was previously passing a string. Even in this case it would
> be a bug in the add-on.

*If* the original bug report cannot be reproduce, I agree that the problem is Add On compatibility. However, the Add On worked until FF7.0.1.

> Btw, I checked code invoking setIcon() and the last changes were in firefox 4.

Favicon Picker 2 was *not* interfering with favicon display before FF7.0.1.  However, it may be true that the code change is not in the "vicinity" of the bookmark routines, and it may also be true that it is not setIcon(), itself, that is directly involved.

I do not intend to be adversarial, especially since the Bugzilla community has been perfectly efficient at solving my problem, but I think that there is still a mystery code change out there that could come back to bite other Add Ons and FF, itself, if we close this bug without finding it.
Comment 63 Marco Bonardo [::mak] 2011-11-22 07:17:53 PST
(In reply to Peter E. Humphries from comment #62)
> However, the Add On worked until FF7.0.1.

Since the add-on code is wrong, it would have happened soon or later.

> but I think that there
> is still a mystery code change out there that could come back to bite other
> Add Ons and FF, itself, if we close this bug without finding it.

Nobody said the opposite. So you may start testing the mozilla-central nightlies that brought to 8.0 with the FP2 extension (nightlies between half of July and end of August, from ftp://ftp.mozilla.org/pub/firefox/nightly/2011/) and find a somehow restrict range when your issue starts happening.
Comment 64 Peter E. Humphries 2011-11-22 07:56:39 PST
Thanks.  I will test FF7.0 and FF7.0.1 to confirm that the change takes place between those two releases and then work my way in from the ends.

I might not report back for a while... :-)
Comment 65 Ed Morley [:emorley] 2011-11-22 07:58:12 PST
(In reply to Peter E. Humphries from comment #64)
> Thanks.  I will test FF7.0 and FF7.0.1 to confirm that the change takes
> place between those two releases and then work my way in from the ends.

Mozregression will speed this up for you :-)
http://mozilla.github.com/mozregression/
Comment 66 Peter E. Humphries 2011-11-22 09:16:23 PST
Thanks, Ed.  I have not tried that, before; I will give it a spin.
Comment 67 Ivan Van Laningham 2011-11-29 13:22:27 PST
Looks to me like FF 8 doesn't support .ico files.  This works in IE8:

<link rel='shortcut icon' href='/images/overstock-logo-16.ico'>

This works in FF8:

<link rel='icon' type='image/png' href='/images/overstock-logo-16.png'>

Put them in the same html page and the favicon always shows up in both browsers.
Comment 68 Peter E. Humphries 2011-11-30 13:36:44 PST
Ivan, that could be a server configuration problem (see comment 40).

This page, for example, uses <link rel="shortcut icon" href="extensions/BMO/web/images/favicon.ico"> in its header.
Comment 69 Julius 2011-12-07 12:23:19 PST
I never had the problem in Firefox 8.0, but I have it in FireFox 9.0 beta. I created a brand new profile and reloaded bookmarks using Xmarks, and I still get icons missing from the Bookmarks menu (the space where the icon should be is totally blank and the space where an icon never existed shows the antbox).

The favicons are still stored, they are just not displaying. Every once in a while the icons will all display in the menu like normal, and then disappear a few clicks later.

The only add-ons I am running are Xmarks, DownThemAll and Snagit Autoscroll.
Comment 70 Julius 2011-12-07 12:57:11 PST
Created attachment 579802 [details]
Screenshot of Favicons in Bar but not in Bookmarks

Firefox 9.0 beta 5 (build1)
Comment 71 Marco Bonardo [::mak] 2011-12-07 16:26:19 PST
(In reply to Julius from comment #69)
> I never had the problem in Firefox 8.0, but I have it in FireFox 9.0 beta. I
> created a brand new profile and reloaded bookmarks using Xmarks

I don't know how Xmarks synchronizes icons, so there may just be a bug in it, it's not something we do yet, Sync is looking into adding support for that.
Comment 72 Julius 2011-12-08 08:46:00 PST
Marco, I don't know if the problem is related to Xmarks. I just created a brand new profile (no extensions), navigated to wsj.com and bookmarked it to the bookmarks menu. The favicon displays in the tab and it displays to the left of the URL but it does not display in the bookmarks menu (the space next to the bookmark is blank).
Comment 73 Marco Bonardo [::mak] 2011-12-09 05:36:49 PST
(In reply to Julius from comment #72)
> Marco, I don't know if the problem is related to Xmarks. I just created a
> brand new profile (no extensions), navigated to wsj.com and bookmarked it to
> the bookmarks menu.

I just did the same, and I see the icon correctly :/
Comment 74 Eli Greenberg 2011-12-20 01:22:15 PST
I can confirm this occurs in the 9.0 release for Mac
Comment 75 Marco Bonardo [::mak] 2011-12-20 04:29:32 PST
please define "this", what happens to you in the 9.0 release? how does it differ from 8.0? which add-ons you have? Did you verify that's not an effect due to the new empty favicon? Can you point out the address of a page where you see the problem?
Comment 76 Shadesh 2011-12-20 08:17:43 PST
Can it also confirm that no icons in bookmarks menue visible.
Firefox 9 on OS X 10.7. Was ok with the 8.* versions
Comment 77 Mario Grgic 2011-12-20 17:57:57 PST
Created attachment 583357 [details]
Firefox 9.0 on Mac OS X 10.6.8 showing missing bookmarks menu icons, but they do show in the bookmarks sidebar
Comment 78 Tim (fmdeveloper) 2011-12-20 19:34:31 PST
*** Bug 712496 has been marked as a duplicate of this bug. ***
Comment 79 Marco Bonardo [::mak] 2011-12-21 03:35:54 PST
(In reply to Mario Grgic from comment #77)
> Created attachment 583357 [details]
> Firefox 9.0 on Mac OS X 10.6.8 showing missing bookmarks menu icons, but
> they do show in the bookmarks sidebar

is this in safe mode?
Comment 80 Mario Grgic 2011-12-21 04:15:06 PST
This happens both in safe mode and otherwise. I have upgraded 6 macs so far (all different hardware) and different set of extensions and immediately after upgrade they all lost icons in the system menu/bookmarks and nowhere else. I have confirmed this happens on both OS X 10.6.8 and 10.7.2. 

Note also this does not happen (all icons show in all places including menu/bookmarks) with Firefox 9.0 on Windows 7 Enterprise 64 bit. So this seems to Mac OS X specific problem.
Comment 81 Marco Bonardo [::mak] 2011-12-21 04:48:27 PST
hm, then what you are reporting IS NOT this bug, looks like a regression in the native menu binding. I'm reopening your bug.
Comment 82 Don Goldberg 2011-12-25 12:26:41 PST
I am having this happen on my iMac running OS 10.6.8 with Firefox 9.0.1, and I have noticed some variances with my copy. Favicons in the Bookmarks menu will come and go, appearing and disappearing as I go between pages and sites, and bookmarks for pages on Apple's website will often receive a different favicon than the current design. (The current design has a white Apple logo on a grey box; the replacement is a grey logo with no box.)
Comment 83 Marco Bonardo [::mak] 2011-12-27 06:41:16 PST
This bug is sadly becoming a catch-all favicons issues bug, the last reports are just affecting FF9 and due to the missing patch from bug 705516. NOT related to this bug at all.

I know this may be annoying, but at this point we should evaluate resolving as incomplete, since apart incompatible add-ons, more confusing default icon, and Sync adding history/bookmarks without icons, we still don't have any useful data to debug the original issue.
We should get separate reports with decent steps or pages to reproduce.
Comment 84 Alex Keybl [:akeybl] 2012-01-06 09:03:19 PST
(In reply to Marco Bonardo [:mak] from comment #83)
> This bug is sadly becoming a catch-all favicons issues bug, the last reports
> are just affecting FF9 and due to the missing patch from bug 705516. NOT
> related to this bug at all.

Given the fact that the majority of reported instances were resolved in bug 705516, untracking for 10/11.
Comment 85 David 2012-01-22 08:22:01 PST
Having read through all the comments on here, I'm no further forwards with resolving the issue of why all my favicons (hundeds of them) are now missing from the Firefox 8.0.1 bookmark menu. About two versions ago, I installed Favicon Picker 2 which was great and meant I had an icon for every bookmark saved and for websites not having a favicon, I could add my own. Result! So my question is simply this: Is there an equivalent of Favicon Picker 2 that works with Firefox V8.0.1?
Comment 86 Julius 2012-01-23 06:32:31 PST
As previous people have mentioned, this bug has become a catch all for multiple favicon bugs. I don't know which bug you specifically encountered, but this change to prefs solved my icons disappearing in Firefox 9.0:

In the Location bar, type about:config and press Return.
The about:config "This might void your warranty!" warning page may appear. #Click I'll be careful, I promise!, to continue to the about:config page.
In the filter section type, image.mem.decodeondraw
Double-click the entry that results to change it's value to "False"

As posted by Verdi on this thread:

https://support.mozilla.org/en-US/questions/896163?page=1
Comment 87 Michael Marcus 2012-01-23 09:09:56 PST
Well, I figured that I would show a clear example of the issue. Note that I have previously tested Firefox with all add-ons disabled, then run Checkplaces to update all favicons for all bookmarks, restarted Firefox again with all add-ons disabled, only to discover that favicons for web sites would magically disappear. Others had reported the same.

So this time I decided to see if Firefox does not correctly update changed favicons the first time a URL is browsed. I got this idea after loading a bookmark and noting that Firefox in URL bar did update the site's favicon but that the missing favicon for the URL in my bookmarks was not updated. I clicked on the bookmarked URL in my Bookmarks a second time and noted that on the second time the favicon for the bookmarked URL was properly updated.

Now I ran Checkplaces with Checkplaces configured to update the favicons for all URLs. I saved a screen capture of the results for one bookmark folder before closing Firefox. The following screen capture applies to the scenario of using Checkplaces to update all favicons before closing Firefox and then again after restarting Firefox:

http://www.mem-tek.com/firefox/Image1.gif

I then decided to go to a web site in this folder for which I knew that the favicon had been changed since when the bookmark was originally created. I have indicated this web site in the above image via a red box around the web site's name in the bookmark folder. After clicking on this web site in the bookmark folder, I noted that Firefox immediately loads the new favicon for the web site even though Firefox via Checkplaces did not load the new favicon the first time the web site was browsed during the previous Firefox session. Note that Rembember History is turned on in my Firefox settings but not in my Firefox Sync settings. Here is the screen shot for the same URL in the above screen shot, and note that the web site's favicon this time was correctly updated upon visiting the bookmarked URL a second time:

http://www.mem-tek.com/firefox/Image2.gif

Note that I immediately experienced the bookmark favicon issue after Firefox was upgraded to version 8, but also note that I experienced the issue before activating and configuring Firefox Sync. So I guess Sync is not the cause of this issue.

All I know for sure is that the favicon issue was not present in FF7. After Firefox was upgraded to FF8, I tried copying a saved copy of places.sqlite back into the FF8 profile. All of the web site favicons were back. Then in FF8 I would watch favicons magically disappear for many bookmarks which I subsequently clicked on while using FF8.
Comment 88 David 2012-01-26 11:38:38 PST
Further to my last post 85. I'm still having all sorts of grief with bookmarks and favicons in V8.0.1 but made a discovery today. In the bookmarks menu, there is an option to export bookmarks in HTML. Did that and then examined the file in Wordpad. There was far more stuff in there than I expected and a lot of it obviously corrupted. So for the techies out there, does this file try to save the favicon in base 64? The working bookmark favicons made sense but the blank ones either had no data or were obviously corrupted (lots of /////// etc).
Comment 89 David 2012-01-29 04:24:58 PST
Happy man! All sorted and no Firefox instabilities any more. Follows posts 85;88. The HTML bookmark file has a structure that saves the bookmark link, creation date, any update date, favicon address url, the favicon stored in base 64 followed by the text displayed as the link. Spent a happy couple of hours stripping out all the favicon stuff with Notepad. Some was definitely corrupted. 

Given a clean file, I renamed it and then imported back into Firefox. Now had a full set of blank icons. Also had a placessql.corrupt file which was deleted. After that, each favicon would be restored when visited? No!

In my case, another forum suggested trying to load a known good favicon and then pressing F5 to refresh it. www.google.com/favicon.ico seemed a good place to start. In my case, it didn't display and I got a 'blocked by proxy' message. So it turned out that my PAC file (used as a proxy to block adverts and trackers) had a line to block .ico files too. All my icon 'friends' are now back though it's taken hours to solve and fix. Hope this helps.
Comment 90 Michael Marcus 2012-01-30 08:33:28 PST
I did some more testing to follow up on my previous post. Following is an example of a favicon not loading in Firefox whereas the favicon does load in IE8. The issue seems to be due to the use of code which is tailored for IE and which is not part of the HTML5 specification. But unfortunately most web developers still only verify compatibility with IE rather than also verifying compatibility with other web browsers. This situation is exacerbated by commercial web development tools which also are designed to produce IE compatible code.

The example URL for which the specified favicon in the page code displays in IE yet not in Firefox is:

http://www.wsbtv.com/s/weather/interactive-radar/#at=0&

When loading the above URL or when refreshing the above URL (reloading the page) in Firefox, the favicon briefly appears in Firefox's navigation bar and then disappears. Yet of course the favicon is properly displayed in IE when loading or refreshing the page for the above URL. A look at the source code for the above URL might help Firefox's developers resolve the favicon issue which has cropped up in the latest Firefox releases.

Looking at the page source code for the above URL and for the the web site's home page (www.wsbtv.com), one sees that the code only uses IE7+ compatible methods for loading a favicon for the web page. Apparently both web developers and the commercial developers of web page authoring tools are following Microsoft's recommendations for adding favicons. See this Microsoft documentation about shortcut icons, and keep in mind that the described methods are not HTML5 compatible and are not even compatible with the now depreciated IE6:

http://msdn.microsoft.com/en-us/library/ie/ms537656%28v=vs.85%29.aspx#About_Shortcut_Icons

This whole mess was created by Microsoft in support of web developers who wanted to have dynamically changing favicons within a web site in order to either indicate different types of site content or to get the viewer's attention. Or perhaps Microsoft created this mess in order to be able to change the displayed favicon for portions of Microsoft's own web sites, or maybe to speed up the depreciation of IE6 since the methods in the above Microsoft URL do not work with IE6.

Thus Firefox must incorporate non-HTML5 code in order to properly display favicons for web sites which only use IE7+ compatible methods for displaying web page favicons, while keeping in mind exactly what Firefox behavior is desired when browser.chrome.favicons is set to true (default) or false, while keeping in mind that some web developers now are using scripts to load favicons, and while keeping in mind that URLs are now being used to load page favicons from off-site locations.

Just some thoughts for what they are worth.
Comment 91 David Hetherington 2012-02-20 14:41:49 PST
I have a simple example that I think is the same bug. See my (tiny) company website:

   http://AsattePress.com

- Favicon is OK with Firefox for Windows (latest version 10.0.2 I think)
- Favicon is NOT OK with Firefox for MacOS (10.0.2)
- Favicon is OK with Chrome for MacOS
- Favicon is OK with Safari for MacOS
- Favicon is OK with all the Windows Browsers.

This is a very simple 16x16 Favicon, no multiple images. It is in the root
directory of the web site, no funny redirections...

Of course, it is my first favicon...perhaps I missed some magic incantation
that is needed only for Firefox on MacOS?

??

Thanks,

David Hetherington
Comment 92 Masatoshi Kimura [:emk] 2012-02-20 14:54:29 PST
If it is bug 705516, it will be fixed in Firefox 11.
Comment 93 Michael Marcus 2012-02-20 20:12:17 PST
(In reply to David Hetherington from comment #91)
> I have a simple example that I think is the same bug. See my (tiny) company
> website:
> 
>    http://AsattePress.com
> 
> - Favicon is OK with Firefox for Windows (latest version 10.0.2 I think)
> - Favicon is NOT OK with Firefox for MacOS (10.0.2)
> - Favicon is OK with Chrome for MacOS
> - Favicon is OK with Safari for MacOS
> - Favicon is OK with all the Windows Browsers.
> 
> This is a very simple 16x16 Favicon, no multiple images. It is in the root
> directory of the web site, no funny redirections...
> 
> Of course, it is my first favicon...perhaps I missed some magic incantation
> that is needed only for Firefox on MacOS?
> 
> ??
> 
> Thanks,
> 
> David Hetherington

Hi David,

Your present favicon.ico for your web site is 16x16 256 colors. Try converting it to 16x16 with true color (24-bit color), upload it, and see if the new favicon version works okay with Firefox for MacOS. If the new favicon does work okay, then in my opinion you have confirmed a bug. Technically, favicons are supposed to be true color. As far as I am aware, IE has always supported 256 color favicons, harkening back to the old days of 256 color graphics cards and EGA monitors.
Comment 94 Marco Bonardo [::mak] 2012-02-21 02:11:14 PST
(In reply to David Hetherington from comment #91)
> I have a simple example that I think is the same bug. See my (tiny) company
> website:

comment 92 is right for your case.
Comment 95 Marco Bonardo [::mak] 2013-02-12 07:37:03 PST
please file new separate bugs for single cases still existing, this bug as-is is sadly totally useless.

Note You need to log in before you can comment on or make changes to this bug.