Render bug cause white glowing inner border around the page in Firefox 8.0

RESOLVED DUPLICATE of bug 701528

Status

()

Core
Layout: View Rendering
RESOLVED DUPLICATE of bug 701528
7 years ago
7 years ago

People

(Reporter: saix, Unassigned)

Tracking

({regression})

8 Branch
x86
Windows Vista
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments, 1 obsolete attachment)

9.34 KB, image/png
Details
4.11 KB, image/png
Details
(Reporter)

Description

7 years ago
Created attachment 573505 [details]
Top/left white glow

In Firefox 8.0 some pages show white glowing inner border around the page, see attachment (screenshots taken from http://www.zing.cz as an example). This border seem to be wrapping relatively positioned elements "at the top of the page". 

This glow keeps moving down while scrolling until it disappears at no specific area I could point. When scrolling back on top of the page, glow sometimes disappers, sometimes not. Feels like faster I scroll the bigger chance of shaking this glow off is.

Since I ran into the same exact problem within my project I've been localy developing for some time now, I've tried to find some similarities with both pages. I've noticed, both pages have the fixed background followed by relatively postioned div with main content. Since I've removed "position: relative" from the wrapping div, glow went gone, but page layout got broken as expected.

Unfortunately, whatever I've tried, I haven't been able to reproduce this bug on the simple page and I can't provide my project. Although this bug is visible on the previously mentioned URL as well.

Comment 1

7 years ago
Created attachment 573630 [details]
white glow 1

Comment 2

7 years ago
Created attachment 573631 [details]
white glow 2
Attachment #573505 - Attachment is obsolete: true

Comment 3

7 years ago
Cannot reproduce on XP
Component: General → Layout
Keywords: regression
Product: Firefox → Core
QA Contact: general → layout
roc, tn, any idae?
Component: Layout → Layout: View Rendering
QA Contact: layout → layout.view-rendering
Things that might be helpful: an exact regression range, simplifying the page that shows the problem, testing with or without hardware acceleration to see if the problem still happens.
(Reporter)

Comment 7

7 years ago
Looks like that, however it's much more visible in my case. I can confirm, without hardware acceleration, there's no line or glow described above. I haven't change or update any hardware or drivers. Before last auto update from release channel it worked fine. If any specific sw/hw is requested, I'll be helpful as much as I could.
Can you paste the contents of the "Graphics" section of about:support?
(Reporter)

Comment 9

7 years ago
Popis adaptéru: NVIDIA GeForce GTX 580
Id výrobce: 10de
Id zařízení: 1080
RAM adaptéru: 1536
Ovladače adaptéru: nvd3dum nvwgf2um,nvwgf2um
Verze ovladače: 8.17.12.7533
Datum ovladače: 5-20-2011
RAM adaptéru (GPU #2): Unknown
Ovladače adaptéru (GPU #2): Unknown
Direct2D povolen: true
DirectWrite povolen: true (7.0.6002.18409)
Technologie ClearType: Parametry technologie ClearType nenalezeny
Zobrazování WebGL: Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.686)
Grafická akcelerace Windows: 1/1 Direct3D 10
(Reporter)

Comment 10

7 years ago
Driver update, the problem still persists
Verze ovladače: 8.17.12.8562
Datum ovladače: 10-15-2011
(Reporter)

Comment 11

7 years ago
Ooops, now I've actually noticed, this info is written in my native language since Firefox is localized. I hope you get around that.
Almost certainly fixed by the patch for bug 701528
(Reporter)

Comment 13

7 years ago
Bug 701528 is exactly the same problem as mine. My bug report is older though. However you end up with some resolution there and got more details on problem. So I'm not sure if I should mark this one as duplicate, flag as resolved or just leave it .) Anyway I'm glad this issue has been confirmed and will be taken care of. Thanks.
The issue as that Robert couldn't reproduce this bug, as I understand....

What you should do, if you're willing, is to try a build with the fix for bug 701528, once one is available, and comment here whether that build fixes this bug for you.  That would be really helpful!

Comment 15

7 years ago
Bug 701528 is fixed in Nightly of tomorrow, please test!
http://nightly.mozilla.org/

Comment 16

7 years ago
> However you end up with some resolution there and got more details on problem.

> "This glow keeps moving down while scrolling until it disappears at no specific 
> area I could point. When scrolling back on top of the page, glow sometimes 
> disappers, sometimes not. Feels like faster I scroll the bigger chance of shaking 
> this glow off is."

same behavior i observed with bug 675497 (part 1) which i can verify fixed/dupe Bug 686121.
(Reporter)

Comment 17

7 years ago
Yesterday build wasn't fixed yet but I've just got nightly 11.0a1 (2011-11-15) minutes ago which I can confirm, resolved this issue! Thanks. Although I hope little selfishly for patch being include in beta .)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
Thank you for checking that!
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 701528
You need to log in before you can comment on or make changes to this bug.