Addons wrongly reported as incompatible during upgrade

NEW
Unassigned

Status

()

7 years ago
7 years ago

People

(Reporter: ws.bugzilla, Unassigned)

Tracking

Trunk
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 573560 [details]
List of incompatible addons just before the upgrade

This has happened every time I upgraded since Firefox 4 or so: the prompt that suggests I upgrade lists a bunch of addons as incompatible, when they are actually compatible.

I don't know how to attempt to reproduce this in a nightly, so all I have is the results for the 7->8 upgrade I just did.
(Reporter)

Comment 1

7 years ago
Created attachment 573562 [details]
List of incompatible addons just after the upgrade

Comment 2

7 years ago
https://addons.mozilla.org/en-us/firefox/addon/flash-video-downloader-youtube/versions/ says Flash Video Downloader - Youtube Downloader version 2.0.33, the one in attachment 573560 [details], works with Works with Firefox 3.0 - 7.*.

https://addons.mozilla.org/en-US/firefox/addon/firepicker/versions/ says Firepicker version 1.3.6, the one in attachment 573560 [details], works with Firefox 3.5 - 8.0a1. (Yes, 8.0a1 - that's not 8.*)

https://addons.mozilla.org/en-US/firefox/addon/open-in-browser/versions/ says Open in Browser version 1.11, the one shown in attachment 573560 [details], works with Firefox 3.6 - 8.0a1. (Yes, 8.0a1 - that's not 8.*)

So, I don't really see what the bug is.
(Reporter)

Comment 3

7 years ago
The bug is that before the update I'm told that a certain addon will be disabled, which ends up not being disabled. The implication is that a compatible update is not available at this stage.

I have a suspicion that the compatibility check before the upgrade is performing as designed, but the design is not ideal: the user doesn't want to know if the currently installed version is compatible; rather, whether one that *is* compatible has already been published.
You need to log in before you can comment on or make changes to this bug.