Last Comment Bug 701458 - Enter compartment while initializing in CreateDedicatedWorkerGlobalScope
: Enter compartment while initializing in CreateDedicatedWorkerGlobalScope
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: unspecified
: x86 Mac OS X
: -- normal (vote)
: mozilla11
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-10 11:34 PST by Brian Hackett (:bhackett)
Modified: 2011-11-11 02:19 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (779 bytes, patch)
2011-11-10 11:34 PST, Brian Hackett (:bhackett)
no flags Details | Diff | Splinter Review

Description Brian Hackett (:bhackett) 2011-11-10 11:34:48 PST
Created attachment 573582 [details] [diff] [review]
patch

CreateDedicatedWorkerGlobalScope makes some JS API calls without entering the appropriate compartment.  JS doesn't catch this because the cross compartment assertions are too weak (bug 701427).
Comment 1 Brian Hackett (:bhackett) 2011-11-10 12:05:18 PST
Comment on attachment 573582 [details] [diff] [review]
patch

Got r+ earlier over IRC.

https://hg.mozilla.org/integration/mozilla-inbound/rev/6da51a2cebb0
Comment 2 Marco Bonardo [::mak] 2011-11-11 02:19:46 PST
https://hg.mozilla.org/mozilla-central/rev/6da51a2cebb0

Note You need to log in before you can comment on or make changes to this bug.