Thunderbird ftp download fails

RESOLVED DUPLICATE of bug 694798

Status

mozilla.org
FTP: Mirrors
RESOLVED DUPLICATE of bug 694798
6 years ago
6 years ago

People

(Reporter: Todd, Unassigned)

Tracking

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux i686; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110928134238

Steps to reproduce:

Would you please correct ftp access to 

ftp://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/8.0/linux-x86_64/en-US/thunderbird-8.0.tar.bz2

http access does work.

Many thanks,
-T
(Reporter)

Comment 2

6 years ago
(In reply to Tim (fmdeveloper) from comment #1)
> The correct link is
> ftp://releases.mozilla.org/mozilla.org/thunderbird/releases/8.0/linux-x86_64/
> en-US/thunderbird-8.0.tar.bz2
> 
> How did you get to the ftp link provided?

I got it by browsing with Firefox.  The link you gave me, without the "/pub", gives "unable to change directory".  Your link does not work in http either

Take a peak at my link with http instead of ftp:

http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/8.0/linux-x86_64/en-US
/thunderbird-8.0.tar.bz2

The link just doesn't work with ftp.

Comment 3

6 years ago
Clicking on the link does give the error. Not sure if that is by design...

If I start at ftp://releases.mozilla.org and click through the path it works...

Guessing at the best component to get feedback
Assignee: nobody → server-ops
Component: General → FTP: Mirrors
Product: Firefox → mozilla.org
QA Contact: general → mrz
Version: 8 Branch → other
releases.mozilla.org is multiple machines, so the problem might appear intermittent depending on which IP you get. In this case the two machines returning 550 errors (can't change directory) for the path in comment #0 are
  129.101.198.59 / mirror2.its.uidaho.edu
  155.98.64.83   / mozilla.cs.utah.edu
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Thunderbird ftp download crashes → Thunderbird ftp download fails
(Reporter)

Comment 6

6 years ago
(In reply to Dumitru Gherman [:dumitru] from comment #5)
> Both seem to work for me.
> 
> http://mirror2.its.uidaho.edu/pub/mozilla.org/thunderbird/releases/8.0/linux-
> x86_64/en-US/thunderbird-8.0.tar.bz2
> http://mozilla.cs.utah.edu/pub/mozilla.org/thunderbird/releases/8.0/linux-
> x86_64/en-US/thunderbird-8.0.tar.bz2
> 
> Is this still an issue?

These links always worked under http://, retry your test under ftp://.  Also, the problem with some of your mirrors not supporting ftp.


$ wget --output-document thunderbird-8.0.tar.bz2 ftp://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/8.0/linux-x86_64/en-US/thunderbird-8.0.tar.bz2
--2011-11-14 09:17:24--  ftp://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/8.0/linux-x86_64/en-US/thunderbird-8.0.tar.bz2
           => `thunderbird-8.0.tar.bz2'
Resolving releases.mozilla.org... 202.177.202.154, 204.152.184.113, 204.152.184.196, ...
Connecting to releases.mozilla.org|202.177.202.154|:21... connected.
Logging in as anonymous ... Logged in!
==> SYST ... done.    ==> PWD ... done.
==> TYPE I ... done.  ==> CWD /pub/mozilla.org/thunderbird/releases/8.0/linux-x86_64/en-US ... done.
==> SIZE thunderbird-8.0.tar.bz2 ... 20886942
==> PASV ... couldn't connect to 202.177.202.154 port 54987: Connection refused
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 694798
You need to log in before you can comment on or make changes to this bug.