algorithm for resolving erroneous column width specifications

VERIFIED DUPLICATE of bug 69743

Status

()

Core
Layout: Tables
VERIFIED DUPLICATE of bug 69743
17 years ago
16 years ago

People

(Reporter: Ian A. Marsman, Assigned: karnaze (gone))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
The site at http://www.chapters.ca does not display correctly in Mozilla. I
think it is due to an error in column width settings for the table row
containing the tab images for the category tab-bar. One column is set to 100%,
while the other is set at 642 pixels. The result is a pileup of the tabs
vertically rather than a horizontal ordering. The relevant HTML is listed at the
bottom of this text. IE does not have a problem with this, probably because it
removes 642 pixels from whatever 100% would be. I have told the company about
this problem and given a fix I have tested (remove the relevant width="100%"),
but they were bought out recently and are probably busy. If the behaviour I
think IE uses is a safe one, perhaps Mozilla could adopt it.


<tr>
<td COLSPAN="2">
<table WIDTH="100%" CELLPADDING="0" CELLSPACING="0" BORDER="0">
<tr>
<td VALIGN="Bottom" ALIGN="Left" WIDTH="100%">
<table WIDTH="100%" BORDER="0" CELLSPACING="0" CELLPADDING="0">
<tr>
<td HEIGHT="1" BGCOLOR="#000000"><img
SRC="/Images/Header/SingleTransparentPixel.gif" HEIGHT="1" WIDTH="1"></td>
</tr>
</table>
</td>
<td ALIGN="Right" WIDTH="642" NOWRAP>
<a
HREF="http://www.chapters.ca/Welcome/Default.asp?WSID=230271C83432F0174255B924C6CE5AC40A081225&mscssid=9E6TU7LU4EJF9PE8EN4KSHK4V3KSBXN9"
STYLE="color:Maroon"><font COLOR="#990033"><b><img
SRC="/Images/Header/tabs_welcome_on.gif" BORDER=0 WIDTH=54 HEIGHT=23
ALT="Home"></b></font></a><a
HREF="http://www.chapters.ca/Books/Default.asp?WSID=230271C83432F0174255B924C6CE5AC40A081225&mscssid=9E6TU7LU4EJF9PE8EN4KSHK4V3KSBXN9"
STYLE="color:Maroon"><font COLOR="#990033"><b><img
SRC="/Images/Header/tabs_books_off.gif" BORDER=0 WIDTH=54 HEIGHT=23
ALT="Books"></b></font></a><a
HREF="http://www.chapters.ca/Magazines/Default.asp?WSID=230271C83432F0174255B924C6CE5AC40A081225&mscssid=9E6TU7LU4EJF9PE8EN4KSHK4V3KSBXN9"
STYLE="color:Maroon"><font COLOR="#990033"><b><img
SRC="/Images/Header/tabs_magazines_off.gif" BORDER=0 WIDTH=70 HEIGHT=23
ALT="Magazines"></b></font></a><a
HREF="http://www.chapters.ca/Music/Default.asp?WSID=230271C83432F0174255B924C6CE5AC40A081225&mscssid=9E6TU7LU4EJF9PE8EN4KSHK4V3KSBXN9"
STYLE="color:Maroon"><font COLOR="#990033"><b><img
SRC="/Images/Header/tabs_music_off.gif" BORDER=0 WIDTH=54 HEIGHT=23
ALT="Music"></b></font></a><a
HREF="http://www.chapters.ca/Video/Default.asp?WSID=230271C83432F0174255B924C6CE5AC40A081225&mscssid=9E6TU7LU4EJF9PE8EN4KSHK4V3KSBXN9"
STYLE="color:Maroon"><font COLOR="#990033"><b><img
SRC="/Images/Header/tabs_video_off.gif" BORDER=0 WIDTH=54 HEIGHT=23
ALT="Video"></b></font></a><a
HREF="http://www.chapters.ca/DVD/Default.asp?WSID=230271C83432F0174255B924C6CE5AC40A081225&mscssid=9E6TU7LU4EJF9PE8EN4KSHK4V3KSBXN9"
STYLE="color:Maroon"><font COLOR="#990033"><b><img
SRC="/Images/Header/tabs_DVD_off.gif" BORDER=0 WIDTH=54 HEIGHT=23
ALT="DVD"></b></font></a><a
HREF="http://www.chapters.ca/Software/Default.asp?WSID=230271C83432F0174255B924C6CE5AC40A081225&mscssid=9E6TU7LU4EJF9PE8EN4KSHK4V3KSBXN9"
STYLE="color:Maroon"><font COLOR="#990033"><b><img
SRC="/Images/Header/tabs_software_off.gif" BORDER=0 WIDTH=70 HEIGHT=23
ALT="Software"></b></font></a><a
HREF="http://www.chapters.ca/Electronics/Default.asp?WSID=230271C83432F0174255B924C6CE5AC40A081225&mscssid=9E6TU7LU4EJF9PE8EN4KSHK4V3KSBXN9"
STYLE="color:Maroon"><font COLOR="#990033"><b><img
SRC="/Images/Header/tabs_electronics_off.gif" BORDER=0 WIDTH=70 HEIGHT=23
ALT="Electronics"></b></font></a><a
HREF="http://www.chapters.ca/GamesCentre/Default.asp?WSID=230271C83432F0174255B924C6CE5AC40A081225&mscssid=9E6TU7LU4EJF9PE8EN4KSHK4V3KSBXN9"
STYLE="color:Maroon"><font COLOR="#990033"><b><img
SRC="/Images/Header/tabs_games_off.gif" BORDER=0 WIDTH=54 HEIGHT=23
ALT="Games"></b></font></a><a
HREF="http://www.chapters.ca/Kids/Default.asp?WSID=230271C83432F0174255B924C6CE5AC40A081225&mscssid=9E6TU7LU4EJF9PE8EN4KSHK4V3KSBXN9"
STYLE="color:Maroon"><font COLOR="#990033"><b><img
SRC="/Images/Header/tabs_kids_off.gif" BORDER=0 WIDTH=54 HEIGHT=23
ALT="Kids"></b></font></a><a
HREF="http://www.chapters.ca/GiftCentre/Default.asp?WSID=230271C83432F0174255B924C6CE5AC40A081225&mscssid=9E6TU7LU4EJF9PE8EN4KSHK4V3KSBXN9"
STYLE="color:Maroon"><font COLOR="#990033"><b><img
SRC="/Images/Header/tabs_gifts_off.gif" BORDER=0 WIDTH=54 HEIGHT=23
ALT="Gifts"></b></font></a></td>
</tr>
</table>
</td>
</tr>

Comment 1

17 years ago

*** This bug has been marked as a duplicate of 69743 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 2

17 years ago
QA contact update
QA Contact: chrisd → amar

Comment 3

16 years ago
 Verified that this bug is a dupe of 69743.. and its fixed
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.