[Mobile] Tablets - Implement lightbox promo for Fx9 GA

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: jfu, Unassigned)

Tracking

Firefox 9
x86
Mac OS X
Dependency tree / graph

Details

(Reporter)

Description

7 years ago
Hi Mark,

Similar to the Aurora lightbox promo, we'd like to implement an in-product promo for Firefox 9 on tablets. We believe the tablet experience is going to get a lot of positive feedback, and wanted to take the opportunity to boost our ratings. This lightbox promo will prompt users on the 5th time to rate the app in the Android Market (only for tablet users on GA). 

We'd like the link to go to: http://www.mozilla.org/m/download-android.html

What should the specs/dimensions for a tablet promo be? When should I get the final creative assets to you by? 

Thanks!
(Reporter)

Updated

7 years ago
Blocks: 698505
(Reporter)

Comment 1

7 years ago
Hi Mark - Design assets can be found in Bug 701572 along with implementation details.

Please let me know what else you need, thanks!
(Reporter)

Comment 2

7 years ago
Just spoke with Mark - this in-product promo will not be able to make it to Fx 9 :( If anyone has a suggestion on how else to nudge our users to rate, feel free to let me know
(In reply to Jaclyn Fu from comment #2)
> Just spoke with Mark - this in-product promo will not be able to make it to
> Fx 9 :( If anyone has a suggestion on how else to nudge our users to rate,
> feel free to let me know

I have a theory that Firefox Input (input.mozilla.com) actually hurts our Android Market ratings.

Firefox Input feedback has always been much, much higher on Android than on any other platform.  Feedback is only 20% negative on mobile, compared to 58% negative on desktop.  This suggests to me that users who like Firefox and continue using it are more often funneled to Firefox Input, while users who dislike Firefox and stop using it leave reviews in the Android Market instead.

We received 416 new Android Market ratings in the last week, and 1193 new Firefox Input submissions from Android users in the same period.
More evidence that we are steering Firefox users away from the Android Market:  Opera Mobile has about the same number of Android Market downloads as Firefox (both apps reached 5M downloads in the same week) but has almost twice as many ratings (83K for Opera vs 45K for Firefox).

We might be able to improve this by inviting users who leave happy feedback (or possibly all feedback users) to also rate the app in the Market, by giving them a link after their feedback submission.
(Reporter)

Comment 5

7 years ago
That's really interesting - I like the idea of asking users who left happy input feedback to rate on the Android Market as well. Maybe we can update the http://m.input.mozilla.com/en-US/thanks page. Thanks Matt
(Reporter)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX

Comment 6

7 years ago
Another problem is that 20% negative reviews just isn't competitive for mobile. We need to be between 3 and 7% for negative reviews to compete. Any higher than 7% and we aren't competing in the top-five mobile browser space. More than 93% of users need to be happy with our product to compete. To be *the best*, we need 98% of reviews to be positive (at least 3 stars). 

This is a challenge. We'll need 555,000 new positive reviews to get to 98% because we have 12k low reviews currently. Not trying to be a wet blanket, but I think we need to consider how to completely start over with the nativeUI on android market with respect to the reviews.
Status: RESOLVED → UNCONFIRMED
Ever confirmed: false
Resolution: WONTFIX → ---

Comment 7

7 years ago
(adding isandu)

(In reply to Michelle Luna from comment #6)
> Another problem is that 20% negative reviews just isn't competitive for
> mobile. We need to be between 3 and 7% for negative reviews to compete. Any
> higher than 7% and we aren't competing in the top-five mobile browser space.
> More than 93% of users need to be happy with our product to compete. To be
> *the best*, we need 98% of reviews to be positive (at least 3 stars). 
> 
> This is a challenge. We'll need 555,000 new positive reviews to get to 98%
> because we have 12k low reviews currently. Not trying to be a wet blanket,
> but I think we need to consider how to completely start over with the
> nativeUI on android market with respect to the reviews.


We should understand what our options are.  Native UI will seem like a new product to us and to our users, but we are the same vendor releasing a product with the same name. 

At the same time, we should set our target.  550k reviews is (I'm sure this is your point) an unrealistic target, although I'd like to check the maths.  Wouldn't 100k 5-star reviews get us to 4.54?  

Having the top-rating on the Android marketplace for a browser is highly desirable, but I'm more concerned about overall adoption.  Right now, Firefox shows up as a top free communications app, and our score is only going up (averaging 3.8 since October).  My biggest concern is the presence of many negative reviews (many of them very old) showing up which deter potential users.

So - I agree we should investigate relaunching on the Android marketplace, but unless I am missing a hard goal around having the top rating overall, my main concern with our existing marketplace showing is that should foster adoption, not deter it.
Depends on: 704964
I suggest that we retire the "Firefox" name from the Android Market and publish Native Fennec as "Firefox Mobile". This would reset our legacy ratings as we launch our new product.

That would also be a good time to revisit discussions about renaming "Firefox Beta" to something less confusing like "Firefox [Mobile] Next".
(In reply to Chris Peterson (:cpeterson) from comment #8)
> I suggest that we retire the "Firefox" name from the Android Market and
> publish Native Fennec as "Firefox Mobile". This would reset our legacy
> ratings as we launch our new product.

Is this true even if the package name (org.mozilla.firefox) stays the same?
> Is this true even if the package name (org.mozilla.firefox) stays the same?

I believe the manifest package name would need to change, but we could change the package name to "org.mozilla.firefoxmobile". Unfortunately, that would break the auto-upgrade path for XUL Fennec users.
I think this bug was re-opened by accident.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.