Closed Bug 701613 Opened 9 years ago Closed 8 years ago

Add WinVista as supported OS in updater.exe.manifest

Categories

(Toolkit :: Application Update, defect)

x86_64
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla19

People

(Reporter: bbondy, Assigned: bbondy)

Details

Attachments

(1 file)

The manifest only lists Vista as a supported OS but should also list Win7.  I don't think this will cause any problems but should have both listed.

rs originally found this for the maintenanceservice in a review, this is just applying that same fix to updater.exe.
Assignee: nobody → netzen
Status: NEW → ASSIGNED
Attachment #573721 - Flags: review?(robert.bugzilla)
Attachment #573721 - Flags: review?(robert.bugzilla) → review+
Currently listed only Win7, not WinVista.
And I doubt the usefulness of adding WinVista to SupportedOS because SupportedOS feature is added to the manifest when Win7 is released. WinVista will not recognize the SupportedOS anyway (at least before SP2).
Summary: Add Win7 as supported OS in updater.exe.manifest → Add WinVista as supported OS in updater.exe.manifest
> Currently listed only Win7, not WinVista.

Thanks, my bad.

>  I doubt the usefulness

I don't think it matters either because we don't currently use what is listed here:
http://msdn.microsoft.com/en-us/library/dd371711%28v=vs.85%29.aspx

But I don't see any harm in adding it.
I've had helper.exe's run in compatibility mode turn on on my machine for an unexplained reason. I read that it could be because of the parent program that executes it.  

I can't reliably reproduce anything but I'm going to land this anyway because it's the right thing to do.
https://hg.mozilla.org/mozilla-central/rev/a0e9fba17816
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.