Grab aggregate commit info from Mozilla GitHub Repo and show on Mozillians profiles

RESOLVED WONTFIX

Status

Participation Infrastructure
Phonebook
P2
enhancement
RESOLVED WONTFIX
6 years ago
2 years ago

People

(Reporter: aakashd, Unassigned)

Tracking

Details

(Whiteboard: [display contributions][Triage 2015-04-17])

(Reporter)

Description

6 years ago
This hasn't been properly defined, but we should grab contributor metrics from user commits within Mozilla GitHub Repos and show them on Mozillian profiles.

GitHub has an API for commits, but it's not exactly what we want:

http://developer.github.com/v3/commits/

We'll need to engineering this a bit to make it fit our needs or co-erce some folks to helping our cause ;).

Updated

6 years ago
Blocks: 701743
(Reporter)

Updated

6 years ago
Target Milestone: 1.4 → 1.5
(Reporter)

Updated

6 years ago
Duplicate of this bug: 720969

Comment 2

6 years ago
I'm not sure why github should be special.  AFAIK, they are not a strategic partner.

Updated

5 years ago
Component: mozillians.org → Phonebook
Product: Websites → Community Tools
QA Contact: mozillians-org → phonebook
Target Milestone: 1.5 → ---
Version: unspecified → other
I think a fork of this ptoject would be helpful: https://github.com/berkerpeksag/github-badge
I think a fork of this project would be helpful: https://github.com/berkerpeksag/github-badge
There are two options that comes to my mind:
 1. Add a filter to the existing project for organizations and it will use the information from repos only owned by the organization or forks of those repos to calculate user metrics.
 2. Fork the project and create a new one from scratch which specifically walks through all recent commits in all Mozilla repos and gets the commits owned by a specific user. Since Mozilla is a very active organizations this second approach may be more resource intensive but it sounds more accurate.
Pre-Note: I'm new to this and what I have written below will be extremely far away from the best practice.

I got bored tonight and messed about with the Github API. How about you keep a count of the commits added during a day using a bot(like the bots present in the mozillians release and dev channels) and then pass the count into a basic python script that runs at the end of the day?

https://gist.github.com/2552511/7e184ac0095cc0d40f7f0ba677c602540559f57b

The script would be something similar to that basic function with the count passed in and rather than printing out the results you'd store them in a DB.

The users name(and perhaps email?) will be the same on Github as it is on Mozillians so the commits would be able to be matched to a user.

Once again I'm new to this so that may all be complete rubbish :)
There's a lot of value in pulling in this information. We're working on a broad effort to better recognize and showcase contributions on individual profiles. Will try to work on this more in the next few months (Q2).
Priority: P1 → P2
Whiteboard: [display contributions]
After program meeting this is considered out of scope.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
Whiteboard: [display contributions] → [display contributions][Triage 2015-04-17]
You need to log in before you can comment on or make changes to this bug.