talos shouldn't shell out to python so much

RESOLVED DUPLICATE of bug 701195

Status

Testing
Talos
RESOLVED DUPLICATE of bug 701195
6 years ago
6 years ago

People

(Reporter: Jeff Hammel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mozbase])

(Reporter)

Description

6 years ago
Talos shells out a lot. In bcontroller we shell out to start/stop_xperf and etlparser.py. In ffprocess we shell out to run bcontroller.py and head and tail scripts.  At a casual glance, it looks like we can just import these things and call via an API versus shelling out and we should do this when we can.  There's no real point of opening a subshell for a blocking python script.
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 701195
You need to log in before you can comment on or make changes to this bug.