Startup Crash: Db should check before trying to allocate size to prevent OOM crashing

RESOLVED DUPLICATE of bug 702365

Status

()

Firefox for Android
General
--
critical
RESOLVED DUPLICATE of bug 702365
6 years ago
6 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [native-crash], [testday-20111111])

Attachments

(2 attachments)

1. fill up memory by doing something like a system update
2. setup logcat
3. install fennec
4. launch fennec

Expected: UI to say free up some memory before starting
Actual: OOM crash

Toshiba Thrive; Android 3.1; Testday build
Note:
11-11 11:32:13.720: D/dalvikvm(4421): GC_CONCURRENT freed 157K, 4% free 6583K/6791K, paused 2ms+2ms
11-11 11:32:13.740: W/PluginManager(4421): zerdatime 1321039933749 - onCreate
11-11 11:32:13.770: D/Favicons(4421): Creating Favicons instance
11-11 11:32:13.770: D/Favicons(4421): Creating DatabaseHelper
11-11 11:32:13.800: D/dalvikvm(4421): GC_CONCURRENT freed 61K, 2% free 6981K/7111K, paused 2ms+2ms
11-11 11:32:13.820: D/dalvikvm(4421): GC_FOR_ALLOC freed 2K, 2% free 6978K/7111K, paused 20ms
11-11 11:32:13.820: I/dalvikvm-heap(4421): Grow heap (frag case) to 7.353MB for 513744-byte allocation
11-11 11:32:13.860: D/dalvikvm(4421): GC_FOR_ALLOC freed 0K, 2% free 7480K/7623K, paused 20ms
11-11 11:32:13.900: D/dalvikvm(4421): GC_CONCURRENT freed 4K, 2% free 7488K/7623K, paused 2ms+2ms
11-11 11:32:13.920: D/dalvikvm(4421): GC_FOR_ALLOC freed <1K, 2% free 7488K/7623K, paused 23ms
11-11 11:32:13.950: I/dalvikvm-heap(4421): Grow heap (frag case) to 23.361MB for 16777232-byte allocation
11-11 11:32:13.980: D/dalvikvm(4421): GC_CONCURRENT freed 0K, 1% free 23872K/24071K, paused 2ms+2ms
11-11 11:32:14.020: D/dalvikvm(4421): GC_FOR_ALLOC freed 111K, 1% free 24031K/24199K, paused 22ms
11-11 11:32:14.030: I/dalvikvm-heap(4421): Grow heap (frag case) to 31.517MB for 8388624-byte allocation
11-11 11:32:14.070: D/dalvikvm(4421): GC_CONCURRENT freed 0K, 1% free 32223K/32455K, paused 2ms+3ms
11-11 11:32:14.200: D/dalvikvm(4421): GC_FOR_ALLOC freed 134K, 1% free 32204K/32455K, paused 22ms
11-11 11:32:14.200: I/dalvikvm-heap(4421): Forcing collection of SoftReferences for 33554448-byte allocation
11-11 11:32:14.220: D/dalvikvm(4421): GC_BEFORE_OOM freed 9K, 1% free 32195K/32455K, paused 27ms
11-11 11:32:14.220: E/dalvikvm-heap(4421): Out of memory on a 33554448-byte allocation.

Occurs in nightly and testday build
Created attachment 573875 [details]
logcat

Comment 2

6 years ago
Confirmed on also a ASUS Transformer running 3.2 and the 11/11 testday build, Fennec is unresponsive on startup. Logcat is attached.

Updated

6 years ago
Duplicate of this bug: 701949

Comment 4

6 years ago
http://pastebin.mozilla.org/1380357

Pastebin from ASUS Transformer running 3.2

Comment 5

6 years ago
Created attachment 574335 [details]
Another logcat of the crash on my 3.1

Comment 6

6 years ago
john, unrelated.  Are you sure that this is a OOM?

This is incomplete.  No str, unsure if we caused the OOM.  Logcats are different.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
Resolution: INCOMPLETE → DUPLICATE
Summary: Db should check before trying to allocate size to prevent OOM crashing → Startup Crash: Db should check before trying to allocate size to prevent OOM crashing
Duplicate of bug: 702365
You need to log in before you can comment on or make changes to this bug.