Android mochitests intermittently time out after completion | TimeoutError: command timed out: 2400 seconds without output

RESOLVED DUPLICATE of bug 703194

Status

()

defect
RESOLVED DUPLICATE of bug 703194
8 years ago
7 years ago

People

(Reporter: mbrubeck, Unassigned)

Tracking

({intermittent-failure})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mobile_unittests][android][tegra])

(Reporter)

Description

8 years ago
Sometimes mochitests on the Native Fennec builds (birch branch) finish their tests but then time out; presumably the browser is failing to exit correctly.

For example: https://tbpl.mozilla.org/php/getParsedLog.php?id=7356029&tree=Birch
Android Tegra 250 birch opt test mochitest-3 on 2011-11-11 10:18:01 PST for push e65b9655e3e8

2034 INFO TEST-START | /tests/dom/tests/mochitest/dom-level1-core/test_textsplittextthree.html
2035 INFO TEST-PASS | textSplitTextThreeAssert
2036 INFO TEST-END | /tests/dom/tests/mochitest/dom-level1-core/test_textsplittextthree.html | finished in 512ms
2037 INFO TEST-START | /tests/dom/tests/mochitest/dom-level1-core/test_textsplittexttwo.html
2038 INFO TEST-PASS | textSplitTextTwoAssert
2039 INFO TEST-END | /tests/dom/tests/mochitest/dom-level1-core/test_textsplittexttwo.html | finished in 532ms
2040 INFO TEST-START | /tests/dom/tests/mochitest/dom-level1-core/test_textwithnomarkup.html
2041 INFO TEST-PASS | textNodeValue
2042 INFO TEST-END | /tests/dom/tests/mochitest/dom-level1-core/test_textwithnomarkup.html | finished in 481ms
2043 INFO TEST-START | Shutdown
2044 INFO Passed: 755
2045 INFO Failed: 0
2046 INFO Todo:   233
2047 INFO SimpleTest FINISHED

INFO | automation.py | Application ran for: 0:04:54.885637
INFO | automation.py | Reading PID log: /tmp/tmp1fK3PNpidlog
getting files in '/mnt/sdcard/tests/profile/minidumps/'
WARNING | automationutils.processLeakLog() | refcount logging is off, so leaks can't be detected!

INFO | runtests.py | Running tests: end.

command timed out: 2400 seconds without output, killing pid 79916
process killed by signal 9
program finished with exit code -1
elapsedTime=2711.124274
TinderboxPrint: mochitest-plain<br/>755/0/233
buildbot.slave.commands.TimeoutError: command timed out: 2400 seconds without output, killing pid 79916
TinderboxPrint: mochitest-plain<br/><em class="testfail">timeout</em>
(Reporter)

Updated

8 years ago
Blocks: 702373
(Reporter)

Comment 3

8 years ago
Also happening in XUL Fennec:

https://tbpl.mozilla.org/php/getParsedLog.php?id=7477280&tree=Mozilla-Inbound
Android XUL Tegra 250 mozilla-inbound opt test mochitest-6 on 2011-11-18 14:25:51 PST for push fcc7876cab43
Summary: [birch] Native Fennec mochitests intermittently time out after completion | TimeoutError: command timed out: 2400 seconds without output → Android mochitests intermittently time out after completion | TimeoutError: command timed out: 2400 seconds without output
(Reporter)

Comment 10

8 years ago
https://tbpl.mozilla.org/php/getParsedLog.php?id=7757583&tree=Birch
Android Tegra 250 birch opt test mochitest-5 on 2011-12-05 11:27:53 PST for push a7fb88bd5148

https://tbpl.mozilla.org/php/getParsedLog.php?id=7756838&tree=Birch
Android Tegra 250 birch opt test mochitest-5 on 2011-12-05 10:39:53 PST for push 7b72e55cfe69

https://tbpl.mozilla.org/php/getParsedLog.php?id=7756831&tree=Birch
Android Tegra 250 birch opt test mochitest-5 on 2011-12-05 10:34:53 PST for push bea2748292cc
(Reporter)

Comment 11

8 years ago
This looks like a dupe of bug 703194 which is more informatively named.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 703194
Whiteboard: [orange][mobile_unittests][android][tegra] → [mobile_unittests][android][tegra]
You need to log in before you can comment on or make changes to this bug.