Closed Bug 701858 Opened 9 years ago Closed 9 years ago

Intermittent failure in test_annos_expire_session.js | true == false

Categories

(Toolkit :: Places, defect)

All
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: gps, Unassigned)

Details

Failed on Win opt on latest m-c -> services-central integration: https://tbpl.mozilla.org/?tree=Services-Central&rev=8ae941beee71

TEST-INFO | c:\talos-slave\test\build\xpcshell\tests\toolkit\components\places\tests\expiration\test_annos_expire_never.js | running test ...
TEST-PASS | c:\talos-slave\test\build\xpcshell\tests\toolkit\components\places\tests\expiration\test_annos_expire_never.js | test passed (time: 4785.000ms)
TEST-INFO | c:\talos-slave\test\build\xpcshell\tests\toolkit\components\places\tests\expiration\test_annos_expire_policy.js | running test ...
TEST-PASS | c:\talos-slave\test\build\xpcshell\tests\toolkit\components\places\tests\expiration\test_annos_expire_policy.js | test passed (time: 8615.000ms)
TEST-INFO | c:\talos-slave\test\build\xpcshell\tests\toolkit\components\places\tests\expiration\test_annos_expire_session.js | running test ...
TEST-UNEXPECTED-FAIL | c:\talos-slave\test\build\xpcshell\tests\toolkit\components\places\tests\expiration\test_annos_expire_session.js | test failed (with xpcshell return code: 0), see following log:
>>>>>>>

TEST-INFO | (xpcshell/head.js) | test 1 pending

TEST-INFO | (xpcshell/head.js) | test 2 pending

TEST-PASS | c:/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/expiration/test_annos_expire_session.js | [run_test : 81] 10 == 10

TEST-PASS | c:/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/expiration/test_annos_expire_session.js | [run_test : 83] 10 == 10

TEST-PASS | c:/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/expiration/test_annos_expire_session.js | [run_test : 85] 10 == 10

TEST-PASS | c:/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/expiration/test_annos_expire_session.js | [run_test : 87] 10 == 10

TEST-INFO | (xpcshell/head.js) | test 2 finished

TEST-INFO | (xpcshell/head.js) | running event loop

TEST-UNEXPECTED-FAIL | c:/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/expiration/test_annos_expire_session.js | true == false - See following stack:
JS frame :: c:\talos-slave\test\build\xpcshell\head.js :: do_throw :: line 453
JS frame :: c:\talos-slave\test\build\xpcshell\head.js :: _do_check_eq :: line 547
JS frame :: c:\talos-slave\test\build\xpcshell\head.js :: do_check_eq :: line 568
JS frame :: c:\talos-slave\test\build\xpcshell\head.js :: do_check_false :: line 596
JS frame :: c:/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/expiration/test_annos_expire_session.js :: <TOP_LEVEL> :: line 95
JS frame :: c:/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/expiration/head_expiration.js -> file:///c:/talos-slave/test/build/xpcshell/tests/toolkit/components/places/tests/head_common.js :: <TOP_LEVEL> :: line 634

TEST-INFO | (xpcshell/head.js) | exiting test
<<<<<<<
TEST-INFO | c:\talos-slave\test\build\xpcshell\tests\toolkit\components\places\tests\expiration\test_debug_expiration.js | running test ...
unseen from a long time, and I think I fixed this recently...
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.