IonMonkey: Bailouts broken when calling a non-object.

RESOLVED DUPLICATE of bug 706692

Status

()

RESOLVED DUPLICATE of bug 706692
7 years ago
7 years ago

People

(Reporter: sstangl, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 573928 [details]
Fail during unboxing a known non-object, triggering an exception.

This is related to the recently-fixed Bug 701508.

The attached testcase is a reduced version of ion/bug670484.js.
Trips on master with --ion-eager on x86_64, after taking the bailout:

>Assertion failure: sp_ >= fp_->base() && sp_ <= fp_->slots() + script->nslots, at /home/sstangl/dev/ionmonkey/js/src/vm/Stack.cpp:1087
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 706692
You need to log in before you can comment on or make changes to this bug.