Crashing occurs when launching chrome experiment ball of smoke and fire [webgl]

RESOLVED WORKSFORME

Status

()

Core
Canvas: WebGL
P4
critical
RESOLVED WORKSFORME
7 years ago
6 years ago

People

(Reporter: nhirata, Unassigned)

Tracking

({crash, reproducible})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [native-crash:P1], [testday-20111111], [chromeexperiments], dupme, URL)

Attachments

(1 attachment)

11-12 01:39:21.980: I/Tab(26092): Updated title: Fire Walk With Me for tab with id: 1
11-12 01:39:21.985: D/Favicons(26092): Calling loadFavicon() with URL = http://inear.se/fireshader/ and favicon URL = null
11-12 01:39:21.985: D/Favicons(26092): Creating LoadFaviconTask with URL = http://inear.se/fireshader/ and favicon URL = null
11-12 01:39:21.985: D/Favicons(26092): Favicon URL is now: http://inear.se/favicon.ico
11-12 01:39:21.990: D/Favicons(26092): Calling getFaviconUrlForPageUrl() for http://inear.se/fireshader/
11-12 01:39:21.990: I/GeckoApp(26092): URI - http://inear.se/fireshader/, title - Fire Walk With Me
11-12 01:39:21.995: D/Favicons(26092): Downloading favicon for URL = http://inear.se/fireshader/ with favicon URL = http://inear.se/favicon.ico
11-12 01:39:22.005: E/nsConsoleService(26092): [JavaScript Warning: "Unknown property 'transition'.  Declaration dropped." {file: "http://inear.se/fireshader/" line: 1}]
11-12 01:39:22.140: D/GeckoAppJava(26092): IME: run()
11-12 01:39:22.140: D/GeckoAppJava(26092): IME: v=org.mozilla.gecko.gfx.LayerView@40597c80
11-12 01:39:22.140: D/CLIPBOARD(2707): Hide Clipboard dialog inside hideSoftInput() !
11-12 01:39:22.225: E/nsConsoleService(26092): [JavaScript Error: "uncaught exception: [Exception... "Component returned failure code: 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [nsIDOMWindow.crypto]"  nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame :: https://ssl.gstatic.com/webclient/js/gc/25095437-ce843676/iframes-styles-bubble-mobile__plusone.js :: <TOP_LEVEL> :: line 32"  data: no]"]
11-12 01:39:22.235: I/Gecko(26092): Got message: Content:StateChange
11-12 01:39:22.235: I/GeckoApp(26092): State - 196612
11-12 01:39:22.360: E/nsConsoleService(26092): ### Resize!
11-12 01:39:22.360: E/nsConsoleService(26092): ### Resize: No browser!
11-12 01:39:22.365: E/nsConsoleService(26092): [JavaScript Error: "browser is null" {file: "chrome://browser/content/browser.js" line: 1135}]
11-12 01:39:22.375: D/skia(26092): --- SkImageDecoder::Factory returned null
11-12 01:39:22.375: D/Favicons(26092): LoadFaviconTask finished for URL = http://inear.se/fireshader/
11-12 01:39:22.680: I/ActivityManager(2707): Process org.mozilla.fennec_dougt (pid 26092) has died.
11-12 01:39:22.680: I/WindowManager(2707): WIN DEATH: Window{408f24f8 org.mozilla.fennec_dougt/org.mozilla.fennec_dougt.App paused=false}
11-12 01:39:22.680: I/WindowManager(2707): WIN DEATH: Window{409e7990 SurfaceView paused=false}
STR:
1. go to http://www.chromeexperiments.com/detail/ball-of-smoke-and-fire/?f=
2. click on launch

Expected: no crash
Actual: crash

Note:
1. nothing in about:crashes
testday build, Samsung Galaxy S II
Whiteboard: [native → [native-crash]
Forgot to mention: mevans found this bug.
Whiteboard: [native-crash] → [native-crash], [testday-20111111]
Severity: normal → critical
Can you retest this and post new logcats

Comment 5

7 years ago
looks like crashreporter crashing.

Updated

7 years ago
Priority: -- → P4
Crash reporter is crashing.  There's a separate bug for that : Bug 702624.

I am not sure, but it looks like this bug is crashing due to [nsIDOMWindow.crypto] not being implemented based on the log report?
 
11-14 18:43:31.629: D/Favicons(3572): Calling getFaviconUrlForPageUrl() for http://inear.se/fireshader/
11-14 18:43:31.629: D/Favicons(3572): Downloading favicon for URL = http://inear.se/fireshader/ with favicon URL = http://inear.se/favicon.ico
11-14 18:43:31.639: E/InetAddress(3572): InetAddress_getaddrinfoImpl addressList
11-14 18:43:31.639: E/InetAddress(3572): InetAddress_getaddrinfoImpl --
11-14 18:43:31.639: E/InetAddress(3572): InetAddress_getaddrinfo -- 
11-14 18:43:31.959: E/nsConsoleService(3572): [JavaScript Error: "uncaught exception: [Exception... "Component returned failure code: 0x80004001 (NS_ERROR_NOT_IMPLEMENTED) [nsIDOMWindow.crypto]"  nsresult: "0x80004001 (NS_ERROR_NOT_IMPLEMENTED)"  location: "JS frame :: https://ssl.gstatic.com/webclient/js/gc/25095437-ce843676/iframes-styles-bubble-mobile__plusone.js :: <TOP_LEVEL> :: line 32"  data: no]"]
11-14 18:43:31.979: I/Gecko(3572): Got message: Content:StateChange
11-14 18:43:31.979: I/GeckoApp(3572): State - 196612
11-14 18:43:32.049: D/skia(3572): --- SkImageDecoder::Factory returned null
11-14 18:43:32.059: D/Favicons(3572): LoadFaviconTask finished for URL = http://inear.se/fireshader/
11-14 18:43:33.199: I/ActivityManager(1572): Process org.mozilla.fennec (pid 3572) has died.
11-14 18:43:33.199: I/WindowManager(1572): WIN DEATH: Window{47c34040 org.mozilla.fennec/org.mozilla.fennec.App paused=false}
11-14 18:43:33.199: I/WindowManager(1572): WIN DEATH: Window{47c501f8 SurfaceView paused=false}
11-14 18:43:33.209: E/ActivityManager(1572): fail to set top app changed!
11-14 18:43:33.209: D/Zygote(1455): Process 3572 exited cleanly (1)
Setting to End User P1 as it is reproducible.
Keywords: reproducible
Whiteboard: [native-crash], [testday-20111111] → [native-crash:P1], [testday-20111111], dupme

Updated

7 years ago
Whiteboard: [native-crash:P1], [testday-20111111], dupme → [native-crash:P1], [testday-20111111], [chromeexperiments], dupme
This is a WebGL issue. I just tested on my Nexus One with a nightly, and we work... but very slowly.

There are several WebGL/Fennec crasher bugs filed. It would be nice to be able to get the stack from this crash (if you can still repro) and dupe the bug.:

https://bugzilla.mozilla.org/buglist.cgi?quicksearch=webgl%20fennec
Summary: Crashing occurs when launching chrome experiment ball of smoke and fire → Crashing occurs when launching chrome experiment ball of smoke and fire [webgl]

Updated

7 years ago
Component: General → Canvas: WebGL
Product: Fennec Native → Core
QA Contact: general → canvas.webgl
No longer crashing. resolving as WFM
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.