Mozilla renders correct when it shouldn't

VERIFIED WONTFIX

Status

()

Core
HTML: Parser
VERIFIED WONTFIX
17 years ago
17 years ago

People

(Reporter: Christian Schaller, Assigned: harishd)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
The page I have linked to renders correctly in Mozilla (correctly in the sense
that it renders the way I wanted the page to look like.)
However there is a bug in the page which commes clear when using Netscape
Classic(4.7 etc.), which is that the H1 tag never was ended so the rest of the
page is rendered with H1 size and font. I think the correct behaviour for
Mozilla is to render the page the way Netscape Classic does, since the HTML code
never says to end the H1 tag.
Over to parser.
Component: HTML Element → Parser
Assignee: clayton → harishd
QA Contact: gerardok → janc
reassigning for real....
(Assignee)

Comment 3

17 years ago
http://www.w3.org/TR/1998/REC-html40-19980424/struct/global.html#h-7.5.5

The spec. says that HEADING tags do require an end tag. Also, mozilla behaves 
the way it does ( which is correct ) because HEADING tags can contain only 
inline elements and H2, contained in H1,in the above URL, is a block level!. 

I'm inclined to mark this WONTFIX...but may be for compatibililty we should 
think twice. Any idea if there are more pages affected by this?
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true

Comment 4

17 years ago
i like the way mozilla handles this case. i'd also say WONTFIX
(Reporter)

Comment 5

17 years ago
Let me add as an argument (weak one but still) that by having the old Netscape
classic behaviour we force people(myself in this case) to code correct HTML.
The new behaviour on the other hand allows for sloppy HMTL coding. 
(Assignee)

Comment 6

17 years ago
Christian: I don't understand your argument. Mozilla is forcing the user to do 
the correct thing by following the spec. Please take a look into the spec.
(Reporter)

Comment 7

17 years ago
No I don't understand you :) .The page I linked to had a 'bug', it is missing
the /H1 tag. Mozilla still renders the page like I had a /H1 tag, while the old
Netscape renders the whole page with the H1 fontsize etc. This means that
Mozilla forgives me for forgetting the /H1 tag, while the old Netscape forces me
to correct the mistake in order for the page to render the way it should be.

I realise that the SPEC says a H1 tag can't contain a H2 tag so by rendering the
page in H1 style only until the H2 tag is found you are following the SPEC, but
on the other hand the SPEC also says you should have an end tag to H1, which you
with the current behaviour indirectly allow to be ommited.
(Assignee)

Comment 8

17 years ago
Making WONTFIX.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WONTFIX

Comment 9

17 years ago
updated qa contact.
QA Contact: janc → bsharma
VERIFIED WONTFIX -- we have much, much bigger fish to fry, sorry! :-)

Thanks for helping though.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.