XSL transformation destroys table rendering

RESOLVED INVALID

Status

()

Core
XSLT
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: development, Unassigned)

Tracking

7 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

7 years ago
Created attachment 574032 [details]
XML input

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20110930134708

Steps to reproduce:

1. Create events.xml (Attached, [1]), event-list.xsl (Attached, [2]).
2. Open events.xml in Firefox


Actual results:

The <td> tags are somehow displayed all in one column (below the “Timestamp”-th)


Expected results:

<td> tags should behave as in pretransformed.xhtml (Attached, [3])

-- From what I found in the search, this bug may be related to #230214
(Reporter)

Comment 1

7 years ago
Created attachment 574034 [details]
xsl transformation applied

Attached xsl transformation
[2] http://sotecware.net/files/xslbugreport/event-list.xsl
(Reporter)

Comment 2

7 years ago
Created attachment 574035 [details]
Example output for reference

Attached pretransformed xhtml output
[3] http://sotecware.net/files/xslbugreport/pretransformed.xhtml
This is because you are using XML output (which happens because the root element outputted isn't in the null namespace) but the <td> elements which are output are not in the XHTML namespace.

You can fix this by either removing the namespace declaration on the <html> element, which makes the transform use HTML output, or by making sure that all elements you output are in the XHTML namespace.

This is all per the XSLT specification.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → INVALID
Oh, if you want to use HTML output, you should also remove the method="xml" in the output element (or remove the output element completely).
(Reporter)

Comment 5

7 years ago
Aaaaargh of course. not seen the obvious, sorry for having bothered you! moving the xmlns to the xsl:stylesheet node fixes it.

best regards
You need to log in before you can comment on or make changes to this bug.