Downloadable Fonts fail to download / format not supported

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
6 years ago
6 years ago

People

(Reporter: rtrappman, Unassigned)

Tracking

8 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 2 obsolete attachments)

(Reporter)

Description

6 years ago
Created attachment 574100 [details]
common-min.css

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0 Firefox/8.0
Build ID: 20111104165243

Steps to reproduce:

Visit the Mozilla Support website.


Actual results:

Error Console:

Error: downloadable font: download failed (font-family: "MetaBlack" style:normal weight:bold stretch:normal src index:1): status=2152398850
Source: http://support.mozilla.com/media/fonts/MetaWebPro-Black.woff
Source File: http://support.mozilla.com/media/css/common-min.css?build=66ba9bd
Line: 0
Source Code:
@font-face {   font-family: "MetaBlack";   font-weight: bold;   src: url("../fonts/MetaWebPro-Black.eot?") format("eot"), url("../fonts/MetaWebPro-Black.woff") format("woff"); }
WFM in both FF8.0 and a Nightly build.
(Reporter)

Comment 2

6 years ago
Created attachment 574193 [details]
Error: Download Failed
(Reporter)

Comment 3

6 years ago
Created attachment 574194 [details]
Warning: Not Supported

Also showing that the font format is not supported:

Warning: downloadable font: format not supported (font-family: "MetaBlack" style:normal weight:bold stretch:normal src index:0)
source: http://support.mozilla.com/media/fonts/MetaWebPro-Black.eot?
Source File: http://support.mozilla.com/media/css/common-min.css?build=66ba9bd
Line: 0
Source Code:
@font-face {   font-family: "MetaBlack";   font-weight: bold;   src: url("../fonts/MetaWebPro-Black.eot?") format("eot"), url("../fonts/MetaWebPro-Black.woff") format("woff"); }
(Reporter)

Updated

6 years ago
Summary: Error: downloadable font: download failed (font-family: "MetaBlack" style:normal weight:bold stretch:normal src index:1): status=2152398850 → Downloadable Fonts fail to download / format not supported
(Reporter)

Updated

6 years ago
Attachment #574193 - Attachment description: Screenshot → Error: Download Failed
Firefox does not support the EOT format (src index 0 in the @font-face rule here), so this message is expected.

I don't know why the WOFF file is failing to download, however; it works for me here.
Your screenshot also shows problems with image downloads ("corrupt or truncated"), which I don't see here when loading the support.mozilla.com site. This seems to imply that you're having a more general network/connectivity problem.
(Reporter)

Comment 6

6 years ago
It is odd, because all sites appear to be rendering normal (graphically and content wise), just causing FF to throw theses errors in the console log.

Is there a test site, that you could use to determine WFM? v.s. Connection Issues?
(Reporter)

Comment 7

6 years ago
RE: "corrupt or truncated" - Images

"...It's actually a correct response in reading an image that has had it's extension changed from it's original saved format." - Quoted from Bug#646090

This error is not a local (ex: connection problem), this error occurs when site use images that are not in their original format.
On support.mozilla.com, the "FIREFOX HELP" heading should be in a bold sans-serif font, but as you can see in your screenshot, you're getting a default fallback (light, serif) font because the load failed.

Further down the page (in the right-hand sidebar) there should be images for SUMO and plugin-check; do you see those, or are they broken/missing for you?
For example, does the image http://support.mozilla.com/media/img/promo.plugins.png load for you?
(Reporter)

Comment 10

6 years ago
Created attachment 574206 [details]
Test Image

Image downloads and displays correctly
(Reporter)

Comment 11

6 years ago
Created attachment 574207 [details]
Sumo/Plugins Image - TEST
And are you still getting error messages in the console regarding the images, even though they display correctly?
(Reporter)

Comment 13

6 years ago
It seems like now the images are displaying without the error, although I'm still getting the font download failed error.
(Reporter)

Updated

6 years ago
Attachment #574207 - Attachment is obsolete: true
(Reporter)

Updated

6 years ago
Attachment #574206 - Attachment is obsolete: true
It sounds as though there's something erratic about your connection or your system, if those error messages for the images have spontaneously stopped happening.

It would be good to try running Firefox in Safe Mode, and running with a new profile, to see if this makes any difference. Also, are you connected directly to the internet, or via some kind of proxy?
(Reporter)

Comment 15

6 years ago
I'm using a direct connection.
I will delete my profile, in addition to a full re-install.

Closing this bug as "Resolved - WFM", as not widely reproducible.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.