Last Comment Bug 702094 - Dragging attachments from the compose window doesn't work anymore
: Dragging attachments from the compose window doesn't work anymore
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: Message Compose Window (show other bugs)
: 8 Branch
: All All
: -- normal (vote)
: Thunderbird 11.0
Assigned To: Jim Porter (:squib)
:
:
Mentors:
: 702946 703528 (view as bug list)
Depends on:
Blocks: 304835 630759
  Show dependency treegraph
 
Reported: 2011-11-13 01:13 PST by Jim Porter (:squib)
Modified: 2014-01-14 01:11 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed
fixed


Attachments
Fix this (4.58 KB, patch)
2011-11-13 01:13 PST, Jim Porter (:squib)
no flags Details | Diff | Splinter Review
Attach the right patch this time (481 bytes, patch)
2011-11-13 11:49 PST, Jim Porter (:squib)
bwinton: review+
standard8: approval‑comm‑aurora+
Details | Diff | Splinter Review

Description Jim Porter (:squib) 2011-11-13 01:13:40 PST
Created attachment 574130 [details] [diff] [review]
Fix this

Bug 630759 broke this because I forgot to update a string in MsgComposeCommands.js. Here's the fix. I could write tests for this, but inter-window drag-and-drop tests are fairly complicated, so I'm going to avoid doing it unless specifically requested. :)
Comment 1 Thomas D. (needinfo?me) 2011-11-13 05:06:41 PST
This patch does a lot more than just fixing the drag problem (lots of "renameAttachment" changes from bug 526998 in here as well)...
Not sure if such mixed patches are intended or desired?
Comment 2 Jim Porter (:squib) 2011-11-13 11:49:39 PST
Created attachment 574170 [details] [diff] [review]
Attach the right patch this time

Oops. The previous patch had some extra changes that stowed away.
Comment 3 Blake Winton (:bwinton) (:☕️) 2011-11-15 14:41:16 PST
Comment on attachment 574170 [details] [diff] [review]
Attach the right patch this time

Review of attachment 574170 [details] [diff] [review]:
-----------------------------------------------------------------

Seems to work for me.
Comment 4 Mark Banner (:standard8, afk until Dec) 2011-11-16 06:19:11 PST
*** Bug 702946 has been marked as a duplicate of this bug. ***
Comment 5 Jim Porter (:squib) 2011-11-16 19:15:46 PST
Checked in: http://hg.mozilla.org/comm-central/rev/e4c895f1d759
Comment 6 Alice0775 White 2011-11-18 04:19:47 PST
*** Bug 703528 has been marked as a duplicate of this bug. ***
Comment 7 Daniel 2011-11-18 10:57:12 PST
(In reply to Jim Porter (:squib) from comment #5)
> Checked in: http://hg.mozilla.org/comm-central/rev/e4c895f1d759

How might I apply this patch to my local copy of Thunderbird? 

Thank you.
Comment 8 Mark Banner (:standard8, afk until Dec) 2011-11-21 03:13:21 PST
(In reply to Jim Porter (:squib) from comment #0)
> Bug 630759 broke this because I forgot to update a string in
> MsgComposeCommands.js. Here's the fix. I could write tests for this, but
> inter-window drag-and-drop tests are fairly complicated, so I'm going to
> avoid doing it unless specifically requested. :)

We should get some litmus tests then ;-)
Comment 9 Mark Banner (:standard8, afk until Dec) 2011-11-21 05:45:12 PST
Checked into branches:

http://hg.mozilla.org/releases/comm-aurora/rev/91945160ae4f
http://hg.mozilla.org/releases/comm-beta/rev/08f96e424cd6
Comment 10 Ludovic Hirlimann [:Usul] 2011-12-06 08:53:18 PST
What was broken here ? dragging from one compose window to another ?

Note You need to log in before you can comment on or make changes to this bug.