If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

thunderbird-bin keeps on running after close (shutdown) when profile on NAS

RESOLVED INCOMPLETE

Status

Thunderbird
General
--
critical
RESOLVED INCOMPLETE
6 years ago
3 years ago

People

(Reporter: Coen Blijker, Unassigned)

Tracking

({hang})

7 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [needs stacktrace][dupeme?])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:7.0.1) Gecko/20100101 Firefox/7.0.1
Build ID: 20111008085652

Steps to reproduce:

I created a Samba share on my NAS. 
Copied my XXX.default folder to that NAS. 
Started thunderbird --profilemanager en created a new profile using the copied XXX.default folder on the NAS.
Started Thunderbird. Every seems to be OK. I can see all my emails.



Actual results:

Closing Thunderbird only closes the GUI, thunderbird-bin keeps on running.
Before I can start Thunderbird again I need to kill that instance first, or remove the lock-file. In the latter case, starting TB is possible but now 2 instances of thunderbird-bin appear to be running. Closing Thunderbird in this case will only close the second instance of thunderbird-bin.

The last lines of strace are:
futex(0x7f1c9a9e8e8c, FUTEX_WAIT_PRIVATE, 1, NULL) = ? ERESTARTSYS (To be restarted)
[Below I closed thunderbird-bin]
--- SIGTERM (Terminated) @ 0 (0) ---
unlink("/home/coen/NAS/Thunderbird/.thunderbird/jclq7mp7.default/lock") = 0
rt_sigaction(SIGTERM, {SIG_DFL, [], SA_RESTORER, 0x7f1ca3f6f060}, NULL, 8) = 0
rt_sigprocmask(SIG_UNBLOCK, [TERM], NULL, 8) = 0
tgkill(5754, 5754, SIGTERM)             = 0
--- SIGTERM (Terminated) @ 0 (0) ---
+++ killed by SIGTERM +++

If any of you need additional information please let know!


Expected results:

thinderbird-bin should close..
If thunderbird-bin automatically terminates sooner or later if you wait for termination completion, or if no problem with profile on local disk, see Bug 488809.

If thunderbird-bin never terminates, does the problem occur always when you try to terminate Tb?
If "Never terminate" and "Not always", do you use IMAP?
Loop while terminating(CPU 100%)? Or Wait/Hang while terminating(CPU 0%)?
Does Suspend/Resume(or Sleep/Wakeup) look relevant to your problem?

> Before I can start Thunderbird again I need to kill that instance first,
> or remove the lock-file. In the latter case, starting TB is possible
> but now 2 instances of thunderbird-bin appear to be running. Closing
> Thunderbird in this case will only close the second instance of thunderbird-bin.

In the latter case, Tb looks to complete almost all termination processes except deletion of parent.lock, and it doesn't look to delete parent.lock when looping or hanging Tb is killed. "IMAP related both of Loop and Wait/Hang at end of termination process" is already known problem, but cause of problem is still not clear, although "IDLE related issue" is found in some cases.
(Reporter)

Comment 2

6 years ago
Hi M-Wada,
Thanks for replying. 

When I stop TB, Thunderbird-bin never terminates. It will *always* stay active.
The problem occurs *only* when the complete profile folder is located on a Samba share. TB works OK is only the actual Mail-folder is located on my NAS. Disadvantage in this case is that TB doesn't know which files are already loaded from my provider. 
I am using a POP3 account. (IMAP might be a better alternative for my needs though) 
I did an 'strace', see my first mail, and thunderbird seems to wait for a futex, it doesn't use any cpu cycles (0%)
I don't think sleep/resume has anything to do with the problem. The problem occurs both on my laptop and my desktop PC and I never closed my machine while trying to get this solved. ;-)
I tried to install the profile folder on my (remote) Linux server using Samba also. Having my profile on both the NAS or the server yields to the same result, a hanging thinderbird-bin. It's 100% reproducable (in my case).
All systems are Kubuntu based.
I hope this helps.
(In reply to Coen Blijker from comment #2)
> When I stop TB, Thunderbird-bin never terminates. It will *always* stay active.
> The problem occurs *only* when the complete profile folder is located on a samba share. 
> TB works OK is only the actual Mail-folder is located on my NAS.

What is SMB version which your samba uses? SMB2? (See bug 545650 for problem due to bug of SMB2 of MS.)
(Reporter)

Comment 4

6 years ago
I can't tell what Samba version is running on my NAS but my client is running Kubuntu 11.10 (which is the latest version). My server is running Kubuntu 11.04. Both have Samba 3.5 installed.
As said, the problem occurs also if the profiles folder is put on the server.
By the way, no MS machines are involved in this issue.. I prefer to be 'linux only' ;-)
Severity: normal → critical
Keywords: hang
Whiteboard: [dupeme?]
Coen, do you still see this shutdown hang using a current version? (looks like you were previously using roughly version 9 code?)

And if you do see it, please provide a stacktrace with thunderbird symbols. see https://developer.mozilla.org/En/How_to_get_a_stacktrace_for_a_bug_report

(I no longer remember what I thought this might dup to)
Whiteboard: [dupeme?] → [needs stacktrace][dupeme?]
(Reporter)

Comment 6

6 years ago
Hi Wayne Mery,

This problem is no longer an issue for me because I recently installed an imap server and TB works flawless with this server (dovecot). 

So, as far as I am concerned you can ignore this bug.

Kind regards,

Coen
thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE
Summary: thunderbird-bin keeps on running after close when profile on NAS → thunderbird-bin keeps on running after close (shutdown) when profile on NAS
You need to log in before you can comment on or make changes to this bug.