AMO search for name_of_addon sometimes doesn't find that add-on

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
7 years ago
3 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

7 years ago
I was just trying to find the "ViewAbout" add-on for thunderbird, so I searched AMO:
  https://addons.mozilla.org/en-US/thunderbird/search/?q=viewabout
and got no results.

Then I found the direct URL somewhere else on the web:
  https://addons.mozilla.org/en-US/thunderbird/addon/viewabout/
and I confirmed that the add-on still exists and works fine.  However, an AMO search for "viewabout" still doesn't return anything.

So, it would seem that AMO search is broken...
(Reporter)

Comment 1

7 years ago
wha... and now all of a sudden it works (using the URL from comment 0 that didn't work just 5 minutes ago)

Perhaps some internal search database was offline or being rebuilt or something?

Anyway, resolving WFM.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Comment 2

7 years ago
dholbert, you are not nuts. I have had mixed results with AMO search
(Reporter)

Comment 3

7 years ago
(In reply to Wayne Mery (:wsmwk) from comment #2)
> dholbert, you are not nuts.

Thank you for the confirmation of that. :)
(Reporter)

Comment 4

7 years ago
...and now an AMO search for "Greasemonkey" doesn't find Greasemonkey, even though it's listed on the front page as one of the most popular addons and is available here:
  https://addons.mozilla.org/en-US/firefox/addon/greasemonkey/

Reopening as an intermittent problem.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Summary: AMO search for "viewabout" doesn't find thunderbird addon called "ViewAbout" → AMO search for name_of_addon sometimes doesn't find that add-on
This isn't an intermittent problem, this is a search trying to be smarter than you problem.  Look at the filters on the left side - if greasemonkey isn't compatible with your browser it won't show up by default.  If you remove the app version restriction it's the first hit:

https://addons.mozilla.org/en-US/firefox/search/?q=greasemonkey&platform=all&appver=

Your concern is a valid UX bug but can you file a new bug rather than reopening an old one?  Thanks.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → WORKSFORME

Comment 6

7 years ago
> Your concern is a valid UX bug but can you file a new bug rather than
> reopening an old one?  Thanks.

There is an existing bug for this. Please see bug 692540.
(Reporter)

Comment 7

7 years ago
(In reply to Wil Clouser [:clouserw] from comment #5)
> if greasemonkey
> isn't compatible with your browser it won't show up by default.  If you
> remove the app version restriction it's the first hit:

Ok, that does seem to be the case for Greasemonkey -- thanks.

Note that for the Thunderbird add-on "ViewAbout" that I initially filed this bug for, comment 5 doesn't explain it (because I was searching for a *thunderbird* add-on, so my Firefox version shouldn't affect the search)...  In that instance, the exact URL from comment 0 returned no results at one point, and then did return a result 5 minutes later. (as noted in comment 1)

So, that's still mysterious.  WORKSFORME is appropriate at this point, though, anyway.
(Reporter)

Comment 8

7 years ago
Aha! I think I figured out what was originally behind this bug, when I filed it.

Apparently searches for *Thunderbird* addons are filtered according to my *Firefox* version-number.  That's pretty clearly incorrect.  I've now filed bug 715968 to track that issue.
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.