FATAL EXCEPTION: main BadTokenException: Unable to add window -- token android.os.BinderProxy@41348778 is not valid; is your activity running?

VERIFIED FIXED

Status

P1
critical
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: aaronmt, Assigned: Harald)

Tracking

Details

(Reporter)

Description

7 years ago
W/dalvikvm(12263): threadid=1: thread exiting with uncaught exception (group=0x409e01f8)
W/WindowManager(  132): Attempted to add application window with unknown token ActivityRecord{412ca118 org.mozilla.labs.Soup/.app.AppActivity}.  Aborting.
E/AndroidRuntime(12263): FATAL EXCEPTION: main
E/AndroidRuntime(12263): android.view.WindowManager$BadTokenException: Unable to add window -- token android.os.BinderProxy@41348778 is not valid; is your activity running?
E/AndroidRuntime(12263): 	at android.view.ViewRootImpl.setView(ViewRootImpl.java:490)
E/AndroidRuntime(12263): 	at android.view.WindowManagerImpl.addView(WindowManagerImpl.java:279)
E/AndroidRuntime(12263): 	at android.view.WindowManagerImpl.addView(WindowManagerImpl.java:193)
E/AndroidRuntime(12263): 	at android.view.WindowManagerImpl$CompatModeWrapper.addView(WindowManagerImpl.java:118)
E/AndroidRuntime(12263): 	at android.view.Window$LocalWindowManager.addView(Window.java:532)
E/AndroidRuntime(12263): 	at android.app.Dialog.show(Dialog.java:269)
E/AndroidRuntime(12263): 	at android.app.AlertDialog$Builder.show(AlertDialog.java:910)
E/AndroidRuntime(12263): 	at com.phonegap.DroidGap$GapClient.onJsPrompt(DroidGap.java:1134)
E/AndroidRuntime(12263): 	at android.webkit.CallbackProxy.handleMessage(CallbackProxy.java:594)
E/AndroidRuntime(12263): 	at android.os.Handler.dispatchMessage(Handler.java:99)
E/AndroidRuntime(12263): 	at android.os.Looper.loop(Looper.java:137)
E/AndroidRuntime(12263): 	at android.app.ActivityThread.main(ActivityThread.java:4215)
E/AndroidRuntime(12263): 	at java.lang.reflect.Method.invokeNative(Native Method)
E/AndroidRuntime(12263): 	at java.lang.reflect.Method.invoke(Method.java:511)
E/AndroidRuntime(12263): 	at com.android.internal.os.ZygoteInit$MethodAndArgsCaller.run(ZygoteInit.java:784)
E/AndroidRuntime(12263): 	at com.android.internal.os.ZygoteInit.main(ZygoteInit.java:551)
E/AndroidRuntime(12263): 	at dalvik.system.NativeStart.main(Native Method)
W/ActivityManager(  132):   Force finishing activity org.mozilla.labs.Soup/.app.LauncherActivity

--
STR: Launch one of the supplied web apps, and then hit back and launch again.

Samsung Nexus S (Android 4.0)
origin/HEAD (6e9a13a)
(Reporter)

Updated

7 years ago
Blocks: 702168
This should be fixed in the latest version of Soup, please retry and change status if you can still reproduce it.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

7 years ago
Please don't resolve bugs without explicit links to check-ins into the project.

This still occurs with origin/HEAD 6e9a13a
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Updated

7 years ago
Severity: normal → critical
(Reporter)

Updated

7 years ago
Priority: -- → P1
Blocks: 698883
No longer blocks: 702168
Severity: critical → normal
Priority: P1 → --
Severity: normal → critical
Priority: -- → P1
(Assignee)

Comment 3

7 years ago
I could not reproduce anymore on the devices I have after tweaking a few phonegap settings (like disabling to load pages in the background). Please confirm.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 4

7 years ago
Verified Fixed
origin/HEAD 5e17ba
Samsung Galaxy SII (Android 2.3.4)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.