Closed Bug 702216 Opened 8 years ago Closed 8 years ago

Menu > Quit doesn't close Fennec

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set

Tracking

()

VERIFIED FIXED

People

(Reporter: xti, Assigned: blassey)

References

Details

(Keywords: regression)

Attachments

(1 file, 1 obsolete file)

Mozilla/5.0 (Android;Linux armv7l;rv:10.0a1)Gecko/20111113
Firefox/10.0a1 Fennec/10.0a1
Devices: Motorola Droid 2
OS: Android 2.3.3

Steps to reproduce:
1. Open Fennec app
2. Tap on device Menu button
3. Tap on More > Quit

Expected result:
After step 3, the app is closed and the Fennec process will be stopped.

Actual result:
After step 3, nothing happens. The app menu triggered at step 2 still remains displayed on the screen.
Keywords: regression
Assignee: nobody → doug.turner
Blocks: 700675
Attached patch patch v.1 (obsolete) — Splinter Review
Android apps don't typically have a Quit menu.  Remove it, and close all of the bugs related to "quit not working right"
Note, atm there is no way to close Native Fennec. The Back button doesn't do it, like it does
in the stock browser. (I'm not sure if Back button just hides stock browser)
Attachment #574699 - Flags: review?(blassey.bugs)
Comment on attachment 574699 [details] [diff] [review]
patch v.1

Review of attachment 574699 [details] [diff] [review]:
-----------------------------------------------------------------

remove the "Browser:Quit" handler in browser.js and the image from drawables
Attachment #574699 - Flags: review?(blassey.bugs) → review-
Attached patch patch v.2Splinter Review
no drawables for quit.
Attachment #574699 - Attachment is obsolete: true
Attachment #574993 - Flags: review?(blassey.bugs)
Comment on attachment 574993 [details] [diff] [review]
patch v.2

Review of attachment 574993 [details] [diff] [review]:
-----------------------------------------------------------------

looking at this patch, I realize why quit isn't working and its because the logic that handles it got bashed by one of mfinkle's pushes (http://hg.mozilla.org/projects/birch/rev/043d1443dbc2).

Our justification for removing this is "we just can't get it to work right," which doesn't seem to hold water. Let's fix mfinkle's push and get this feature back in.
Attachment #574993 - Flags: review?(blassey.bugs) → review-
Assignee: doug.turner → blassey.bugs
(In reply to Brad Lassey [:blassey] from comment #6)
> Let's fix mfinkle's push and get this
> feature back in.
Thank you.
pushed https://hg.mozilla.org/projects/birch/rev/75c427dc76f9
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Samsung Nexus S (Android 2.3.6)
20111117040329
http://hg.mozilla.org/projects/birch/rev/d7fa4814218d
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.