Last Comment Bug 702223 - nsXMLHttpRequest::GetResponse duplicates quickstub code
: nsXMLHttpRequest::GetResponse duplicates quickstub code
Status: RESOLVED FIXED
[qa-]
:
Product: Core
Classification: Components
Component: DOM (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla11
Assigned To: :Ms2ger (⌚ UTC+1/+2)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-14 02:56 PST by :Ms2ger (⌚ UTC+1/+2)
Modified: 2013-04-04 13:53 PDT (History)
4 users (show)
Ms2ger: in‑testsuite-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (1.67 KB, patch)
2011-11-14 02:56 PST, :Ms2ger (⌚ UTC+1/+2)
bzbarsky: review+
Details | Diff | Splinter Review

Description :Ms2ger (⌚ UTC+1/+2) 2011-11-14 02:56:45 PST
Created attachment 574266 [details] [diff] [review]
Patch v1

Except it doesn't handle the case where XPCStringConvert::ReadableToJSVal returns null.
Comment 1 Masatoshi Kimura [:emk] 2011-11-14 03:36:35 PST
Is it correct including XPCQuickStubs.h outside the quickstub?
Comment 2 Olli Pettay [:smaug] 2011-11-14 03:40:21 PST
xpc_qsStringToJsval is used elsewhere already, and I don't see any reasons why not use it in XHR.
Comment 3 Masatoshi Kimura [:emk] 2011-11-14 04:03:55 PST
Although xpcprivate.h is already used outside the xpconnect, there exists bug 691463.
Comment 4 :Ms2ger (⌚ UTC+1/+2) 2011-11-14 04:14:25 PST
Yep, and that bug is the reason I was checking if XHR needed to use XPCConvert.
Comment 5 Boris Zbarsky [:bz] 2011-11-14 11:17:39 PST
Comment on attachment 574266 [details] [diff] [review]
Patch v1

r=me.  Yay code removal.
Comment 6 :Ms2ger (⌚ UTC+1/+2) 2011-11-16 10:18:03 PST
https://hg.mozilla.org/mozilla-central/rev/178a3e2dc3f0

Note You need to log in before you can comment on or make changes to this bug.