Closed Bug 702245 Opened 9 years ago Closed 9 years ago

Accessibility - foreground and background colours

Categories

(Calendar :: General, defect)

Lightning 1.1
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 671119

People

(Reporter: bjl, Unassigned)

Details

Attachments

(1 file)

Attached image lightning.png
User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.24) Gecko/20111103 Firefox/3.6.24
Build ID: 20111103063747

Steps to reproduce:

Set Windows to display white text on a black backround


Actual results:

Text not visible in several places in the Lightning interface


Expected results:

It is good practice that when setting a foerground colour that a background colour is also set, and vice versa. If this is not done than you cannot guarantee the interface will be visible to users, such as the visually impaired, who may change their colour settings as I do. More info can be found at: http://www.w3.org/TR/WCAG-TECHS/F24.html

Years ago I reported such a problem with the Minimonth pane (bug #435096) which still has not been fixed.

This is a general plea to please please abide by this accessibility guideline. Attached is a screen shot showing where this guideline has been broken in the Lightning interface.

In the screen shot I set Windows text to be lime green against a blue background. To obide by the guideline you should never see lime green text against a non blue background - this would indicate where the background has been set but not the text colour. Nor shoud you see a blue background where the text is not lime green - this would indicate where the text colour has been set but not the background colour.

You will also note that there is a section where there is lime green text on blue. Although this obeys the guidline it shows an inconsistant apporack to the user interface. Please either set both foreground and background, or neither. But don't mix and match on different parts of the same interface.

It would be very nice if Lightning took it's forground (text) and background colours from those set in the Thunderbird options but I don't know how simiple that would be to implement.

Thanks.
Summary: Accessibility - foreground anf background colours → Accessibility - foreground and background colours
Please, see bug 671119 it should cover this issue.
The screen shots showing the problem certainly look similar but this is for MS Windows not Linux - so is it a different devel branch?
... sorry yes. I see the sample screenshot are for multiple OS's so there's so seperation in devel branch.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 671119
You need to log in before you can comment on or make changes to this bug.