Last Comment Bug 702349 - On Mac the background of the individual test pilot studies is transparent
: On Mac the background of the individual test pilot studies is transparent
Status: RESOLVED FIXED
[testpilot]
:
Product: Thunderbird
Classification: Client Software
Component: Mail Window Front End (show other bugs)
: Trunk
: All All
: -- normal (vote)
: Thunderbird 11.0
Assigned To: Mike Conley (:mconley) - (Needinfo me!)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-14 10:58 PST by Mark Banner (:standard8)
Modified: 2011-11-16 02:53 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
+
fixed
fixed


Attachments
Patch v1 (680 bytes, patch)
2011-11-14 17:58 PST, Mike Conley (:mconley) - (Needinfo me!)
squibblyflabbetydoo: review+
standard8: approval‑comm‑aurora+
Details | Diff | Review

Description Mark Banner (:standard8) 2011-11-14 10:58:12 PST
On Mac, if you have a test pilot study listed, and you view the details of the study, you get a page with a transparent background.

We need to fix this before shipping test pilot.

Mike, could you take a look at this please?
Comment 1 Mike Conley (:mconley) - (Needinfo me!) 2011-11-14 11:06:47 PST
Do you have steps to reproduce?  On OSX, when bringing up user studies, I'm stuck at a "Loading, please wait..." message.

Is there a test study server that I should be pointing to?
Comment 2 Mike Conley (:mconley) - (Needinfo me!) 2011-11-14 12:00:44 PST
Hrm, unable to reproduce, since I cannot seem to get past the "Loading, please wait" screen.

I did see it reproduced on Blake's machine, but until I get it happening locally, I don't think I'll be much use on this bug.
Comment 3 Mike Conley (:mconley) - (Needinfo me!) 2011-11-14 15:04:05 PST
Ok, got things sorted out with squib, and I can reproduce.  Assigning to self.
Comment 4 Mike Conley (:mconley) - (Needinfo me!) 2011-11-14 17:58:36 PST
Created attachment 574491 [details] [diff] [review]
Patch v1

Found the problem - missing semi-colon.  Locally tested - background is now nice and white.
Comment 5 Jim Porter (:squib) 2011-11-14 19:10:26 PST
Comment on attachment 574491 [details] [diff] [review]
Patch v1

Ah ha! Looks good to me.
Comment 6 Mike Conley (:mconley) - (Needinfo me!) 2011-11-15 06:30:24 PST
Pushed to comm-central as: http://hg.mozilla.org/comm-central/rev/67d404aad8a7

Pushed to comm-aurora as: http://hg.mozilla.org/releases/comm-aurora/rev/8b8a00804661

Pushed to comm-beta as: http://hg.mozilla.org/releases/comm-beta/rev/d540d1739287

Note You need to log in before you can comment on or make changes to this bug.