Last Comment Bug 702407 - The "fake display port" hack is breaking sites
: The "fake display port" hack is breaking sites
Status: RESOLVED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P1 normal (vote)
: ---
Assigned To: Patrick Walton (:pcwalton)
:
: Sebastian Kaspari (:sebastian)
Mentors:
Depends on: 699351
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-14 13:07 PST by Patrick Walton (:pcwalton)
Modified: 2012-01-09 14:56 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
Proposed patch. (3.36 KB, patch)
2011-11-14 13:07 PST, Patrick Walton (:pcwalton)
no flags Details | Diff | Splinter Review
Proposed patch, version 2. (3.42 KB, patch)
2011-11-14 13:09 PST, Patrick Walton (:pcwalton)
bugmail: review+
Details | Diff | Splinter Review

Description Patrick Walton (:pcwalton) 2011-11-14 13:07:51 PST
Created attachment 574387 [details] [diff] [review]
Proposed patch.

The "fake display port" hack will break sites because it monkey patches content CSS. This patch removes it.
Comment 1 Patrick Walton (:pcwalton) 2011-11-14 13:08:26 PST
NB: This depends on bug 699351.
Comment 2 Patrick Walton (:pcwalton) 2011-11-14 13:09:40 PST
Created attachment 574388 [details] [diff] [review]
Proposed patch, version 2.

Oops, uploaded a bad version of the patch.
Comment 3 Kartikaya Gupta (email:kats@mozilla.com) 2011-11-14 13:10:29 PST
Comment on attachment 574387 [details] [diff] [review]
Proposed patch.

>     let data = JSON.parse(aData);
>+    let browser = this.selectedBrowser;
>+    browser.scrollTo(data.x, data.y);

Should this be browser.contentWindow.scrollTo?
Comment 4 Kartikaya Gupta (email:kats@mozilla.com) 2011-11-15 09:27:04 PST
http://hg.mozilla.org/projects/birch/rev/978e96c62262

Note You need to log in before you can comment on or make changes to this bug.