Last Comment Bug 702477 - Change the names of nsSVGPathElement::GetScale and nsSVGTextPathFrame::GetPathScale
: Change the names of nsSVGPathElement::GetScale and nsSVGTextPathFrame::GetPat...
Product: Core
Classification: Components
Component: SVG (show other bugs)
: Trunk
: All All
-- normal (vote)
: mozilla11
Assigned To: Jonathan Watt [:jwatt]
: Jet Villegas (:jet)
Depends on:
  Show dependency treegraph
Reported: 2011-11-14 16:14 PST by Jonathan Watt [:jwatt]
Modified: 2012-02-01 14:00 PST (History)
1 user (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---

patch (6.75 KB, patch)
2011-11-14 16:14 PST, Jonathan Watt [:jwatt]
longsonr: review+
Details | Diff | Splinter Review

Description User image Jonathan Watt [:jwatt] 2011-11-14 16:14:58 PST
Created attachment 574472 [details] [diff] [review]

The method names nsSVGPathElement::GetScale and nsSVGTextPathFrame::GetPathScale (especially the former) are less than helpful. Here's a patch to give them better names and add some documenting comments.
Comment 1 User image Jonathan Watt [:jwatt] 2011-11-15 05:11:18 PST
Comment 2 User image Ed Morley [:emorley] 2011-11-15 11:49:14 PST

To save time/mistakes when merging, please could you set assignee + target milestone when landing on inbound (

Thanks :-)
Comment 3 User image Jonathan Watt [:jwatt] 2011-11-15 11:58:40 PST
Oops, will do, thanks.

Note You need to log in before you can comment on or make changes to this bug.