Closed Bug 702527 Opened 11 years ago Closed 10 years ago

excessive GC routines cause browser to lag.

Categories

(Firefox :: General, defect)

8 Branch
x86_64
Windows 7
defect
Not set
normal

Tracking

()

VERIFIED INCOMPLETE

People

(Reporter: chrcoluk, Unassigned)

Details

(Keywords: perf)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111104165243

Steps to reproduce:

I load my browser and the session which is currently 20 windows and 226 tabs, and initially the browsing is smooth.  


Actual results:

Then after a while (usually when firefox ram usage is over 750meg), things like scrolling pages, flash videos, animation on pages, and the gui itself start getting jerky, laggy, this is an old bug that has existed since firefox 3.


Expected results:

Smooth experience.

In firefox4 the behaviour was significantly improved, something was done in that release to reduce jerkyness at high ram usage, however firefox 4 also had extreme memory leaks and I suspect extra GC was added to firefox5 and newer to work around that and the jerkyness is back as a result.  I would like to see a debug version of firefox which has all GC stripped out and to see how well it runs out of curiosity, thats the easiest way to see if the GC is the cause of the problem, my belief is that eventually as ram usage goes up and up eventually the frequent GC are continously running in a loop and the app slows down.  I have filed previous bug reports but none have had any response.  The large report in ff3.6 which wasnt filed by me was controlled by the bartab addon which stopped working in firefox4.  So a solution to this problem may be to integrate bartab features into firefox. Which is auto unload idle tabs (but keep the tab on gui), allow manual unload of tabs, and have ability to always keep whitelisted tabs loaded.  Also its worth noting my configuration only loads one tab from each window at startup so only 20 tabs get loaded and the jerkyness starts before 40 get loaded.  Never are all 226 tabs loaded.
does it happen in version 11 stsarted in safe mdoe?
Keywords: perf
Whiteboard: [closeme 2012-04-15]
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2012-04-15]
Well running in safe mode makes the browser unfit for my use, as my plugins are required, and it seems an easy cop out to be constantly blaming plugins, I also actually only use a small amount of plugins as well.

adblock plus
noscript
tabmix plus
cookie monster
memory restart
status4ever
foxyproxy

Currently this is ff10 ESR build but I have noticed ff13 has improved cycle collector so I am now extremely tempted to try that version to see if the problems is resolved or at least improved up on.

What I dont like tho is the lack of configurability on the memory routines and why they cant be disabled, some of us have lots of ram where improved performance with higher memory usage is preferable.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.